nutch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "wilco sheh (JIRA)" <j...@apache.org>
Subject [jira] [Created] (NUTCH-1891) Can't run nutch2.3-snapshot on hadoop2.4.0 using gora0.5 and mongodb as backend datastore
Date Sun, 23 Nov 2014 03:58:12 GMT
wilco sheh created NUTCH-1891:
---------------------------------

             Summary: Can't run nutch2.3-snapshot on hadoop2.4.0 using gora0.5 and mongodb
as backend datastore
                 Key: NUTCH-1891
                 URL: https://issues.apache.org/jira/browse/NUTCH-1891
             Project: Nutch
          Issue Type: Bug
          Components: storage
    Affects Versions: 2.3
         Environment: nutch-2.3-snapshot, hadoop2.4,gora0.5 mongodb
            Reporter: wilco sheh
            Priority: Critical


java.lang.Exception: java.lang.IncompatibleClassChangeError: Found interface org.apache.hadoop.mapreduce.TaskAttemptContext,
but class was expected
    at org.apache.hadoop.mapred.LocalJobRunner$Job.runTasks(LocalJobRunner.java:462)
    at org.apache.hadoop.mapred.LocalJobRunner$Job.run(LocalJobRunner.java:522)
Caused by: java.lang.IncompatibleClassChangeError: Found interface org.apache.hadoop.mapreduce.TaskAttemptContext,
but class was expected
    at org.apache.gora.mapreduce.GoraOutputFormat.getRecordWriter(GoraOutputFormat.java:83)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message