nutch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Furkan KAMACI <furkankam...@gmail.com>
Subject Re: reg. help -Nutch in maven
Date Mon, 09 Jan 2017 19:21:46 GMT
Hi Ashok,

Don't hesitate to ask again if you have any problems. On the other hand,
you can ask on user list instead of dev list for such purposes.

Kind Regards,
Furkan KAMACI

On Mon, Jan 9, 2017 at 9:14 PM, ashok raj <ashokraj.info@gmail.com> wrote:

> Thank you so much Furkan.
> I will surely try it out both and come back.
> You saved my day! :)
>
> best wishes,
> -Ashok.
>
>
> On Tue, Jan 10, 2017 at 12:19 AM, Furkan KAMACI <furkankamaci@gmail.com>
> wrote:
>
>> Hi Ashok,
>>
>> Yes, it is the right patch to test. On the other hand, does excluding
>> dependency at ant/ivy works for you: http://ant.apache.org/ivy
>> /history/2.4.0/ivyfile/artifact-exclude.html
>>
>> Kind Regards,
>> Furkan KAMACI
>>
>> On Mon, Jan 9, 2017 at 8:04 PM, ashok raj <ashokraj.info@gmail.com>
>> wrote:
>>
>>> Thank you Furkan Kamaci for the response.
>>>
>>> In the jira there are many patches for maven, I guess this
>>> <https://issues.apache.org/jira/secure/attachment/12626867/NUTCH-1371-2x.patch>
is
>>> the right one? (which is just nutch in maven without plugins i guess).
>>>
>>> *Reg. ant for Elasticsearch 5.x:  *
>>> I updated ElasticIndexwriter.java to call ES 5.x, ES 5.x uses a bunch of
>>> jars, which I manually added in 'nutch/plugins/indexer-elastic5/ivy.xml'.
>>> When I try to run, it fails
>>> <https://discuss.elastic.co/t/es-5-transport-java-lang-nosuchmethoderror-io-netty-buffer-compositebytebuf-addcomponents/65267/3>,
>>> because two conflicting jars are there. If I remove any one of them,
>>> ClassnotFoundException is thrown.
>>> Trying to index content in ES 5 separately from java, works perfect in
>>> maven.
>>> I am stuck on this for days.
>>>
>>> -Ashok.
>>>
>>>
>>> On Mon, Jan 9, 2017 at 10:52 PM, Furkan KAMACI <furkankamaci@gmail.com>
>>> wrote:
>>>
>>>> Hi Ashok,
>>>>
>>>> Are you looking for this: https://issues.apache.or
>>>> g/jira/browse/NUTCH-1371 Could you elaborate what is the problem which
>>>> prevents you to use ant+ivy for your case?
>>>>
>>>> Kind Regards,
>>>> Furkan KAMACI
>>>>
>>>> On Mon, Jan 9, 2017 at 7:15 PM, ashok raj <ashokraj.info@gmail.com>
>>>> wrote:
>>>>
>>>>> Hi,
>>>>> Anyone have tried building Nutch 2.x in maven (/gradle)?
>>>>> I am trying to write plugin to connect Elasticsearch 5.x and ant+ivy
>>>>> doesn't support this.
>>>>>
>>>>> Thanks in advance,
>>>>> -Ashok.
>>>>>
>>>>
>>>>
>>>
>>
>

Mime
View raw message