ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthieu Riou" <matthieu.r...@gmail.com>
Subject Re: Trunk -- mvn Install-- Build Error
Date Sat, 06 Jan 2007 00:58:53 GMT
Another wrong dependency. Amazing how smooth a build can go as long as you
have a pretty full repository. Well, relatively smooth.

That's fixed, please update and try again.

On 1/5/07, victor panizza <victor.panizza@gmail.com> wrote:
>
> Thanks matthieu.
> now the follow error appear:
>
>
> [INFO]
> -------------------------------------------------------------------------
> ---
> [INFO] Building ODE :: BPEL Tests
> [INFO]    task-segment: [install]
> [INFO]
> -------------------------------------------------------------------------
> ---
> [INFO] [resources:resources]
> [INFO] Using default encoding to copy filtered resources.
> [INFO] snapshot org.apache.ode:ode-dao-jpa-ojpa-derby:2.0-SNAPSHOT:checking for
>  updates from intalio
> [INFO] snapshot org.apache.ode:ode-dao-jpa-ojpa-derby:2.0-SNAPSHOT:checking for
>  updates from ibiblio
> [INFO] snapshot org.apache.ode:ode-dao-jpa-ojpa-derby:2.0-SNAPSHOT:checking for
>  updates from apache-snapshots
> Downloading:
> http://pxe.intalio.org/public/maven2/org/apache/ode/ode-dao-jpa-ojp
> a-derby/2.0-SNAPSHOT/ode- dao-jpa-ojpa-derby-2.0-SNAPSHOT.pom
> [WARNING] Unable to get resource from repository intalio (
> http://pxe.intalio.org
> /public/maven2)
> Downloading:
> http://www.ibiblio.org/maven2/org/apache/ode/ode-dao-jpa-ojpa-derby
> /2.0-SNAPSHOT/ode-dao-jpa-ojpa-derby-2.0-SNAPSHOT.pom
> [WARNING] Unable to get resource from repository ibiblio (http://www.ibiblio.org
> /maven2)
> Downloading:
> http://people.apache.org/repo/m2-snapshot-repository/org/apache/ode
> /ode-dao-jpa-ojpa-derby/2.0-SNAPSHOT/ode-
> dao-jpa-ojpa-derby-2.0-SNAPSHOT.pom
> [WARNING] Unable to get resource from repository apache-snapshots (
> http://people
> .apache.org/repo/m2-snapshot-repository)
> Downloading:
> http://pxe.intalio.org/public/maven2/org/apache/ode/ode-dao-jpa-ojp
> a-derby/2.0-SNAPSHOT/ode-dao-jpa-ojpa-derby-2.0-SNAPSHOT.jar
> [WARNING] Unable to get resource from repository intalio (http://pxe.intalio.org
> /public/maven2)
> Downloading:
> http://www.ibiblio.org/maven2/org/apache/ode/ode-dao-jpa-ojpa-derby
> /2.0-SNAPSHOT/ode- dao-jpa-ojpa-derby-2.0-SNAPSHOT.jar
> [WARNING] Unable to get resource from repository ibiblio (
> http://www.ibiblio.org
> /maven2)
> Downloading:
> http://people.apache.org/repo/m2-snapshot-repository/org/apache/ode
> /ode-dao-jpa-ojpa-derby/2.0-SNAPSHOT/ode-
> dao-jpa-ojpa-derby-2.0-SNAPSHOT.jar
> [WARNING] Unable to get resource from repository apache-snapshots (
> http://people
> .apache.org/repo/m2-snapshot-repository)
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Failed to resolve artifact.
>
> Missing:
> ----------
> 1) org.apache.ode:ode-dao-jpa-ojpa-derby:jar:2.0-SNAPSHOT
>
>   Try downloading the file manually from the project website.
>
>   Then, install it using the command:
>       mvn install:install-file -DgroupId=org.apache.ode-DartifactId=ode-dao-jpa
> -ojpa-derby \
>           -Dversion=2.0-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file
>
>   Path to dependency:
>         1) org.apache.ode:ode-test:jar:2.0-SNAPSHOT
>         2) org.apache.ode:ode-dao-jpa-ojpa-derby:jar:2.0-SNAPSHOT
>
> ----------
> 1 required artifact is missing.
>
> for artifact:
>   org.apache.ode:ode-test:jar:2.0-SNAPSHOT
>
> from the specified remote repositories:
>   ibiblio (http://www.ibiblio.org/maven2),
>   central (http://repo1.maven.org/maven2),
>   intalio ( http://pxe.intalio.org/public/maven2),
>   ode (http://incubator.apache.org/ode/m2),
>   apache-snapshots ( http://people.apache.org/repo/m2-snapshot-repository
> ),
>   apache (http://cvs.apache.org/repository)
>
>
> [INFO]
> ------------------------------------------------------------------------
> [INFO] For more information, run Maven with the -e switch
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 5 minutes 40 seconds
> [INFO] Finished at: Fri Jan 05 19:45:37 EST 2007
> [INFO] Final Memory: 31M/58M
> [INFO]
> ------------------------------------------------------------------------
>
> C:\vpanizza\ode_working_copy>
>
>
>
> On 1/5/07, Matthieu Riou <matthieu.riou@gmail.com> wrote:
> >
> > A dependency declaration was missing in bpel-runtime so the build was
> > happening in the wrong order. Update and try again, it should be better.
> >
> > Matthieu
> >
> > On 1/5/07, victor panizza < victor.panizza@gmail.com> wrote:
> > >
> > > Hello all, Happy new year for everyone!!!!!
> > >
> > >
> > > I was trying to build an updated trunk working copy, but the next
> > error
> > > bellow appear.
> > >
> > > Any idea, plz let me know, and again, Happy new yer for everyone!!.
> > >
> > >
> > > [INFO] [resources:resources]
> > > [INFO] Using default encoding to copy filtered resources.
> > > [INFO] [compiler:compile]
> > > Compiling 140 source files to
> > > C:\vpanizza\ode_working_copy\bpel-runtime\target\c
> > > lasses
> > > [INFO] [resources:testResources]
> > > [INFO] Using default encoding to copy filtered resources.
> > > [INFO] [compiler:testCompile]
> > > [INFO] Not compiling test sources
> > > [INFO] [antrun:run {execution: default}]
> > > [INFO] Executing tasks
> > >
> > > test-db:
> > > [artifact:dependencies] An error has occurred while processing the
> > Maven
> > > artifac
> > > t tasks.
> > > [artifact:dependencies]  Diagnosis:
> > > [artifact:dependencies]
> > > [artifact:dependencies] Failed to resolve artifact.
> > > [artifact:dependencies]
> > > [artifact:dependencies] Missing:
> > > [artifact:dependencies] ----------
> > > [artifact:dependencies] 1)
> > > org.apache.ode:ode-jpa-ojpa-derby:tar:2.0-SNAPSHOT
> > > [artifact:dependencies]
> > > [artifact:dependencies]   Try downloading the file manually from the
> > > project
> > > web
> > > site.
> > > [artifact:dependencies]
> > > [artifact:dependencies]   Then, install it using the command:
> > > [artifact:dependencies]       mvn install:install-file -DgroupId=
> > > org.apache.ode
> > > -DartifactId=ode-jpa-ojpa-derby \
> > > [artifact:dependencies]           -Dversion=2.0-SNAPSHOT-Dpackaging=tar
> > > -Dfile=
> > > /path/to/file
> > > [artifact:dependencies]
> > > [artifact:dependencies]   Path to dependency:
> > > [artifact:dependencies]         1) unspecified:unspecified:jar:0.0
> > > [artifact:dependencies]         2)
> > > org.apache.ode:ode-jpa-ojpa-derby:tar:2.0-SNA
> > > PSHOT
> > > [artifact:dependencies]
> > > [artifact:dependencies] ----------
> > > [artifact:dependencies] 1 required artifact is missing.
> > > [artifact:dependencies]
> > > [artifact:dependencies] for artifact:
> > > [artifact:dependencies]   unspecified:unspecified:jar: 0.0
> > > [artifact:dependencies]
> > > [artifact:dependencies] from the specified remote repositories:
> > > [artifact:dependencies]   central (http://repo1.maven.org/maven2 )
> > > [artifact:dependencies]
> > > [artifact:dependencies]
> > > [artifact:dependencies]
> > > [INFO]
> > >
> > ------------------------------------------------------------------------
> > > [ERROR] BUILD ERROR
> > > [INFO]
> > >
> > ------------------------------------------------------------------------
> > > [INFO] Failed to resolve artifact.
> > >
> > > Missing:
> > > ----------
> > > 1) org.apache.ode:ode-jpa-ojpa-derby:tar:2.0-SNAPSHOT
> > >
> > >   Try downloading the file manually from the project website.
> > >
> > >   Then, install it using the command:
> > >       mvn install:install-file -DgroupId=
> > > org.apache.ode-DartifactId=ode-jpa-ojp
> > > a-derby \
> > >           -Dversion=2.0-SNAPSHOT -Dpackaging=tar -Dfile=/path/to/file
> > >
> > >   Path to dependency:
> > >         1) unspecified:unspecified:jar:0.0
> > >         2) org.apache.ode:ode-jpa-ojpa-derby:tar:2.0-SNAPSHOT
> > >
> > > ----------
> > > 1 required artifact is missing.
> > >
> > > for artifact:
> > >   unspecified:unspecified:jar:0.0
> > >
> > > from the specified remote repositories:
> > >   central ( http://repo1.maven.org/maven2)
> > >
> > >
> > > [INFO]
> > >
> > ------------------------------------------------------------------------
> > > [INFO] For more information, run Maven with the -e switch
> > > [INFO]
> > >
> > ------------------------------------------------------------------------
> > > [INFO] Total time: 1 minute 32 seconds
> > > [INFO] Finished at: Fri Jan 05 19:13:28 EST 2007
> > > [INFO] Final Memory: 26M/49M
> > > [INFO]
> > >
> > ------------------------------------------------------------------------
> > >
> > >
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message