ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Janne Savukoski" <ja...@savukoski.name>
Subject Re: Quartz commits and JobStoreJTA
Date Tue, 20 Mar 2007 12:43:57 GMT
Hi Matthieu,

Thanks for the link, I hadn't noticed that page. Yes, the OpenJPA worked fine.

The instruction page kind-of helped, but also introduced new problems,
mainly http://www.nabble.com/Jencks-2.0-and-Tranql-t2755967.html and
http://permalink.gmane.org/gmane.comp.java.servicemix.user/7076. I
believe those have nothing to do with Ode, but I've started pondering
if this servicemix+activemq+spring+geronimo+jencks+tranql -stack is
such a good setup after all. Seems pretty mixed up. I'll burn up a
little more time with the servicemix and if it won't start to bend, I
guess I could give OpenESB a try.


-janne


> From: "Matthieu Riou" <matthieu.riou@gmail.com>
>
> So how did you setup MySQL exactly, did you follow this little guide?
>
> http://incubator.apache.org/ode/using-a-jndi-datasource-under-servicemix-jbi.html
>
> Is it only quartz? Do you get something persisted by the store when you
> deploy a process?
>
> Also try to set the log4j category org.apache.ode.sql to DEBUG, all
> statements will be logged, including Quartz ones, which can help. The
> connection commit (which is not necessarily the tx commit) will be logged as
> well.
>
> There's no need for a synchronizer as the job store is the one committing
> the transactions here so there must be something weird happening there, the
> datasource not being aware of the transaction manager for example.
>
> Cheers,
> Matthieu
>
> On 3/19/07, Janne Savukoski <janne@savukoski.name> wrote:
> >
> > Hello guys!
> >
> > I'm having a little trouble with the Quartz stuff. The basic problem
> > is that the JobStoreJTA#storeJobAndTrigger(...) just doesn't produce
> > anything to the database. I've been debugging the system for the best
> > part of today and that's for sure now that the inserts are never
> > committed, which is the basic cause of the problem. I guess I have
> > some glitch somewhere in my settings and I'm just failing to spot it.
> >
> > Any ideas? I'm so totally out of those.
> >
> > I'm using JPA over MySQL, inside servicemix. Using XA-datasource
> > didn't have any effect.
> >
> >
> > I though the name JobStoreJTA suggested that there would be a
> > synchronization registered somewhere which would commit the db tx
> > along the JTA tx, but I couldn't spot any that kind of a mechanism.
> > And I really couldn't figure out where the commit should've happened.
> >
> > Thanks in advance!
> >
> > best, janne
> >
> >
> > ps. those nightly builds would be great. :) Maven isn't.
> >
>

Mime
View raw message