ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthieu Riou (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (ODE-170) Stale reference to servlet which has been removed from Axis2 1.3 - "Axis2RESTServlet"
Date Wed, 08 Aug 2007 19:24:59 GMT

     [ https://issues.apache.org/jira/browse/ODE-170?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Matthieu Riou resolved ODE-170.
-------------------------------

       Resolution: Fixed
    Fix Version/s: 1.1
         Assignee: Matthieu Riou

Patch applied.

> Stale reference to servlet which has been removed from Axis2 1.3 - "Axis2RESTServlet"
> -------------------------------------------------------------------------------------
>
>                 Key: ODE-170
>                 URL: https://issues.apache.org/jira/browse/ODE-170
>             Project: ODE
>          Issue Type: Bug
>          Components: Axis2 Integration
>    Affects Versions: 1.1
>         Environment: JDK 1.5.0_11
> Axis2 Distro
> Jetty 6.1.1 Servlet engine
> Latest trunk as 8/8/2007
> WinXPx64
>            Reporter: Richard Taylor
>            Assignee: Matthieu Riou
>            Priority: Minor
>             Fix For: 1.1
>
>         Attachments: diff.patch
>
>
> It appears there are some dirty references in the Ode web.xml to an Axis2 servlet class
that has been removed in Axis2 1.3.  There are two references
> to "AxisRESTServlet" in the web.xml in the "axis2-war" module.   Looking at
> the Axis2 1.3 source it appears that this servlet class no longer exists, I'm not sure
of the details.
> Tomcat 5.5 doesn't seem to complain about this fact when starting but Jetty
> 6 throws an exception and fails to start.   I have commented out these
> references to Axis2RESTServlet and things seem to load and run fine for me now.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message