ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthieu Riou (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (ODE-44) XPath10 does not appear to be working within ASSIGN
Date Thu, 09 Aug 2007 17:43:43 GMT

     [ https://issues.apache.org/jira/browse/ODE-44?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Matthieu Riou resolved ODE-44.
------------------------------

       Resolution: Fixed
    Fix Version/s:     (was: 1.1)
                   1.0-incubating
         Assignee: Matthieu Riou

I believe this has been fixed.

> XPath10 does not appear to be working within ASSIGN
> ---------------------------------------------------
>
>                 Key: ODE-44
>                 URL: https://issues.apache.org/jira/browse/ODE-44
>             Project: ODE
>          Issue Type: Bug
>          Components: BPEL Runtime
>    Affects Versions: 1.0-incubating
>            Reporter: Lance Waterman
>            Assignee: Matthieu Riou
>            Priority: Minor
>             Fix For: 1.0-incubating
>
>
> In working on the BPEL unit tests I ran into the following problem. It appears that ACTIVITY.getEvaluationContext()
is using this constructor: ExprEvaluationContextImpl(_scopeFrame,getBpelRuntimeContext()).
> and 
> XPath10ExpressionRuntime.createContext() is invoking ...
>     ContextSupport support = new ContextSupport(new JaxenNamespaceContextAdapter(oxpath.namespaceCtx),
>                                                 bpelSupport, bpelSupport, 
>                                                 new BpelDocumentNavigator(ctx.getRootNode()));
> Note: ctx.getRootNode() is returning null because the constructor above does not set
the attribute.
> Switched to XPath20 and things work fine.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message