ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Janne Savukoski" <ja...@savukoski.name>
Subject Re: Deploying precompiled processes
Date Tue, 28 Aug 2007 21:42:44 GMT
I have the deploy.xml there, but some xsd/wsdls may be missing.
However, from the code it strongly looks like the execution is aborted
if no bpels are found.

The relevant(?) two stack pointers are following:

org/apache/ode/store/DeploymentUnitDir.java:123
org/apache/ode/store/ProcessStoreImpl.java:165

and there the DeploymentUnitDir throws an exception; ProcessStoreImpl
never gets to 'du.scan()' at 172. After I manually skipped the
exception the deploy seemed to complete normally.



On 8/29/07, Alex Boisvert <boisvert@intalio.com> wrote:
> A pre-compiled process is only a replacement for the .bpel file.  I think
> you still need to include deploy.xml, and related WSDLs and XSDs.
>
> alex
>
> On 8/28/07, Janne Savukoski <janne@savukoski.name> wrote:
> >
> > Hello,
> >
> > I'm trying to deploy a unit with only precompiled (.cbp) files and my
> > futile attempt ends to a message "Directory xyzzy does not contain any
> > process!". I guess the commit 549966 with message "Deployment of empty
> > DUs shouldn't be allowed." may have something to do with this?) (See
> >
> > /bpel-store/src/main/java/org/apache/ode/store/DeploymentUnitDir.java:122.)
> > So, should it still be possible to deploy precompiled processes and
> > this is just a bug, or?
> >
> > Thanks!
> >
> > best, Janne

Mime
View raw message