ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sebastian Breier <breie...@studi.informatik.uni-stuttgart.de>
Subject Re: Building ODE
Date Tue, 05 Feb 2008 07:34:58 GMT
Hey,

It worked. Many thanks. :-)

I agree with the Debian devs - I don't exactly *love* putting stuff all
over my file system without my standard package manager... but I guess I
only have to uninstall using gem, then remove /usr/lib/ruby
& /usr/local/lib/site_ruby to have it cleaned again. ;)

Anyway, I have two things to note:
1) Maybe it's a mistake of mine, but you should definitely update
http://ode.apache.org/building-ode.html . I know time is sparse, but the
"buildr 1.2.4" requirement seems outdated - when I only had this
installed, rake stopped with "can't find buildr/antlr". Updating buildr
to the current version made it work.

2) I'm now stuck at a segfault when doing "rake". I'll attach the trace
to the end of my reply [1] (I thought about using a nopaste-Service, but
I want this to be archived).

Maybe it's a common occurence, or you notice anything... if not, I'll
gladly post a bug report so we can do some debugging off the list.

Thanks for helping thus far. :-)

Bye,
	Sebastian.

[1]
tomcat@Hal9000:~/Dokumente/Universität/DA/ode$ rake -t eclipse
(in /home/tomcat/Dokumente/Universität/DA/ode)
** Invoke buildr:initialize (first_time)
** Execute buildr:initialize
/home/tomcat/Dokumente/Universität/DA/ode/tasks/derby.rake:22:
Deprecated: please use Java.wrapper() instead
/home/tomcat/Dokumente/Universität/DA/ode/tasks/derby.rake:22:
Deprecated: use setup { |wrapper| ... } instead
** Invoke ode (first_time)
** Execute ode
** Invoke /usr/lib/jvm/java-6-sun/lib/tools.jar (first_time, not_needed)
**
Invoke /home/tomcat/.m2/repository/org/apache/openjpa/openjpa-all/0.9.7-incubating/openjpa-all-0.9.7-incubating.jar
(first_time, not_needed)
**
Invoke /home/tomcat/.m2/repository/commons-collections/commons-collections/3.1/commons-collections-3.1.jar
(first_time, not_needed)
**
Invoke /home/tomcat/.m2/repository/commons-dbcp/commons-dbcp/1.2.1/commons-dbcp-1.2.1.jar
(first_time, not_needed)
**
Invoke /home/tomcat/.m2/repository/commons-lang/commons-lang/2.1/commons-lang-2.1.jar (first_time,
not_needed)
**
Invoke /home/tomcat/.m2/repository/commons-pool/commons-pool/1.2/commons-pool-1.2.jar (first_time,
not_needed)
**
Invoke /home/tomcat/.m2/repository/javax/persistence/persistence-api/1.0/persistence-api-1.0.jar
(first_time, not_needed)
**
Invoke /home/tomcat/.m2/repository/org/apache/geronimo/specs/geronimo-j2ee-connector_1.5_spec/1.0/geronimo-j2ee-connector_1.5_spec-1.0.jar
(first_time, not_needed)
**
Invoke /home/tomcat/.m2/repository/org/apache/geronimo/specs/geronimo-jta_1.0.1B_spec/1.0/geronimo-jta_1.0.1B_spec-1.0.jar
(first_time, not_needed)
**
Invoke /home/tomcat/.m2/repository/net/sourceforge/serp/serp/1.11.0/serp-1.11.0.jar (first_time,
not_needed)
**
Invoke /home/tomcat/.m2/repository/net/java/dev/javacc/javacc/4.0/javacc-4.0.jar (first_time,
not_needed)
** Invoke /home/tomcat/.m2/repository/org/antlr/antlr/3.0/antlr-3.0.jar
(first_time, not_needed)
** Invoke /home/tomcat/.m2/repository/antlr/antlr/2.7.7/antlr-2.7.7.jar
(first_time, not_needed)
**
Invoke /home/tomcat/.m2/repository/org/antlr/stringtemplate/3.0/stringtemplate-3.0.jar (first_time,
not_needed)
**
Invoke /home/tomcat/.m2/repository/org/apache/ant/ant/1.7.0/ant-1.7.0.jar (first_time, not_needed)
**
Invoke /home/tomcat/.m2/repository/org/apache/ant/ant-launcher/1.7.0/ant-launcher-1.7.0.jar
(first_time, not_needed)
**
Invoke /home/tomcat/.m2/repository/xerces/xercesImpl/2.6.2/xercesImpl-2.6.2.jar (first_time,
not_needed)
**
Invoke /home/tomcat/.m2/repository/org/apache/ant/ant-trax/1.7.0/ant-trax-1.7.0.jar (first_time,
not_needed)
**
Invoke /home/tomcat/.m2/repository/org/apache/ant/ant-junit/1.7.0/ant-junit-1.7.0.jar (first_time,
not_needed)
**
Invoke /home/tomcat/.m2/repository/org/mortbay/jetty/jetty/6.1.3/jetty-6.1.3.jar (first_time,
not_needed)
**
Invoke /home/tomcat/.m2/repository/org/mortbay/jetty/jetty-util/6.1.3/jetty-util-6.1.3.jar
(first_time, not_needed)
**
Invoke /home/tomcat/.m2/repository/org/mortbay/jetty/servlet-api-2.5/6.1.3/servlet-api-2.5-6.1.3.jar
(first_time, not_needed)
**
Invoke /home/tomcat/.m2/repository/org/slf4j/slf4j-api/1.4.3/slf4j-api-1.4.3.jar (first_time,
not_needed)
**
Invoke /home/tomcat/.m2/repository/org/slf4j/slf4j-simple/1.4.3/slf4j-simple-1.4.3.jar (first_time,
not_needed)
**
Invoke /home/tomcat/.m2/repository/org/slf4j/jcl104-over-slf4j/1.4.3/jcl104-over-slf4j-1.4.3.jar
(first_time, not_needed)
** Invoke /usr/lib/ruby/gems/1.8/gems/buildr-1.2.10/lib/buildr/jetty
(first_time, not_needed)
**
Invoke /home/tomcat/.m2/repository/org/apache/derby/derby/10.1.2.1/derby-10.1.2.1.jar (first_time,
not_needed)
**
Invoke /home/tomcat/.m2/repository/org/apache/derby/derbytools/10.1.2.1/derbytools-10.1.2.1.jar
(first_time, not_needed)
** Invoke ode:axis2 (first_time)
** Execute ode:axis2
** Invoke ode:bpel-api (first_time)
** Execute ode:bpel-api
** Invoke ode:utils (first_time)
** Execute ode:utils
** Invoke ode:bpel-obj (first_time)
** Execute ode:bpel-obj
** Invoke ode:utils 
** Invoke ode:bpel-schemas (first_time)
** Execute ode:bpel-schemas
** Invoke ode:bpel-compiler (first_time)
** Execute ode:bpel-compiler
** Invoke ode:bpel-api 
** Invoke ode:bpel-obj 
** Invoke ode:bpel-schemas 
** Invoke ode:utils 
** Invoke ode:bpel-connector (first_time)
** Execute ode:bpel-connector
** Invoke ode:bpel-api 
** Invoke ode:bpel-api-jca (first_time)
** Execute ode:bpel-api-jca
** Invoke ode:bpel-api 
** Invoke ode:bpel-runtime (first_time)
** Execute ode:bpel-runtime
** Invoke ode:bpel-api 
** Invoke ode:bpel-compiler 
** Invoke ode:bpel-dao (first_time)
** Execute ode:bpel-dao
** Invoke ode:bpel-api 
** Invoke ode:bpel-obj 
** Invoke ode:bpel-schemas 
** Invoke ode:bpel-store (first_time)
** Execute ode:bpel-store
** Invoke ode:bpel-api 
** Invoke ode:bpel-compiler 
** Invoke ode:bpel-dao 
** Invoke ode:bpel-obj 
** Invoke ode:bpel-schemas 
** Invoke ode:dao-hibernate (first_time)
** Execute ode:dao-hibernate
** Invoke ode:bpel-api 
** Invoke ode:bpel-dao 
** Invoke ode:bpel-ql (first_time)
** Execute ode:bpel-ql
** Invoke ode:bpel-api 
** Invoke ode:bpel-compiler 
** Invoke ode:bpel-obj 
** Invoke ode:jacob (first_time)
** Execute ode:jacob
** Invoke ode:utils 
** Invoke ode:jacob-ap (first_time)
** Execute ode:jacob-ap
Segmentation fault (core dumped)

Am Montag, den 04.02.2008, 19:31 -0800 schrieb Matthieu Riou:
> Are you running Debian or Ubuntu? The Debian people don't like the fact the
> Gem bypasses their own package system so they Gem package you install
> through apt-get is somewhat broken. It never installs the binaries
> associated with Gems.
> 
> Try uninstalling Gem and reinstall it manually (it's pretty easy, just
> download it and run 'sudo ruby setup.rb'). That should fix your problem.
> 
> Matthieu
> 
> On Feb 4, 2008 11:30 AM, Sebastian Breier <
> breiersn@studi.informatik.uni-stuttgart.de> wrote:
> 
> > I get "command not found".
> >
> > I should point out that for rake to work at all, I had to install it
> > using my package manager; Doing "gem install rake" worked, but I only
> > get the rake command using my package manager.
> >
> > Maybe that's the reason buildr doesn't work? There's no command for it?
> > Unfortunately, my packaging system doesn't contain buildr.
> >
> > Is there any way to use the buildr command without installing something
> > through the package manager? Maybe call "ruby /var/lib/.../buildr.rb" or
> > something?
> >
> > Thanks,
> >        Sebastian.
> >
> > Am Montag, den 04.02.2008, 11:19 -0800 schrieb Alex Boisvert:
> > > Hi Sebastian,
> > >
> > > This is strange.  What do you get if you use the "buildr" command
> > instead?
> > >
> > > alex
> > >
> > >
> > > On 2/4/08, Sebastian Breier <breiersn@studi.informatik.uni-stuttgart.de>
> > > wrote:
> > > >
> > > > Hi,
> > > >
> > > > I tried building ODE, but it didn't work out. I have searched the web
> > > > and this list for advice, but couldn't find anything that matched my
> > > > situation; So I'm asking.
> > > >
> > > > I'm on Ubuntu Linux 7.10, using Ruby 1.8. I installed gem, rake and
> > > > buildr successfully: "gem list" lists
> > > >
> > > > buildr (1.2.4)
> > > >     A build system that doesn't suck
> > > >
> > > > Yet, when I call rake in the ode source dir, I get the following
> > error:
> > > >
> > > > tomcat@Hal9000:~/Dokumente/Universität/DA/ode$ rake
> > > > (in /home/tomcat/Dokumente/Universität/DA/ode)
> > > > rake aborted!
> > > > no such file to load -- buildr
> > > > /home/tomcat/Dokumente/Universität/DA/ode/Rakefile:18:in `require'
> > > > (See full trace by running task with --trace)
> > > >
> > > > I have checked that the buildr files are indeed
> > > > in /var/lib/gems/1.8/gems/buildr-1.2.4. The trace is no use because it
> > > > only lists what commands are being run to load the buildr file.
> > > >
> > > > It would be great if anybody could shed some light onto this. :-)
> > > >
> > > > Thanks,
> > > >         Sebastian.
> > > > --
> > > > Sebastian Breier <breiersn@studi.informatik.uni-stuttgart.de>
> > > > University of Stuttgart
> > > >
> > > >
> > --
> > Sebastian Breier <breiersn@studi.informatik.uni-stuttgart.de>
> > University of Stuttgart
> >
-- 
Sebastian Breier <breiersn@studi.informatik.uni-stuttgart.de>
University of Stuttgart

Mime
View raw message