ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthieu Riou" <matth...@offthelip.org>
Subject Re: Buildr upgrade (almost)
Date Tue, 01 Jul 2008 15:12:02 GMT
On Tue, Jul 1, 2008 at 7:56 AM, Dan Kearns <dan.kearns@gmail.com> wrote:

> Hi Folks,
>
> is this me or Ode? (buildr is 1.3.1.1)
>
> dan@mtop :-)buildr ode:package
> /usr/local/java/ode/odetrunk/tasks/derby.rake:22: Deprecated: See
> documentation for new way to access Java code.
> /usr/local/java/ode/odetrunk/tasks/derby.rake:22: Deprecated: Append to
> Java.classpath instead.
> (in /usr/local/java/ode/odetrunk, development)
> rake aborted!
> Failed to parse "2.3.0" due to:
> /usr/lib/ruby/site_ruby/1.8/rubygems/version.rb:89:in `match': can't
> convert
> Fixnum into String
> /usr/local/java/ode/odetrunk/Rakefile:23
> (See full trace by running task with --trace)
>

I think it's your RubyGems, probably a bit old. Try:

sudo gem update --system

Should work better. Enjoy the new IAPI ;)

Cheers,
Matthieu


>
>
> On Thu, Jun 19, 2008 at 12:25 PM, Matthieu Riou <matthieu@offthelip.org>
> wrote:
>
> > I've turned the big switch on yesterday, the trunk is on 1.3 now. You
> don't
> > need to do anything special, 1.3 should work directly without any special
> > option.
> >
> > The 1.1 branch is still on 1.2 and I think should stay this way (people
> > who've been building the branch have always been doing so on 1.2). So if
> > you
> > have both versions installed, to build the 1.1 branch, you'll have to do
> > for
> > example:
> >
> > buildr _1.2.10_ package TEST=no
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message