ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexis Midon (JIRA)" <j...@apache.org>
Subject [jira] Updated: (ODE-409) User properties are not applied to the HTTP method
Date Thu, 06 Nov 2008 15:41:50 GMT

     [ https://issues.apache.org/jira/browse/ODE-409?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Alexis Midon updated ODE-409:
-----------------------------

      Component/s:     (was: BPEL Runtime)
                   Axis2 Integration
    Fix Version/s: 1.3
          Summary: User properties are not applied to the HTTP method  (was: endpoint configuration
files not getting picked up)

I renamed this JIRA because the real issue is that the HttpParams carrying the user properties
are not applied to the HttpMethod instance.
The wiring is done after the creation of the HttpMethod.

Properties files are properly picked and handled. See org.apache.ode.axis2.EndpointConfigurationTest
[1]

HttpMethodConverter.java, line 190 [2] the charset is retrieved from the HttpMethod instance
but the user params have not been applied yet. The wiring is done in Httphelper.java, line
70 [3]

[1] http://svn.apache.org/viewvc/ode/branches/APACHE_ODE_1.X/axis2-war/src/test/java/org/apache/ode/axis2/EndpointConfigurationTest.java?view=log
[2] http://svn.apache.org/viewvc/ode/branches/APACHE_ODE_1.X/axis2/src/main/java/org/apache/ode/axis2/httpbinding/HttpMethodConverter.java?view=log
[3] http://svn.apache.org/viewvc/ode/branches/APACHE_ODE_1.X/axis2/src/main/java/org/apache/ode/axis2/httpbinding/HttpHelper.java?view=markup

> User properties are not applied to the HTTP method
> --------------------------------------------------
>
>                 Key: ODE-409
>                 URL: https://issues.apache.org/jira/browse/ODE-409
>             Project: ODE
>          Issue Type: Bug
>          Components: Axis2 Integration
>    Affects Versions: 1.2
>         Environment: ODE 1.2.1 (latest trunk build at this time); Websphere 6.1
>            Reporter: Chris Taylor
>            Assignee: Alexis Midon
>             Fix For: 1.3
>
>
> Per ODE endpoint configuration documentation, http://ode.apache.org/user-guide.html#UserGuide-EndpointConfiguration,
a *.endpoint configuration file in either the ode deployment's WEB-INF/conf folder or in a
given deployed process folder should be picked up (either periodically, or at least on start-up)
and properties set.  This appears not to be working, as properties set in appropriate files
are not overriding default settings.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message