ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kuba Nowakowski ...@touk.pl>
Subject Re: GSOC project ideas
Date Thu, 12 Mar 2009 20:34:45 GMT
Hi

extjs has some exceptions to gpl license so it might be not so bad if  
it already exists.

http://extjs.com/products/ux-exception.php
http://extjs.com/products/floss-exception.php

Kuba
ps. I'm not fan of using JavaScript libraries




Wiadomość napisana w dniu 2009-03-12, o godz. 21:11, przez Tammo van  
Lessen:

> Hi,
>
> The core of Oryx is AFAIK MIT licensed. It's just the editor part that
> uses extjs. For a debugger we'd only need a minimal Oryx server, which
> would be in this case also under MIT license (no extjs, no GPL). Gero
> may correct me if I'm wrong.
>
> So I don't see any license issues in that case.
>
> Best,
>  Tammo
>
> phan huy wrote:
>> Hmm, maybe I should wait for more responds from Oryx and AODE  
>> developers.
>>
>> 2009/3/13 Alex Boisvert <boisvert@intalio.com>
>>
>>> On Thu, Mar 12, 2009 at 12:39 PM, Ciaran <ciaranj@gmail.com> wrote:
>>>
>>>> I don't believe that EXTJS' license is compatible with the  
>>>> existing ODE
>>>> licenses? Would this not cause
>>>> you some issues ?
>>>
>>> It depends what is meant by "incompatible".  The GPLv3 is  
>>> compatible with
>>> ASLv2 although it is Apache policy to not distribute GPL'ed  
>>> software so
>>> it's
>>> wouldn't be a very good choice for this project.
>>>
>>> alex
>>>
>>
>
>
> -- 
> Tammo van Lessen - http://www.taval.de
>
>


Mime
View raw message