ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ciaran Jessup (JIRA)" <j...@apache.org>
Subject [jira] Created: (ODE-594) ODE DeploymentWebservice seems broken.
Date Thu, 23 Apr 2009 16:42:30 GMT
ODE DeploymentWebservice seems broken.
--------------------------------------

                 Key: ODE-594
                 URL: https://issues.apache.org/jira/browse/ODE-594
             Project: ODE
          Issue Type: Bug
          Components: Deployment
    Affects Versions: 1.3.1
         Environment: n/a
            Reporter: Ciaran Jessup
            Priority: Blocker
             Fix For: 1.3.1


As of the changes that went into https://issues.apache.org/jira/browse/ODE-591 the deployment
web service appears to be broken, any attemp to deploy will probably result in an exception
similar to : 

WARN - GeronimoLog.warn(96) | Invocation of operation deploy failed
org.apache.ode.axis2.OdeFault: Your message should contain an element named 'package' with
a 'zip' element
	at org.apache.ode.axis2.service.DeploymentWebService$DeploymentMessageReceiver.invokeBusinessLogic(DeploymentWebService.java:117)

This I believe is due to a namespace mis-match between what the code now expects and what
the WSDL exposes.  Please, please, please can we not change the WSDL at this point, but change
the code to match what is exposed :) ... There follows a small patch to make the code work
as the WSDL expects :)


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message