ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Buddhika Chamith De Alwis (JIRA)" <j...@apache.org>
Subject [jira] Created: (ODE-597) Faulty Message to Deployment Web Service wipes out process repository location
Date Sat, 25 Apr 2009 16:26:30 GMT
Faulty Message to Deployment Web Service wipes out process repository location
------------------------------------------------------------------------------

                 Key: ODE-597
                 URL: https://issues.apache.org/jira/browse/ODE-597
             Project: ODE
          Issue Type: Bug
          Components: Deployment
    Affects Versions: 1.3.2
            Reporter: Buddhika Chamith De Alwis
            Priority: Critical
             Fix For: 1.3.2


Currently a following type message with empty packageName, to the undeploy operation of the
DeploymentWebService will cause the process repository location to be deleted.

<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"><soap:Body>
<undeploy xmlns="http://www.apache.org/ode/deployapi">
	<packageName></packageName>
</undeploy>
</undeploy>
</soap:Body>
</soap:Envelope>

This will also later cause the DeploymentPoller to spit out a nullpointerException since the
process repository is no longer there.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message