ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Naoki Okitsu" <okit...@m2.gyao.ne.jp>
Subject RE: To run Main class
Date Mon, 22 Jun 2009 13:24:51 GMT
Hi,Matthieu

Can I ask you a help for executing Main java file?

I made eclipse development environment with referring.
(http://ode.apache.org/eclipse-ide.html)
When I built ode1.X,I used jdk1.5.
And I have been trying to execute Main java file.
But I encountered following problems.
-------------
Exception in thread "main" java.lang.IllegalArgumentException: LAUNCHER
FAILURE: A configuration file must be supplied as an argument.
	at org.apache.ode.utils.cli.Main.main(Main.java:44)
ERROR: JDWP Unable to get JNI 1.2 environment, jvm->GetEnv() return code =
-2
JDWP exit error AGENT_ERROR_NO_JNI_ENV(183):  [../../../src/share/back/util.
c:820]
------------
When I encounter those problems,I use jre1.6.

To solve those problems,I set below property files as an arguement.
1.C:\ode-1.X\utils\src\main\java\org\apache\ode\utils\Properties.java
2.C:\ode-1.X\bpel-epr\src\main\java\org\apache\ode\il\config\OdeConfigProper
ties.java
3.ode-init.zip(http://issues.apache.org/jira/browse/TUSCANY-1365)


But I encountered following problems.
1---
Exception in thread "main" java.lang.IllegalArgumentException: BOOTSTRAP
FAILURE: The configuration
fileC:\ode-1.X\utils\src\main\java\org\apache\ode\utils\Properties.java does
not set the org.apache.ode.utils.cli.Main.mainClass property.
	at org.apache.ode.utils.cli.Main.main(Main.java:64)
ERROR: JDWP Unable to get JNI 1.2 environment, jvm->GetEnv() return code =
-2
JDWP exit error AGENT_ERROR_NO_JNI_ENV(183):  [../../../src/share/back/util.
c:820]
---

2---
Exception in thread "main" java.lang.IllegalArgumentException: BOOTSTRAP
FAILURE: The configuration
fileC:\ode-1.X\bpel-epr\src\main\java\org\apache\ode\il\config\OdeConfigProp
erties.java does not set the org.apache.ode.utils.cli.Main.mainClass
property.
	at org.apache.ode.utils.cli.Main.main(Main.java:64)
ERROR: JDWP Unable to get JNI 1.2 environment, jvm->GetEnv() return code =
-2
JDWP exit error AGENT_ERROR_NO_JNI_ENV(183):  [../../../src/share/back/util.
c:820]
---

3---
Exception in thread "main" java.lang.IllegalArgumentException: BOOTSTRAP
FAILURE: The configuration fileC:\Users\okitsun\Desktop\ODE関係\ode-init.zip
does not set the org.apache.ode.utils.cli.Main.mainClass property.
	at org.apache.ode.utils.cli.Main.main(Main.java:64)
ERROR: JDWP Unable to get JNI 1.2 environment, jvm->GetEnv() return code =
-2
JDWP exit error AGENT_ERROR_NO_JNI_ENV(183):  [../../../src/share/back/util.
c:820]
---

I have tried for 1 month,but I am stuck.
What do these error messages mean?
Should I change my eclipse settings?

Thanks in advance!



> -----Original Message-----
> From: Matthieu Riou [mailto:matthieu.riou@gmail.com]
> Sent: Wednesday, June 03, 2009 12:20 AM
> To: dev@ode.apache.org
> Subject: Re: To run Main class
>
> On Sun, May 31, 2009 at 7:19 AM, Naoki Okitsu <okitsun@m2.gyao.ne.jp>
wrote:
>
> > Hi,everyone
> >
> > My name is naoki okitsu.
> > Does someone know how to execute Main class?
> >
> > I use apache-ode-sources-2.0-beta2.
> > There is Main java file in below directory.
> >
> >
> C:\apache-ode-sources-2.0-beta2\utils\src\main\java\org\apache\ode\uti
> ls\cli
> > I want to execute this file.
> >
>
> Those are just command line utilities, they won't really run ODE, is that
> what you want?
>
>
> >
> > I use eclipse 3.4.2.
> > To run Main class,I modified like this.
> > /*package org.apache.ode.utils.cli;*/
> >
> > But I encountered following error.
> > Exception in thread "main" java.lang.IllegalArgumentException: LAUNCHER
> > FAILURE:A configuration file must be supplied as an argument.   at
> > Main.main(Main.java:44)
> >
>
> The Main class is like a global starter, it takes a configuration file
> specifying the class to start and a few other things.
>
> Matthieu
>
>
> >
> > To supply configuration file,I imported following files.
> > deploy.xml
> > HelloWorld2.bpel
> > HelloWorld2.wsdl
> > testRequest.soap
> > These files are imported from
> > C:\apache-ode-war-2.0-beta2\examples\HelloWorld2.
> > But I could not run.
> >
> > If you knew how to build development enviroment,please tell me.
> > It is enough for you to point web site which appears this informations.
> >
> > Thanks in advance!
> >
> >
>
> No virus found in this incoming message.
> Checked by AVG - www.avg.com
> Version: 8.5.339 / Virus Database: 270.12.70/2177 - Release Date: 06/15/09
> 05:54:00

Mime
View raw message