ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ciaran <ciar...@gmail.com>
Subject Re: Problem building ODE
Date Mon, 01 Jun 2009 13:13:17 GMT
Fwiw, I use the following command to build ode_1xx branch:

   buildr TEST=no JAVADOC=off ode:package

Hope that helps :)
- cj.



On Mon, Jun 1, 2009 at 10:12 AM, Ian Harrigan <ianharrigan@hotmail.com>wrote:

> Hi all,
>
> Im having a real problem trying to build the ODE distribution. Im pretty
> sure I installed ruby correctly but when i try to run the command:
>
> rake package
>
> I get the following:
>
> RubyGem version error: rake(0.8.1 not >= 0.8.4)
> C:/TEMP/ode-trunk-1.3.1/trunk/rakefile:18
> (See full trace by running task with --trace)
>
> I then tried to update the gem via the command:
>
> gem install rake -v 0.8.4
>
> After which i get the following error:
>
> (in C:/TEMP/ode-trunk-1.3.1/trunk)
> rake aborted!
> can't activate rake (= 0.8.1), already activated rake-0.8.4]
> C:/TEMP/ode-trunk-1.3.1/trunk/rakefile:18
> (See full trace by running task with --trace)
>
> Below is a list of my installed gems, if anyone can see anything thats
> vastly wrong i would appreciate the help:
>
> *** LOCAL GEMS ***
>
> Antwrap (0.7.0)
>    A Ruby module that wraps the Apache Ant build tool. Antwrap can be
>    used to invoke Ant Tasks from a Ruby or a JRuby script.
>
> archive-tar-minitar (0.5.2)
>    Provides POSIX tarchive management from Ruby programs.
>
> builder (2.1.2)
>    Builders for MarkUp.
>
> buildr (1.3.1)
>    A build system that doesn't suck
>
> fxri (0.3.6)
>    Graphical interface to the RI documentation, with search engine.
>
> fxruby (1.6.12)
>    FXRuby is the Ruby binding to the FOX GUI toolkit.
>
> highline (1.4.0)
>    HighLine is a high-level command-line IO library.
>
> hoe (1.12.2)
>    Hoe is a simple rake/rubygems helper for project Rakefiles
>
> hpricot (0.6)
>    a swift, liberal HTML parser with a fantastic library
>
> log4r (1.0.5)
>    Log4r is a comprehensive and flexible logging library for Ruby.
>
> net-sftp (2.0.0)
>    A pure Ruby implementation of the SFTP client protocol
>
> net-ssh (2.0.1)
>    a pure-Ruby implementation of the SSH2 client protocol
>
> rake (0.8.4, 0.8.1)
>    Ruby based make-like utility.
>
> rjb (1.1.2)
>    Ruby Java bridge
>
> rspec (1.1.3)
>    RSpec-1.1.3 (build 20080131122909) - BDD for Ruby
>    http://rspec.rubyforge.org/
>
> rubyforge (1.0.3, 0.4.5)
>    A script which automates a limited set of rubyforge operations
>
> rubyzip (0.9.1)
>    rubyzip is a ruby module for reading and writing zip files
>
> sources (0.0.1)
>    This package provides download sources for remote gem installation
>
> win32-api (1.0.4)
>    A superior replacement for Win32API
>
> win32-clipboard (0.4.3)
>    A package for interacting with the Windows clipboard
>
> win32-dir (0.3.2)
>    Extra constants and methods for the Dir class on Windows.
>
> win32-eventlog (0.4.6)
>    Interface for the MS Windows Event Log.
>
> win32-file (0.5.4)
>    Extra or redefined methods for the File class on Windows.
>
> win32-file-stat (1.2.7)
>    A File::Stat class tailored to MS Windows
>
> win32-process (0.5.3)
>    Adds fork, wait, wait2, waitpid, waitpid2 and a special kill method
>
> win32-sapi (0.1.4)
>    An interface to the MS SAPI (Sound API) library.
>
> win32-sound (0.4.1)
>    A library for playing with sound on MS Windows.
>
> windows-api (0.2.0)
>    An easier way to create methods using Win32API
>
> windows-pr (0.7.2)
>    Windows functions and constants bundled via Win32::API
>
> xml-simple (1.0.11)
>    A very simple API for XML processing.
>
> Thanks in advance,
> Ian Harrigan

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message