ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill McCusker <wmccus...@parasoft.com>
Subject Re: No routes found for event handler
Date Wed, 08 Jul 2009 18:12:36 GMT
Hi all,

    I submitted a jira (https://issues.apache.org/jira/browse/ODE-634) 
for the various troubles being had with event handlers, messages not 
being received and conflicting receives. The short answer for what the 
problem was is that the message routes were not always being persisted 
and the conflicting receive was the result of a race condition. A 
potential patch is attached to the jira.

Bill McCusker

Bill McCusker wrote:
> It looks like when the event handler calls 
> org.apache.ode.dao.jpa.CorrelatorDAOImpl addRoute it is not being 
> persisted. Putting an explicit call to EntityManager flush resulted in 
> the query being able to find the route. However I have not been able 
> to discern why the receive activity's route is being persisted but not 
> event handlers.
>
> Anyone have any insight that might help explain this behavior?
>
> Bill McCusker wrote:
>> Hi,
>>
>> I have been trying to track down a problem with event handlers. When 
>> I send a message to an event handler the message ends up being saved 
>> to the database because no routes could be found. From debugging I 
>> can see that org.apache.ode.dao.jpa.CorrelatorDAOImpl addRoute is 
>> being called for the expected operation however when the inbound 
>> message is processed the query in findRoute returns an empty result 
>> set. Any ideas what might be causing this? Attached is the process 
>> and a soapUI test to reproduce.
>>
>> Bill McCusker
>
>


Mime
View raw message