ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Boisvert <boisv...@intalio.com>
Subject Re: Building ODE
Date Mon, 19 Oct 2009 13:38:59 GMT
Two workarounds:

1) Install Subversion and make sure the command 'svn' is available in your
PATH

2) Run "buildr ode:package" instead of "buildr package"  (this will package
everything but will not produce a distro)

alex


On Sun, Oct 18, 2009 at 4:46 PM, <arturslicis@inbox.lv> wrote:

> Hello all,
> Wanted to build Apache Ode, but I'm new to Ruby world.
> I followed the instructions found on Apache Ode page, but when
> building the trunk with latest buildr, I get the error message found
> below (also tried setting up buildr 1.3.1, and removing other
> versions, and even some more combinations..)
> Thanks in advance for any hints,
> Arturs
> D:ODE-src>buildr package
> (in D:/ODE-src, development)
> ←[34mD:/ODE-src/buildfile:549:in `__instance_exec0': Deprecated: We
> c
> hanged the way package_as methods are implemented.&#160; See the
> package method docum
> entation for more details.←[0m
> Buildr aborted!
> ←[31mNo such file or directory - svn status -v←[0m
> ←[31mD:/ODE-src/buildfile:734:in ``'←[0m
> ←[31mD:/ODE-src/buildfile:734:in `__instance_exec0'←[0m
> ←[31mD:/ODE-src/buildfile:732:in `__instance_exec0'←[0m
>
> ←[31mc:/ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/app
> lication.rb:400:in `raw_load_buildfile'←[0m
>
> ←[31mc:/ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/app
> lication.rb:218:in `load_buildfile'←[0m
>
> ←[31mc:/ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/app
> lication.rb:213:in `load_buildfile'←[0m
> (See full trace by running task with --trace)

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message