ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexis Midon (JIRA)" <j...@apache.org>
Subject [jira] Created: (ODE-700) deploy retires the oldest package, not the active one
Date Tue, 17 Nov 2009 00:35:39 GMT
deploy retires the oldest package, not the active one
-----------------------------------------------------

                 Key: ODE-700
                 URL: https://issues.apache.org/jira/browse/ODE-700
             Project: ODE
          Issue Type: Bug
    Affects Versions: 1.3.3, 1.3.2, 1.2
            Reporter: Alexis Midon


org.apache.ode.bpel.pmapi.ProcessManagement#setPackageRetired does not retire all the active
processes of previous package versions. Only the previous version (n-1) is retired.
Considering that the ProcessManagement API allows to activate the version n-2 of a process,
you can end up with 2 active versions of a given process.


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message