ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rafal Rusin <rafal.ru...@gmail.com>
Subject Re: buildr 1.x fail
Date Tue, 17 Nov 2009 19:29:11 GMT
Well, I'm not using windows, so it's hard to say.
But I'm using jruby 1.4.0 (ruby 1.8.7 patchlevel 174) with JDK 1.6 and
it works.
It's a pure java way (no need for generating native java extensions),
so you can try it.

I just needed to add a following patch in order to not have
uninitalized variable error:

diff --git a/tasks/nativedb.rake b/tasks/nativedb.rake
index f9193a8..6fff31a 100644
--- a/tasks/nativedb.rake
+++ b/tasks/nativedb.rake
@@ -16,6 +16,7 @@
 #

 SETTINGS = "#{File.expand_path('.buildr', ENV['HOME'])}/settings.rb"
+REQUIRES=""

 module NativeDB
 #


Let me know if it works.


2009/11/17 Andreas Fritzler <andreas.fritzler@googlemail.com>:
> I have the same issue here.
>
> Any ideas?
>
>
> 2009/11/17 Nowakowski, Mateusz <Mateusz.Nowakowski@sabre-holdings.com>:
>> Any reply on that?
>>
>> --
>> Regards
>> Mateusz Nowakowski
>>
>> -----Original Message-----
>> From: Nowakowski, Mateusz [mailto:Mateusz.Nowakowski@sabre-holdings.com]
>> Sent: Friday, November 13, 2009 11:36 AM
>> To: dev@ode.apache.org
>> Subject: buildr 1.x fail
>>
>> I've updated build to 1.3.5  and I have troubles with building ODE from 1.x branch:
>>
>>
>>
>> C:\ODE\sources\branches\1.x>ruby -v
>> ruby 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32]
>> C:\ODE\sources\branches\1.x>gem -v
>> 1.3.4
>> C:\ODE\sources\branches\1.x>gem list buildr
>>
>> *** LOCAL GEMS ***
>> buildr (1.3.5)
>> C:\ODE\sources\branches\1.x>echo %JAVA_HOME%
>> C:\Programs\Java\jdk1.5.0_07
>>
>> C:\ODE\sources\branches\1.x>java -version
>> java version "1.5.0_07"
>> Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_07-b03)
>> Java HotSpot(TM) Client VM (build 1.5.0_07-b03, mixed mode)
>>
>> C:\ODE\sources\branches\1.x>buildr _1.3.5_ package test=no
>> ←[34m./tasks/derby.rake:22: Deprecated: See documentation for new way to access
Java code.←[0m
>> ←[34m./tasks/derby.rake:22: Deprecated: Append to Java.classpath instead.←[0m
>> (in C:/ODE/sources/branches/1.x, development)
>> ←[34mC:/ODE/sources/branches/1.x/rakefile:492:in `__instance_exec0': Deprecated:
We changed the way package_as methods are implemented.  See the package method documentation
for more details.←[0m
>> Buildr aborted!
>> ←[31mprivate method `distro' called for project("apache-ode"):Buildr::Project←[0m
>> ←[31mC:/ODE/sources/branches/1.x/rakefile:618:in `__instance_exec0'←[0m
>> (See full trace by running task with --trace)
>>
>> With --trace the last fragment is:
>> (...)
>>
>> ** Invoke ode:jca-server
>> ** Invoke ode:jbi
>> ** Invoke ode:jacob-ap
>> ** Invoke ode:scheduler-simple
>> ** Invoke ode:bpel-api-jca
>> ** Invoke ode:axis2
>> ** Invoke ode:jca-ra
>> ** Invoke ode:bpel-ql
>> ** Invoke ode:bpel-obj
>> ** Invoke ode:tools
>> ** Invoke ode:bpel-runtime
>> ** Invoke apache-ode:distro (first_time)
>> ** Execute apache-ode:distro
>> Defining task apache-ode:distro:shell:bsh
>> Defining task apache-ode:distro:shell:jirb
>> Defining task apache-ode:distro:shell:clj
>> Buildr aborted!
>> ←[31mprivate method `distro' called for project("apache-ode"):Buildr::Project←[0m
>> C:/ODE/sources/branches/1.x/rakefile:618:in `__instance_exec0'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/util.rb:183:in
`send'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/util.rb:183:in
`instance_exec'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/project.rb:225:in
`define'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `call'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `execute'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `each'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `execute'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/project.rb:625:in
`execute'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/application.rb:146:in
`switch_to_namespace'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/project.rb:624:in
`execute'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/application.rb:630:in
`invoke_with_call_chain'
>> C:/Programs/Ruby/lib/ruby/1.8/monitor.rb:242:in `synchronize'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/application.rb:616:in
`invoke_with_call_chain'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/application.rb:611:in
`invoke'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/project.rb:230:in
`define'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `call'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `execute'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `each'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `execute'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/project.rb:625:in
`execute'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/application.rb:146:in
`switch_to_namespace'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/project.rb:624:in
`execute'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/application.rb:630:in
`invoke_with_call_chain'
>> C:/Programs/Ruby/lib/ruby/1.8/monitor.rb:242:in `synchronize'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/application.rb:616:in
`invoke_with_call_chain'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/application.rb:611:in
`invoke'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/util.rb:204:in
`__send__'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/util.rb:204:in
`to_proc'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/project.rb:281:in
`each'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/project.rb:281:in
`projects'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/project.rb:863:in
`projects'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/application.rb:400:in
`raw_load_buildfile'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/application.rb:218:in
`load_buildfile'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/application.rb:496:in
`standard_exception_handling'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/application.rb:213:in
`load_buildfile'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/application.rb:137:in
`run'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/application.rb:496:in
`standard_exception_handling'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/core/application.rb:135:in
`run'
>> C:/Programs/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/bin/buildr:19
>> C:/Programs/Ruby/bin/buildr:19:in `load'
>> C:/Programs/Ruby/bin/buildr:19
>>
>> Apart from that Apache ODE site still says that 1.2.10 should be used to build 1.x
branch.
>>
>> --
>> Regards
>> Mateusz Nowakowski
>>
>



-- 
Rafał Rusin
http://rrusin.blogspot.com
http://www.touk.pl
http://top.touk.pl

Mime
View raw message