ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Greg Lucas" <greg.lu...@gmail.com>
Subject Re: Build failed in Hudson: ODE-1.x #13
Date Thu, 19 Nov 2009 17:48:05 GMT
Tammo -

Yes, this is a change between buildr 1.3.5 and 1.4-SNAPSHOT (there was  
just some discussion on the buildr user list): In 1.3.5 tag_name is an  
instance method and in 1.4 a class method.

We could make the Rakefile handle either, I suppose? Or go back to 1.3.5  
but apply just the patch for 'test=all', which is what I've done locally.

~Greg


On Thu, 19 Nov 2009 11:25:06 -0500, Tammo van Lessen  
<tvanlessen@gmail.com> wrote:

> Hi,
>
> on hudson I'm currently running buildr trunk, so I'm not sure yet if
> it's a problem with 1.3.5, 1.4-SNAPSHOT or ODE's buildfile.
>
> Tammo
>
> Rafal Rusin wrote:
>> I think we need to post it to buildr Jira.
>> I recently posted some other issue related to buildr 1.3.5 + jruby
>> 1.4.0. So buildr 1.3.5 looks like not very stable release
>> (https://issues.apache.org/jira/browse/BUILDR-348).
>>
>> 2009/11/19 Greg Lucas <greg.lucas@gmail.com>:
>>>> undefined method `tag_name=' for #<Buildr::SvnRelease:0x2982d8>
>>> Anyone know what's up with this? I haven't been able to reproduce this
>>> problem.
>>>
>>>
>>> I do see a similar error building if there are no .svn/.git  
>>> directories, but
>>> in that case the error is for nil:NilClass. I was able to avoid that  
>>> with:
>>>
>>>
>>> Release.find.tag_name = lambda { |version|  
>>> "APACHE_ODE_#{version.upcase}" }
>>> if Release.find
>>>
>>>
>>> --
>>> Greg Lucas
>>>
>>
>>
>> Regards,
>


-- 
Greg Lucas

Mime
View raw message