ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Hudson Server <hud...@hudson.zones.apache.org>
Subject Build failed in Hudson: ODE-1.X-maven2 #41
Date Sat, 08 May 2010 08:54:27 GMT
See <http://hudson.zones.apache.org/hudson/job/ODE-1.X-maven2/41/changes>

Changes:

[rr] ODE-799: variable modification event does not have information about the variable value,
Thanks to Anurag Aggarwal

[rr] ODE-774: npe when something is mapped to message header part of variable (Thanks to Anurag
Aggarwal)

------------------------------------------
[...truncated 2996 lines...]

[HUDSON] Archiving <http://hudson.zones.apache.org/hudson/job/ODE-1.X-maven2/ws/APACHE_ODE_1.X/distro/src/examples-jbi/maven2/ping-pong-osgi/pom.xml>
to /export/home/hudson/hudson/jobs/ODE-1.X-maven2/modules/org.apache.ode.examples$ping-pong-bundle/builds/2010-05-08_06-02-08/archive/org.apache.ode.examples/ping-pong-bundle/1.3.4-SNAPSHOT/pom.xml
[HUDSON] Archiving <http://hudson.zones.apache.org/hudson/job/ODE-1.X-maven2/ws/APACHE_ODE_1.X/distro/src/examples-jbi/maven2/ping-pong-osgi/target/ping-pong-bundle-1.3.4-SNAPSHOT.jar>
to /export/home/hudson/hudson/jobs/ODE-1.X-maven2/modules/org.apache.ode.examples$ping-pong-bundle/builds/2010-05-08_06-02-08/archive/org.apache.ode.examples/ping-pong-bundle/1.3.4-SNAPSHOT/ping-pong-bundle-1.3.4-SNAPSHOT.jar
[INFO] ------------------------------------------------------------------------
[INFO] Building ODE :: Axis2 Based Web Application
[INFO]    task-segment: [clean, install]
[INFO] ------------------------------------------------------------------------
[INFO] [clean:clean {execution: default-clean}]
[INFO] Deleting directory <http://hudson.zones.apache.org/hudson/job/ODE-1.X-maven2/ws/APACHE_ODE_1.X/axis2-war/target>
[INFO] [site:attach-descriptor {execution: default-attach-descriptor}]
[INFO] [assembly:single {execution: war-package}]
[INFO] Reading assembly descriptor: src/main/assembly/bin.xml
[WARNING] POM for 'org.apache.axis2:axis2-adb:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-kernel:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-java2wsdl:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-jibx:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-saaj:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-xmlbeans:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-mtompolicy:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-corba:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-fastinfoset:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-jaxbri:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-jaxws:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-jaxws-api:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-json:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-jws-api:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-metadata:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-spring:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
Downloading: https://repository.apache.org/content/groups/public/woodstox/wstx-asl/3.2.4/wstx-asl-3.2.4.pom
[INFO] Unable to find resource 'woodstox:wstx-asl:pom:3.2.4' in repository servicemix-repo
(https://repository.apache.org/content/groups/public)
Downloading: http://people.apache.org/~rr/saxon-repo/woodstox/wstx-asl/3.2.4/wstx-asl-3.2.4.pom
[INFO] Unable to find resource 'woodstox:wstx-asl:pom:3.2.4' in repository saxon-repo (http://people.apache.org/~rr/saxon-repo)
Downloading: http://repo1.maven.org/maven2/woodstox/wstx-asl/3.2.4/wstx-asl-3.2.4.pom
[INFO] Unable to find resource 'woodstox:wstx-asl:pom:3.2.4' in repository central (http://repo1.maven.org/maven2)
[WARNING] POM for 'org.apache.axis2:axis2-mtompolicy:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-corba:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-fastinfoset:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-jaxbri:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-jaxws:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-jaxws-api:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-json:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-jws-api:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-metadata:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-spring:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] Cannot include project artifact: org.apache.ode:ode-axis2-war:pom:1.3.4-SNAPSHOT;
it doesn't have an associated file or directory.
[WARNING] The following patterns were never triggered in this artifact inclusion filter:
o  'org.apache.axis2:axis2-saaj-api'
o  'org.apache.geronimo.specs:geronimo-ejb_2.1_spec'
o  'org.apache.geronimo.specs:geronimo-annotation_1.0_spec'
o  'org.jibx:jibx-bind'
o  'org.codehaus.jettison:jettison'
o  'org.apache.httpcomponents:httpcore-nio'
o  'javax.xml.bind:jaxb-api'
o  'com.sun.xml.bind:jaxb-impl'
o  'com.sun.xml.bind:jaxb-xjc'
o  'xml-resolver:xml-resolver'

[WARNING] Cannot include project artifact: org.apache.ode:ode-axis2-war:pom:1.3.4-SNAPSHOT;
it doesn't have an associated file or directory.
[INFO] WEB-INF/ already added, skipping
[INFO] WEB-INF/ already added, skipping
[INFO] Building war: <http://hudson.zones.apache.org/hudson/job/ODE-1.X-maven2/ws/APACHE_ODE_1.X/axis2-war/target/ode-axis2-war-1.3.4-SNAPSHOT.war>
[INFO] WEB-INF/ already added, skipping
[INFO] WEB-INF/ already added, skipping
[WARNING] POM for 'org.apache.axis2:axis2-corba:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-fastinfoset:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-jaxbri:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-jaxws:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-jaxws-api:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-json:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-jws-api:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-metadata:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-spring:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[INFO] [surefire:test {execution: test-axis2-web}]
[INFO] No tests to run.
[HUDSON] Recording test results
[INFO] [install:install {execution: default-install}]
[INFO] Installing <http://hudson.zones.apache.org/hudson/job/ODE-1.X-maven2/ws/APACHE_ODE_1.X/axis2-war/pom.xml>
to /export/home/hudson/.m2/repository/org/apache/ode/ode-axis2-war/1.3.4-SNAPSHOT/ode-axis2-war-1.3.4-SNAPSHOT.pom
[INFO] Installing <http://hudson.zones.apache.org/hudson/job/ODE-1.X-maven2/ws/APACHE_ODE_1.X/axis2-war/target/ode-axis2-war-1.3.4-SNAPSHOT.war>
to /export/home/hudson/.m2/repository/org/apache/ode/ode-axis2-war/1.3.4-SNAPSHOT/ode-axis2-war-1.3.4-SNAPSHOT.war
[HUDSON] Archiving <http://hudson.zones.apache.org/hudson/job/ODE-1.X-maven2/ws/APACHE_ODE_1.X/axis2-war/pom.xml>
to /export/home/hudson/hudson/jobs/ODE-1.X-maven2/modules/org.apache.ode$ode-axis2-war/builds/2010-05-08_06-02-08/archive/org.apache.ode/ode-axis2-war/1.3.4-SNAPSHOT/pom.xml
[HUDSON] Archiving /export/home/hudson/.m2/repository/org/apache/ode/ode-axis2-war/1.3.4-SNAPSHOT/ode-axis2-war-1.3.4-SNAPSHOT.pom
to /export/home/hudson/hudson/jobs/ODE-1.X-maven2/modules/org.apache.ode$ode-axis2-war/builds/2010-05-08_06-02-08/archive/org.apache.ode/ode-axis2-war/1.3.4-SNAPSHOT/ode-axis2-war-1.3.4-SNAPSHOT.pom
[HUDSON] Archiving <http://hudson.zones.apache.org/hudson/job/ODE-1.X-maven2/ws/APACHE_ODE_1.X/axis2-war/target/ode-axis2-war-1.3.4-SNAPSHOT.war>
to /export/home/hudson/hudson/jobs/ODE-1.X-maven2/modules/org.apache.ode$ode-axis2-war/builds/2010-05-08_06-02-08/archive/org.apache.ode/ode-axis2-war/1.3.4-SNAPSHOT/ode-axis2-war-1.3.4-SNAPSHOT.war
[INFO] ------------------------------------------------------------------------
[INFO] Building ODE :: Distribution
[INFO]    task-segment: [clean, install]
[INFO] ------------------------------------------------------------------------
[INFO] [clean:clean {execution: default-clean}]
[INFO] Deleting directory <http://hudson.zones.apache.org/hudson/job/ODE-1.X-maven2/ws/APACHE_ODE_1.X/distro/target>
[INFO] [site:attach-descriptor {execution: default-attach-descriptor}]
[INFO] [assembly:single {execution: war-distro}]
[INFO] Reading assembly descriptor: src/main/assembly/war.xml
[WARNING] POM for 'org.apache.axis2:axis2-adb:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-kernel:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-java2wsdl:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-jibx:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-saaj:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-xmlbeans:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] Cannot include project artifact: org.apache.ode:ode-distro:pom:1.3.4-SNAPSHOT; it
doesn't have an associated file or directory.
[WARNING] Cannot include project artifact: org.apache.ode:ode-distro:pom:1.3.4-SNAPSHOT; it
doesn't have an associated file or directory.
[WARNING] Cannot include project artifact: org.apache.ode:ode-distro:pom:1.3.4-SNAPSHOT; it
doesn't have an associated file or directory.
[INFO] Building zip: <http://hudson.zones.apache.org/hudson/job/ODE-1.X-maven2/ws/APACHE_ODE_1.X/distro/target/apache-ode-war-1.3.4-SNAPSHOT.zip>
[INFO] [assembly:single {execution: jbi-distro}]
[INFO] Reading assembly descriptor: src/main/assembly/jbi.xml
[WARNING] POM for 'org.apache.axis2:axis2-adb:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-kernel:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-java2wsdl:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-jibx:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-saaj:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.apache.axis2:axis2-xmlbeans:pom:1.4.1:compile' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] Cannot include project artifact: org.apache.ode:ode-distro:pom:1.3.4-SNAPSHOT; it
doesn't have an associated file or directory.
[WARNING] Cannot include project artifact: org.apache.ode:ode-distro:pom:1.3.4-SNAPSHOT; it
doesn't have an associated file or directory.
[WARNING] Cannot include project artifact: org.apache.ode:ode-distro:pom:1.3.4-SNAPSHOT; it
doesn't have an associated file or directory.
[INFO] Building zip: <http://hudson.zones.apache.org/hudson/job/ODE-1.X-maven2/ws/APACHE_ODE_1.X/distro/target/apache-ode-jbi-1.3.4-SNAPSHOT.zip>
[INFO] [install:install {execution: default-install}]
[INFO] Installing <http://hudson.zones.apache.org/hudson/job/ODE-1.X-maven2/ws/APACHE_ODE_1.X/distro/pom.xml>
to /export/home/hudson/.m2/repository/org/apache/ode/ode-distro/1.3.4-SNAPSHOT/ode-distro-1.3.4-SNAPSHOT.pom
[INFO] Installing <http://hudson.zones.apache.org/hudson/job/ODE-1.X-maven2/ws/APACHE_ODE_1.X/distro/target/apache-ode-war-1.3.4-SNAPSHOT.zip>
to /export/home/hudson/.m2/repository/org/apache/ode/ode-distro/1.3.4-SNAPSHOT/ode-distro-1.3.4-SNAPSHOT.zip
[INFO] Installing <http://hudson.zones.apache.org/hudson/job/ODE-1.X-maven2/ws/APACHE_ODE_1.X/distro/target/apache-ode-jbi-1.3.4-SNAPSHOT.zip>
to /export/home/hudson/.m2/repository/org/apache/ode/ode-distro/1.3.4-SNAPSHOT/ode-distro-1.3.4-SNAPSHOT.zip
[HUDSON] Archiving <http://hudson.zones.apache.org/hudson/job/ODE-1.X-maven2/ws/APACHE_ODE_1.X/distro/pom.xml>
to /export/home/hudson/hudson/jobs/ODE-1.X-maven2/modules/org.apache.ode$ode-distro/builds/2010-05-08_06-02-08/archive/org.apache.ode/ode-distro/1.3.4-SNAPSHOT/pom.xml
[HUDSON] Archiving /export/home/hudson/.m2/repository/org/apache/ode/ode-distro/1.3.4-SNAPSHOT/ode-distro-1.3.4-SNAPSHOT.pom
to /export/home/hudson/hudson/jobs/ODE-1.X-maven2/modules/org.apache.ode$ode-distro/builds/2010-05-08_06-02-08/archive/org.apache.ode/ode-distro/1.3.4-SNAPSHOT/ode-distro-1.3.4-SNAPSHOT.pom
[HUDSON] Archiving <http://hudson.zones.apache.org/hudson/job/ODE-1.X-maven2/ws/APACHE_ODE_1.X/distro/target/apache-ode-war-1.3.4-SNAPSHOT.zip>
to /export/home/hudson/hudson/jobs/ODE-1.X-maven2/modules/org.apache.ode$ode-distro/builds/2010-05-08_06-02-08/archive/org.apache.ode/ode-distro/1.3.4-SNAPSHOT/apache-ode-war-1.3.4-SNAPSHOT.zip
ERROR: Failed to parse POMs
hudson.util.IOException2: Failed to join the process
	at hudson.Proc$RemoteProc.join(Proc.java:312)
	at hudson.maven.ProcessCache$MavenProcess.call(ProcessCache.java:164)
	at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:480)
	at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:416)
	at hudson.model.Run.run(Run.java:1243)
	at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:304)
	at hudson.model.ResourceController.execute(ResourceController.java:88)
	at hudson.model.Executor.run(Executor.java:122)
Caused by: java.util.concurrent.ExecutionException: hudson.remoting.RequestAbortedException:
java.io.EOFException
	at hudson.remoting.Request$1.get(Request.java:218)
	at hudson.remoting.Request$1.get(Request.java:172)
	at hudson.remoting.FutureAdapter.get(FutureAdapter.java:55)
	at hudson.Proc$RemoteProc.join(Proc.java:304)
	... 7 more
Caused by: hudson.remoting.RequestAbortedException: java.io.EOFException
	at hudson.remoting.Request.abort(Request.java:257)
	at hudson.remoting.Channel.terminate(Channel.java:598)
	at hudson.remoting.Channel$ReaderThread.run(Channel.java:876)
Caused by: java.io.EOFException
	at java.io.ObjectInputStream$BlockDataInputStream.peekByte(ObjectInputStream.java:2554)
	at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1297)
	at java.io.ObjectInputStream.readObject(ObjectInputStream.java:351)
	at hudson.remoting.Channel$ReaderThread.run(Channel.java:856)
FATAL: channel is already closed
hudson.remoting.ChannelClosedException: channel is already closed
	at hudson.remoting.Channel.send(Channel.java:412)
	at hudson.remoting.Request.call(Request.java:105)
	at hudson.remoting.Channel.call(Channel.java:551)
	at hudson.Launcher$RemoteLauncher.kill(Launcher.java:735)
	at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:421)
	at hudson.model.Run.run(Run.java:1243)
	at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:304)
	at hudson.model.ResourceController.execute(ResourceController.java:88)
	at hudson.model.Executor.run(Executor.java:122)


Mime
View raw message