ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rafal Rusin (JIRA)" <j...@apache.org>
Subject [jira] Reopened: (ODE-663) DOMUtils.cloneNode results in invalid namespace declaration
Date Thu, 13 May 2010 22:39:42 GMT

     [ https://issues.apache.org/jira/browse/ODE-663?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Rafal Rusin reopened ODE-663:
-----------------------------


> DOMUtils.cloneNode results in invalid namespace declaration
> -----------------------------------------------------------
>
>                 Key: ODE-663
>                 URL: https://issues.apache.org/jira/browse/ODE-663
>             Project: ODE
>          Issue Type: Bug
>          Components: BPEL Runtime
>    Affects Versions: 1.3.3, 1.3.4
>            Reporter: Mark Ford
>            Assignee: Rafal Rusin
>            Priority: Critical
>             Fix For: 1.3.4
>
>         Attachments: ode1.x-663-v1.txt, ode1.x-663-v2.txt, ode1.x-663-v3.txt, ode1.x-663-v4.txt
>
>
> The DOMUtils.cloneNode code doesn't handle default namespace declarations correctly when
processing an XQuery result from Saxon.
> For example:
> <ns1:parent xmlns:ns1="abc">
>    <ns1:child xmlns="def">
>       <ns2:nestedChild xmlns:ns2="def"/>
>    </ns1:child>
> </ns1:parent>
> results in:
> <ns1:parent xmlns:ns1="abc">
>    <ns1:child xmlns:xmlns="def">
>       <ns2:nestedChild xmlns:ns2="def"/>
>    </ns1:child>
> </ns1:parent>
> Notice that the default namespace has been rewritten as xmlns:xmlns which is invalid.

> Granted the above example is a bit odd, but strange things can happen when passing nodes
in and out of XSLT and XQuery with respect to namespace declarations.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message