ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ancoron Luciferis (JIRA)" <j...@apache.org>
Subject [jira] Commented: (ODE-784) Implement OSGi packaging for ODE
Date Tue, 21 Sep 2010 11:28:33 GMT

    [ https://issues.apache.org/jira/browse/ODE-784?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12912941#action_12912941
] 

Ancoron Luciferis commented on ODE-784:
---------------------------------------

I'm currently preparing a list for GlassFish v3.1.

I needed some patches here for ODE itself to get started (hint: TCCL for the ContextConfiguration,
although this should be called using the OSGi service mechanisms as it is exported by Axis2
1.5.1) and I got rid of spring and use the activator for initializing all the things although
I think that we should export services for the management stuff.

In addition I'm on the way to use pure JPA (2.0) for the ode-dao persistence detaching from
the implementation and using the one that is provided by the environment. In case of glassfish
this is eclipselink by default.

Additionally I have some sort of a bundle requirement list already but until it hasn't been
verified to work (playing Ping-Pong of initialization problems between ODE and Axis2 currently)
I'd rather not publish this list. Also I had (and I'm sure that I will have too) OSGi-fy a
lot of libraries the correct way, e.g. saxon-xqj split up into 2 bundles making the javax.*
API part an extension bundle that is visible to the system classloader and the other bundle
containing the saxon implementation.

There is still a lot of work to do but I think I'm on a rather clean way.

> Implement OSGi packaging for ODE
> --------------------------------
>
>                 Key: ODE-784
>                 URL: https://issues.apache.org/jira/browse/ODE-784
>             Project: ODE
>          Issue Type: New Feature
>          Components: Axis2 Integration, Build System
>    Affects Versions: 1.3.3
>            Reporter: Antoine Toulme
>            Assignee: Rafal Rusin
>             Fix For: 1.3.5
>
>
> Implement OSGi packaging for ODE. Make sure ODE is consumable as a set of bundles.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message