ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Florian Wagner - FloWSoft.de" <i...@flowsoft.de>
Subject Re: Can't build 1.3.4 branch
Date Tue, 21 Sep 2010 14:48:46 GMT

\ode-1.3.4>buildr _1.3.5_ package test=no

C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2503:in 
`const_missing'
: uninitialized constant Gem::Requirement::OP_RE (NameError)
         from 
C:/Ruby187/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buil
dr/packaging/version_requirement.rb:24
         from 
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
         from 
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
         from 
C:/Ruby187/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buil
dr/packaging/artifact_namespace.rb:17
         from 
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
         from 
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
         from 
C:/Ruby187/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buil
dr/packaging/artifact.rb:19
         from 
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
         from 
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
         from 
C:/Ruby187/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buil
dr/packaging.rb:17
         from 
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
         from 
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
         from 
C:/Ruby187/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buil
dr.rb:21
         from 
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
         from 
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
         from 
C:/Ruby187/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/bin/buil
dr:18
         from C:/Ruby187/bin/buildr:19:in `load'
         from C:/Ruby187/bin/buildr:19

Am 21.09.2010 16:26, schrieb Antoine Toulme:
> You should not have patched the Rakefile and kept on with 1.3.5. What's the
> problem with 1.3.5 ?
>
> On Tue, Sep 21, 2010 at 00:38, Florian Wagner - FloWSoft.de<
> info@flowsoft.de>  wrote:
>
>>   Dear ODE Devs,
>> I tried to compile the current
>>     http://svn.apache.org/repos/asf/ode/branches/APACHE_ODE_1.3.4.X/
>>
>> branch under Windows XP 32-bit.
>>
>> I installed Ruby 1.8.7-p302 and following
>> Apache Buildr Versions:
>>     1.3.5
>>     1.4.1
>>     1.4.2
>>
>> however the recommended buildr 1.3.5 isn't working with the current Ruby
>> modules...
>>
>> I already patched the Rakefile like described in
>> https://issues.apache.org/jira/browse/ODE-846
>>
>> As I tried to build with
>>     buildr _1.4.x_ package test=no
>>
>> I get following error messages:
>> for 1.4.1:
>>
>>     Skipping tests for ode
>>     Skipping tests for ode:tools
>>     Skipping tests for ode:axis2
>>     Packaging ode-axis2-1.3.4.jar
>>     Skipping tests for ode:axis2-war
>>     Skipping tests for ode:dao-jpa-ojpa-derby
>>     Buildr aborted!
>>     NameError : undefined local variable or method `block' for
>> project("ode:dao-hibe
>>     rnate-db"):Buildr::Project
>>
>> for 1.4.2:
>>
>>     Skipping tests for ode:dao-hibernate-db
>>     Skipping tests for ode:bpel-scripts
>>     Skipping tests for ode:bpel-test
>>     Skipping tests for ode:jbi
>>     Building apache-ode
>>     Skipping tests for apache-ode
>>     Skipping tests for apache-ode:distro
>>     Packaging ode
>>     Packaging ode-dao-hibernate-db-1.3.4.zip
>>     Packaging ode-axis2-war-1.3.4.war
>>     Packaging ode-bpel-test-1.3.4.jar
>>     Packaging ode-jbi-1.3.4.jar
>>     Packaging ode-jbi-1.3.4.zip
>>     Packaging apache-ode
>>     Buildr aborted!
>>     RuntimeError : Unable to define doc task for nil language
>>
>>
>> Thanks for your help!
>>
>> Regards,
>> Florian
>>
>>


Mime
View raw message