ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wallace Araujo <wallace....@gmail.com>
Subject Re: Deploy Exception!!!
Date Mon, 20 Sep 2010 15:52:34 GMT
yup, 1.3.4 version.

in this page the problem is reported:

https://issues.apache.org/jira/browse/ODE-625

Someone have a bug fiz to it? Not Workaround.

  Wallace Araujo
  Linux user #515394
  visite meu site:http://devsubdev.wordpress.com
  MSN:  wallace.jvm@hotmail.com
  Follow me on Twitter: @wallacejvm


2010/9/20 Rafal Rusin <rafal.rusin@gmail.com>

> Hello,
>
> which version did you use? 1.3.4 or snapshot (if so, then please
> provide revision)?
>
> On 16 September 2010 09:20, Wallace Araujo <wallace.jvm@gmail.com> wrote:
> > What Happening!? Cold and Hot deploy throw Exceptions... ODE not
> working...
> > =/
> >
> > INFO: Deploying web application archive ode.war
> > 13:14:45,882 WARN  [ODEServer] Config file
> > [PATH]\apache-tomcat-6.0.29\webapps\ode\WEB-INF\conf\ode-axis2.properties
> > not fo
> > und, default values will be used.
> > 13:14:50,238 INFO  [ODEServer] Using DAO Connection Factory class
> > org.apache.ode
> > .dao.jpa.BPELDAOConnectionFactoryImpl.
> > 13:15:02,298 INFO  [BpelServerImpl] BPEL Server Started.
> > 13:15:02,309 INFO  [SystemSchedulesConfig] SYSTEM CRON
> > configuration: [PATH]\apache-tomcat-6.0.29\webapps\ode\WEB-INF\conf\
> > schedules.xml
> > 13:15:05,905 INFO  [DeploymentPoller] Poller started.
> > 13:15:05,905 INFO  [ODEServer] Process deployment polling started on
> > path [PATH]\apache-tomcat-6.0.29\webapps\ode\WEB-INF\p
> > rocesses.
> > 13:15:05,905 INFO  [ODEServer] ODE Service Engine has been started.
> > 13:15:05,952 FATAL [DeploymentPoller] Encountered an unexpected error.
> >  Exiting
> > poller...
> > java.lang.RuntimeException: java.lang.NullPointerException
> >        at org.apache.ode.utils.WatchDog.check(WatchDog.java:163)
> >        at
> > org.apache.ode.axis2.deploy.DeploymentPoller.checkDeployXmlWatchDog(D
> > eploymentPoller.java:198)
> >        at
> > org.apache.ode.axis2.deploy.DeploymentPoller.check(DeploymentPoller.j
> > ava:142)
> >        at
> > org.apache.ode.axis2.deploy.DeploymentPoller.access$300(DeploymentPol
> > ler.java:60)
> >        at
> > org.apache.ode.axis2.deploy.DeploymentPoller$PollingThread.run(Deploy
> > mentPoller.java:251)
> > Caused by: java.lang.NullPointerException
> >        at
> > org.apache.ode.store.ProcessStoreImpl.refreshSchedules(ProcessStoreIm
> > pl.java:873)
> >        at
> > org.apache.ode.axis2.deploy.DeploymentPoller$DDWatchDogObserver.init(
> > DeploymentPoller.java:296)
> >        at
> > org.apache.ode.utils.WatchDog$DefaultObserver.onUpdate(WatchDog.java:
> > 318)
> >        at org.apache.ode.utils.WatchDog.check(WatchDog.java:132)
> >        ... 4 more
> > Sep 16, 2010 1:15:05 PM org.apache.catalina.startup.HostConfig
> > deployDirectory
> > INFO: Deploying web application directory docs
> > Sep 16, 2010 1:15:06 PM org.apache.catalina.startup.HostConfig
> > deployDirectory
> > INFO: Deploying web application directory examples
> > Sep 16, 2010 1:15:07 PM org.apache.catalina.startup.HostConfig
> > deployDirectory
> > INFO: Deploying web application directory ROOT
> > Sep 16, 2010 1:15:07 PM org.apache.coyote.http11.Http11Protocol start
> > INFO: Starting Coyote HTTP/1.1 on http-8080
> > Sep 16, 2010 1:15:07 PM org.apache.jk.common.ChannelSocket init
> > INFO: JK: ajp13 listening on /0.0.0.0:8009
> > Sep 16, 2010 1:15:07 PM org.apache.jk.server.JkMain start
> > INFO: Jk running ID=0 time=0/31  config=null
> > Sep 16, 2010 1:15:07 PM org.apache.catalina.startup.Catalina start
> > INFO: Server startup in 62939 ms
> >
> > Someone Know some about it?!
> >
> >  Wallace Araujo
> >  Linux user #515394
> >  MSN:  wallace.jvm@hotmail.com
> >  Follow me on Twitter: @wallacejvm
> >
>
>
>
> --
> Regards,
> RafaƂ Rusin
> http://rrusin.blogspot.com
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message