ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gert Vanthienen (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ODE-917) Upgrade to Karaf 2.2.x to support ServiceMix 4.4.0
Date Tue, 29 Mar 2011 11:20:05 GMT

     [ https://issues.apache.org/jira/browse/ODE-917?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Gert Vanthienen updated ODE-917:
--------------------------------

    Attachment: ODE-917.diff

This second patch uses Bnd's -versionpolicy to automatically create a suitable version range
whenever there's no explicit version set on the Import-Package instructions.

With this patch, we now have things like these two examples below without having to manually
maintain the import version ranges:
- org.apache.felix.gogo.commands;version="[0.6,1)",
- org.apache.karaf.shell.console;version="[2.2,2.3)"

> Upgrade to Karaf 2.2.x to support ServiceMix 4.4.0
> --------------------------------------------------
>
>                 Key: ODE-917
>                 URL: https://issues.apache.org/jira/browse/ODE-917
>             Project: ODE
>          Issue Type: Improvement
>            Reporter: Gert Vanthienen
>         Attachments: ODE-917.diff, ODE-917.diff
>
>
> While upgrading dependencies and versions for ServiceMix 4.4.0 which uses Karaf 2.2.0,
I noticed that the current ODE 1.3.5 release does not support Karaf 2.2.0 or above. 

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message