ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From fyrachek <fyrac...@gmail.com>
Subject Schemas with same namespaces problem.
Date Wed, 21 Sep 2011 12:56:39 GMT

When we include one schema to another we have two schemas with the same
namespace names.
ODE handles this situation very odd :

While schemas capturing we have diferent(random) schemas order(depends on
the hash) at the 

_schemas map wich is :

 private final Map<URI, byte[]> _schemas = new HashMap<URI,byte[]>();


Map<URI, byte[]> capture = XSUtils.captureSchema(defuri, schema, resolver);
_schemas.putAll(capture);

While *.bpel file compilation we create XSModelImpl(using it for variables
type checking).It's xercex class.

And at the constructor, we have this code :

fGrammarMap.put(null2EmptyString(fNamespaces[i]), fGrammarList[i]);

So..  if we have more than one namespace with same name at the fNamespaces,
then we loose all previous fGrammarList[i] for this namespace except
last.Because the behavior of the put method is to update value for already
existing key.


Is it the bug of the ODE ?

Because if we lost parent schema grammar it does not matter(child schema
grammar has all parent types),
but if we lost child schema grammar(I debuged such kind of situation)..we
will have compilation error.


Thx !
-- 
View this message in context: http://old.nabble.com/Schemas-with-same-namespaces-problem.-tp32503745p32503745.html
Sent from the Apache Ode Dev mailing list archive at Nabble.com.


Mime
View raw message