ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From abdulkadir yaman <abdulkadirya...@gmail.com>
Subject Re: Ode 1.3.5 in Fuse 4.4
Date Wed, 28 Sep 2011 12:03:24 GMT
Hi Mike, thanks for reply. I have deployed #build 424 which includes these
patches. At first it claimed that it can not find
org.apache.commons.logging.LogFactory, although i have installed
commons-logging 1.1.1 via osgi:install -s mvn:... . Than i had to put
commons-logging jar into $SMX/lib/ and add org.apache.commons.logging
package to jre.properties file.

After these affords, everything has gone smooth and OdeBpelEngine bundle was
Active in osgi:list output without any exception,connection with internal
derby db has been established, openjpa 1.2 has worked and so on . Then i
have put a bpel flow packaged as osgi bundle which is currently working on
 SMX4.3 . But nothing has happened except that cxfbc:consumer endpoint
written in xbean.xml has been exposed via jetty. Neither bpel endpoint has
been registered to nmr,nor any error/exception has been thrown.

I have also set  log level to DEBUG and see what happened while re-deploying
bpel flow. As a result, in terms of ode-bpel, there has happened nothing.

I am working on ;
Linux distro               :  ubuntu 11.04-64bit,
Jdk                          :  1.6.0_27-64bit,
Smx                        :   apache-servicemix-4.4.1-fuse-00-06,
ode-build                 :
https://builds.apache.org/job/ODE-trunk/424/artifact/trunk/distro/target/apache-ode-jbi-1.4-SNAPSHOT.zip
,
properties changed   :   jre.properties- added org.apache.commons.logging


Thanks


On Wed, Sep 28, 2011 at 4:23 AM, Michael Smith <msmith@cbnco.com> wrote:

> On 9/27/2011 1:45 PM, abdulkadir yaman wrote:
>
>> Is there anyone who can able to manage ode 1.3.5 or 1.4-snapshot to work
>> in
>> fuse 4.4 or 4.4.1 ?
>>
>
> Yes, 1.4-snapshot in Fuse 4.4 works with the following patches applied:
>
> https://issues.apache.org/**jira/browse/ODE-917<https://issues.apache.org/jira/browse/ODE-917>
> https://issues.apache.org/**jira/browse/ODE-927<https://issues.apache.org/jira/browse/ODE-927>
>
> and servicemix/etc/org.apache.ode.**jbi.cfg:
>
> ------------------------------
> ode-jbi.**allowIncompleteDeployment=**false
>
> # Default is to use JPA (org.apache.ode.dao.jpa.**
> BPELDAOConnectionFactoryImpl)
> # http://ode.apache.org/smx4-**osgi-deployment.html<http://ode.apache.org/smx4-osgi-deployment.html>recommends
using
> # (older) Hibernate code instead
> ode-jbi.dao.factory=org.**apache.ode.daohib.bpel.**
> BpelDAOConnectionFactoryImpl
>
> ode-jbi.db.mode = EMBEDDED
> ode-jbi.db.emb.name = hibdb
> ------------------------------**-
>
> Dependencies:
>
>  # From the "ode-hib-deps" feature in old ServiceMix 4.3
>  osgi:install -s wrap:mvn:dom4j/dom4j/1.6.1
>  osgi:install -s wrap:mvn:org.hibernate/**hibernate/3.2.5.ga
>
>  # From the "ode-core-deps" feature in old ServiceMix 4.3
>  osgi:install -s mvn:commons-collections/**commons-collections/3.2.1
>  osgi:install -s mvn:commons-beanutils/commons-**beanutils/1.8.2
>  osgi:install -s mvn:commons-io/commons-io/1.4
>  osgi:install -s wrap:mvn:jaxen/jaxen/1.1.1
>  osgi:install -s mvn:org.apache.servicemix.**
> bundles/org.apache.servicemix.**bundles.saxon/9.1.0.8_1
>  osgi:install -s mvn:org.apache.geronimo.**components/geronimo-connector/*
> *2.1.3
>
>  # From the "ode-derby-deps" feature in old ServiceMix 4.3:
>  osgi:install -s mvn:org.apache.derby/derby/10.**5.3.0_1
>
>
> To get it to come up reliably after a restart, I changed the
> osgi:bundle-level of ode-jbi-bundle from 60 to 65 and installed a dummy
> "sleep-delay" bundle at bundle-level 61 whose activator sleeps for 15
> seconds. Otherwise ODE sometimes starts up before the Aries Transaction
> Manager.
>
> Mike
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message