ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tammo van Lessen <tvanles...@gmail.com>
Subject Re: Fwd: What are tables being updated when ODE processes executed
Date Mon, 03 Oct 2011 11:01:00 GMT
Do you have any cleanup rules enabled? If clean up is enabled, it will
remove all messages and process instance entries for completed instances
from the database.

Tammo

On 03.10.2011 10:57, Sajith Kariyawasam wrote:
> ---------- Forwarded message ----------
> From: Sajith Kariyawasam <sajhak@gmail.com>
> Date: Sun, Oct 2, 2011 at 1:48 PM
> Subject: What are tables being updated when ODE processes executed
> To: user <user@ode.apache.org>
> 
> 
> Hi all,
> 
> I would like to know what are the tables being updated / inserted, when an
> ODE process is executed.
> 
> I executed 3 example processes, which comes with the distribution
> (Helloworld2, Dynamic Partner and Magic Session)
> 
> I got the following 3 messages as the responses, respectively. (By looking
> at the response message OK string, i guess the executions were succesful)
> 
> *WARN - 2011-10-01 12:40:44,891 -
> <org.apache.commons.httpclient.HttpMethodBase> Going to buffer response body
> of large or unknown size. Using getResponseBodyAsStream instead is
> recommended.*
> *<?xml version='1.0' encoding='UTF-8'?><soapenv:Envelope xmlns:soapenv="
> http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Body><odens:helloResponse
> xmlns:odens="http://ode/bpel/unit-test.wsdl"><TestPart xmlns:SOAP-ENV="
> http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="
> http://ode/bpel/unit-test.wsdl">Hello
> World</TestPart></odens:helloResponse></soapenv:Body></soapenv:Envelope>*
> 
> 
> *WARN - 2011-10-01 13:29:30,751 -
> <org.apache.commons.httpclient.HttpMethodBase> Going to buffer response body
> of large or unknown size. Using getResponseBodyAsStream instead is
> recommended.*
> *<?xml version='1.0' encoding='UTF-8'?><soapenv:Envelope xmlns:soapenv="
> http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Body><result xmlns="
> http://ode/bpel/unit-test.wsdl
> ">OK</result></soapenv:Body></soapenv:Envelope>*
> 
> 
> 
> WARN - 2011-10-02 13:15:57,013 -
> <org.apache.commons.httpclient.HttpMethodBase> Going to buffer response body
> of large or unknown size. Using getResponseBodyAsStream instead is
> recommended.
> <?xml version='1.0' encoding='UTF-8'?><soapenv:Envelope xmlns:soapenv="
> http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Body><result xmlns="
> http://ode/bpel/unit-test.wsdl
> ">OK</result></soapenv:Body></soapenv:Envelope>
> 
> 
> 
> 
>  But my wonder is that, there was no database records inserted. I made
> DynaicPartner process as persistent, setting in-memory property to
> false. (in WEB-INF/processes/DynPartner/deploy.xml)
> 
>        * <process name="resp:DynPartnerResponder">*
> * <in-memory>false</in-memory>*
> *                <type>resp:DynPartnerResponder</type>*
> * <provide partnerLink="mainPartnerLink">*
> * <service name="rws:DynResponderService" port="DynResponderPort"/>*
> * </provide>*
> * </process>*
> *
> *
> But still, no records in the database were found ...
> 
> Could anybody help me on this?
> 
> Thanks in advance

-- 
Tammo van Lessen - http://www.taval.de

Mime
View raw message