ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "lmuser (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ODE-961) Error installing ode in smx 4.4.1
Date Thu, 17 May 2012 15:36:07 GMT

    [ https://issues.apache.org/jira/browse/ODE-961?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13277895#comment-13277895
] 

lmuser commented on ODE-961:
----------------------------

Thank you - I now get the error :Cannot start bundle mvn:org.apache.ode/ode-jbi-bundle/1.3.5"
in features:ode-core-1.3.5.  The reason is a missing constraint - Import package:org.springframework.beans.factory.xml;version="2.5.0"
was not found.

Here are the steps I have taken so far:
1)created a fragment bundle that is a fragment to the system bundle.  This bundle has the
following libraries in it path: commons-httpclient-3.1.jar, connector-api-1.5.jar and jbi.jar.
 The fragment exports javax.xml.bind;2.2.1, org.apache.commons.lang;2.6.0, org.apache.commons.lang.exception;2.6.0,
javax.xml.stream1.0.1, java.xml.stream.events;1.0.1, javax.resource, javax.resource.spi;1.5.0,
javax.resource.spi.endpoint;1.5.0, javax.resource.spi.security;1.5.0, javax.resource.spi.work;1.5.0,
javax.jbi, javax.jbi.component;1.0.0, javax.jbi.management;1.0.0, javax.jbi.messaging;1.0.0,
javax.jbi.servicedesc;1.0.0,org.apache.commons.httpclient;3.0.0, org.apache.commons.httpclient.params;3.0.0,org.apache.commons.httpclient.util;3.0.0
I needed to create this fragment and export these packages in order to resolve dependencies
on these packages as I kept getting a missing contraint error on them.
2)features:addUrl mvn:org.apache.ode/ode-jbi-karaf/1.3.5/mxl/features
3)osgi:install -s mvn:org.apache.felix.gogo/org.apache.felix.gogo.runtime/0.4.0
4)features:install ode

It when I start step 4 that  I am now getting the error on missing import.  The version of
servicemix 4.4.1 include springframework* 3.0.6.RELEASE packages, so even if I include them
in the exports of the system fragment, I still get the error.  

how can I resolve these dependencies?  Is there a step I have missed?
                
> Error installing ode in smx 4.4.1
> ---------------------------------
>
>                 Key: ODE-961
>                 URL: https://issues.apache.org/jira/browse/ODE-961
>             Project: ODE
>          Issue Type: Bug
>          Components: JBI Integration
>         Environment: eclipse, apache karaf plugin, servicemix 4.4.1
>            Reporter: lmuser
>
> I am using the the url mvn:org.apache.ode/ode-jbi-karaf/1.3.5/xml/features to install
ode.  I get an error about a missing import for the package org.osgi.service.command;version[0.2.0,1.0.0].
 My understanding is that this package is replaced by org.apache.felix.service.command.  

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message