ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fang Zhen <fangzhenz...@gmail.com>
Subject Re: request timed out when debugging the runtime instance .
Date Tue, 06 May 2014 14:12:43 GMT
I think it's not the problem of eclipse or ODE. If you use the sendsoap
script provided by ODE distro, similar problem occurs. When executing
synchronized web service, the client wait for response before timeout. In
sendsoap script case, it uses HttpClient of Apache commons to send http
request, So we can add one line like "mgr.getParams().setSoTimeout(0);"  to
HttpSoapSender.doSend()  for infinite timeout or certain delay. Not sure of
the case of Web Service Explorer since I have never used it before. But I
think if it did not support configuration of timeout, you may need to go
into source of it.

HTH & Good luck! :)



2014-05-06 11:24 GMT+08:00 qynnine <qynnine@gmail.com>:

> Hi,
>
> I have a problem that When I am debugging the runtime of process instance,
> the Eclipse (Test with Web Service Exploer)  always warning me that
>
> http://127.0.0.1:53801/wse/wsdl/actions/InvokeWSDLSOAPOperationFormActionJSP.jsp
> Page load failed with error: The request timed out.
>
> Is there any solution that could make Eclipse quiet or extend some certain
> delay, so I can debug the right things.
>
> thanks very much.
>
>
>
> --
> View this message in context:
> http://apache-ode.996305.n3.nabble.com/request-timed-out-when-debugging-the-runtime-instance-tp17154.html
> Sent from the Apache Ode Dev mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message