ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ODE-1013) Missing context information in Service Endpoint in auto generated WSDL from Axis2
Date Tue, 17 Jun 2014 06:30:04 GMT

    [ https://issues.apache.org/jira/browse/ODE-1013?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14033482#comment-14033482
] 

Hudson commented on ODE-1013:
-----------------------------

ABORTED: Integrated in ODE-trunk-jdk6 #781 (See [https://builds.apache.org/job/ODE-trunk-jdk6/781/])
ODE-1013: Context information has been retianed in the Endpoint by using the same ConfigurationContext
created during start of ODE (sathwik: rev c0b7490f67294e5f2dd6602a151b74b2640cadde)
* axis2/src/main/java/org/apache/ode/axis2/ODEAxis2Server.java
* axis2/src/main/java/org/apache/ode/axis2/SoapExternalService.java
* axis2/src/main/java/org/apache/ode/axis2/hooks/ODEAxisServlet.java
* axis2/src/main/java/org/apache/ode/axis2/ODEServer.java
* axis2/src/main/java/org/apache/ode/axis2/BindingContextImpl.java


> Missing context information in Service Endpoint in auto generated WSDL from Axis2
> ---------------------------------------------------------------------------------
>
>                 Key: ODE-1013
>                 URL: https://issues.apache.org/jira/browse/ODE-1013
>             Project: ODE
>          Issue Type: Bug
>          Components: Axis2 Integration
>    Affects Versions: 1.3.6
>            Reporter: Sathwik Bantwal Premakumar
>            Assignee: Sathwik Bantwal Premakumar
>              Labels: patch
>             Fix For: 1.3.7, 1.4
>
>         Attachments: ODE-1013-1.3.6.patch
>
>
> It has been reported that when the process has an external service call, and after the
execution of the process instance the wsdl service endpoint loses the context information.
> Before the execution of the Process Instance the endpoint in the auto generated WSDL
by axis2 looks like below:
> http://localhost:8080/ode/processes/HelloWorld.HelloWorldPort/
> After the execution of the process instance the endpoint looks like below:
> http://localhost:8080//HelloWorld.HelloWorldPort/
> This behaviour is seen across all deployed process services.
> Forum reporting:
> http://markmail.org/message/m4awoofvdz7nuael?q=problem+with+endpoint+in+Ode+1%2E3%2E6
> http://markmail.org/message/f7lwan3skhkzmbyu?q=404+error+of+BPEL+WebService+at+the+second+run



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message