ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: ODE-1.x #456
Date Tue, 22 Jul 2014 13:13:49 GMT
See <https://builds.apache.org/job/ODE-1.x/456/>

------------------------------------------
Started by user Tammo van Lessen
Building remotely on ubuntu1 (deprecated) in workspace <https://builds.apache.org/job/ODE-1.x/ws/>
 > git rev-parse --is-inside-work-tree
Fetching changes from the remote Git repository
 > git config remote.origin.url https://git-wip-us.apache.org/repos/asf/ode.git
Fetching upstream changes from https://git-wip-us.apache.org/repos/asf/ode.git
 > git --version
 > git fetch --tags --progress https://git-wip-us.apache.org/repos/asf/ode.git +refs/heads/*:refs/remotes/origin/*
 > git rev-parse origin/ode-1.3.x^{commit}
Checking out Revision 443742540807d5b17463a16dc9ff763baacbbb62 (origin/ode-1.3.x)
 > git config core.sparsecheckout
 > git checkout -f 443742540807d5b17463a16dc9ff763baacbbb62
 > git rev-list 443742540807d5b17463a16dc9ff763baacbbb62
[locks-and-latches] Checking to see if we really have the locks
[locks-and-latches] Have all the locks, build can start
[ODE-1.x] $ /bin/bash /tmp/hudson3850565803896920727.sh

######################################################################## 100.0%
######################################################################## 100.0%
######################################################################## 100.0%
######################################################################## 100.0%
                                                                           0.0%
                                                                           0.0%
#########################                                                 35.3%
############################                                              39.5%
############################                                              39.5%
#####################################################                     73.9%
########################################################                  78.9%
######################################################################## 100.0%
######################################################################## 100.0%
######################################################################## 100.0%
Downloading https://github.com/wayneeseguin/rvm/archive/stable.tar.gz

Upgrading the RVM installation in /home/jenkins/.rvm/
    RVM PATH line found in /home/jenkins/.bashrc /home/jenkins/.zshenv.
    RVM sourcing line found in /home/jenkins/.bash_profile /home/jenkins/.zprofile.
    Migrating environment jruby-1.6.7 to use with 'gem-wrappers' gem.
    Migrating environment jruby-1.6.7@CI_1.5 to use with 'gem-wrappers' gem.
    Migrating environment jruby-1.6.7@global to use with 'gem-wrappers' gem.
    Migrating environment jruby-1.7.3 to use with 'gem-wrappers' gem.
    Migrating environment jruby-1.7.3@global to use with 'gem-wrappers' gem.
    Migrating environment ruby-1.8.7-p358 to use with 'gem-wrappers' gem.
    Migrating environment ruby-1.8.7-p358@Buildr-omnibus-build to use with 'gem-wrappers'
gem.
    Migrating environment ruby-1.8.7-p358@global to use with 'gem-wrappers' gem.
    Migrating environment ruby-1.9.2-p320 to use with 'gem-wrappers' gem.
    Migrating environment ruby-1.9.2-p320@Buildr-metrics-build to use with 'gem-wrappers'
gem.
    Migrating environment ruby-1.9.2-p320@CI_1.7 to use with 'gem-wrappers' gem.
    Migrating environment ruby-1.9.2-p320@global to use with 'gem-wrappers' gem.
    Migrating environment ruby-1.9.3-p392 to use with 'gem-wrappers' gem.
    Migrating environment ruby-1.9.3-p392@global to use with 'gem-wrappers' gem.
    Migrating environment ruby-2.0.0-p0 to use with 'gem-wrappers' gem.
    Migrating environment ruby-2.0.0-p0@global to use with 'gem-wrappers' gem.
    Migrating wrappers jruby-1.6.7 to use with 'gem-wrappers' gem.
    Migrating wrappers jruby-1.6.7@CI_1.5 to use with 'gem-wrappers' gem.
    Migrating wrappers jruby-1.6.7@global to use with 'gem-wrappers' gem.
    Migrating wrappers jruby-1.7.3 to use with 'gem-wrappers' gem.
    Migrating wrappers jruby-1.7.3@global to use with 'gem-wrappers' gem.
    Migrating wrappers ruby-1.8.7-p358 to use with 'gem-wrappers' gem.
    Migrating wrappers ruby-1.8.7-p358@Buildr-omnibus-build to use with 'gem-wrappers' gem.
    Migrating wrappers ruby-1.8.7-p358@global to use with 'gem-wrappers' gem.
    Migrating wrappers ruby-1.9.2-p320 to use with 'gem-wrappers' gem.
    Migrating wrappers ruby-1.9.2-p320@Buildr-metrics-build to use with 'gem-wrappers' gem.
    Migrating wrappers ruby-1.9.2-p320@CI_1.7 to use with 'gem-wrappers' gem.
    Migrating wrappers ruby-1.9.2-p320@global to use with 'gem-wrappers' gem.
    Migrating wrappers ruby-1.9.3-p392 to use with 'gem-wrappers' gem.
    Migrating wrappers ruby-1.9.3-p392@global to use with 'gem-wrappers' gem.
    Migrating wrappers ruby-2.0.0-p0 to use with 'gem-wrappers' gem.
    Migrating wrappers ruby-2.0.0-p0@global to use with 'gem-wrappers' gem.
    Installing gem-wrappers gem in 6 gemsets.
    Updating libyaml in /home/jenkins/.rvm/usr to version 0.1.6, see https://github.com/wayneeseguin/rvm/issues/2594
......................................................................................................
Upgrade of RVM in /home/jenkins/.rvm/ is complete.

# jenkins,
#
#   Thank you for using RVM!
#   We sincerely hope that RVM helps to make your life easier and more enjoyable!!!
#
# ~Wayne, Michal & team.

In case of problems: http://rvm.io/help and https://twitter.com/rvm_io

Upgrade Notes:


  * WARNING: You have '~/.profile' file, you might want to load it,
    to do that add the following line to '/home/jenkins/.bash_profile':

      source ~/.profile

  * Zsh 4.3.15 is buggy, be careful with it, it can break RVM, especially multiuser installations,
    You should consider downgrading Zsh to 4.3.12 which has proven to work more reliable with
RVM.
  * RVM comes with a set of default gems including 'bundler', 'rake', 'rubygems-bundler' and
'rvm' gems;
    if you do not wish to get these gems, install RVM with this flag: --without-gems="rvm
rubygems-bundler"
    this option is remembered, it's enough to use it once.

  * RVM will try to automatically use available package manager, might require `sudo`,
    read more about it in `rvm help autolibs`

  * RVM 1.20.12 removes the automated --progress-bar from curl options,
    if you liked this then you can restore this behavior with:

      echo progress-bar >> ~/.curlrc

  * RVM 1.20 changes default behavior of Autolibs to Enabled - if you prefer the 1.19 behavior
    then run "rvm autolibs read-fail", read more details: rvm help autolibs

  * RVM 1.24 changes default package manager on OSX to Homebrew,
    use `rvm autolibs macports` if you prefer Macports.

  * RVM 1.24 changes default `--verify-downloads` flag to `1` you can get the paranoid mode
again with:

      echo rvm_verify_downloads_flag=0 >> ~/.rvmrc

  * RVM 1.25 disables default pollution of rvm_path/bin, you still can generate the links
using:

      rvm wrapper ruby-name           # or for default:
      rvm wrapper default --no-prefix
  * RVM 1.25.11 'rvm remove' will by default remove gems, to remove only ruby use 'rvm uninstall'

RVM reloaded!
jruby-1.7.13 - #removing src/jruby-1.7.13..
Searching for binary rubies, this might take some time.
Found remote file http://jruby.org.s3.amazonaws.com/downloads/1.7.13/jruby-bin-1.7.13.tar.gz
jruby-1.7.13 - #configure
jruby-1.7.13 - #download
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0 18.9M    0  1102    0     0   2501      0  2:12:40 --:--:--  2:12:40  2674
  1 18.9M    1  376k    0     0   303k      0  0:01:03  0:00:01  0:01:02  311k
 19 18.9M   19 3750k    0     0  1659k      0  0:00:11  0:00:02  0:00:09 1680k
 36 18.9M   36 7108k    0     0  2173k      0  0:00:08  0:00:03  0:00:05 2193k
 53 18.9M   53 10.2M    0     0  2449k      0  0:00:07  0:00:04  0:00:03 2466k
 71 18.9M   71 13.4M    0     0  2621k      0  0:00:07  0:00:05  0:00:02 2859k
 88 18.9M   88 16.7M    0     0  2727k      0  0:00:07  0:00:06  0:00:01 3324k
100 18.9M  100 18.9M    0     0  2789k      0  0:00:06  0:00:06 --:--:-- 3332k
No checksum for downloaded archive, recording checksum in user configuration.
jruby-1.7.13 - #validate archive
jruby-1.7.13 - #extract
jruby-1.7.13 - #validate binary
jruby-1.7.13 - #setup
jruby-1.7.13 - #gemset created /home/jenkins/.rvm/gems/jruby-1.7.13@global
jruby-1.7.13 - #importing gemset /home/jenkins/.rvm/gemsets/jruby/global.gems............................................................................
jruby-1.7.13 - #generating global wrappers........
jruby-1.7.13 - #gemset created /home/jenkins/.rvm/gems/jruby-1.7.13
jruby-1.7.13 - #importing gemsetfile /home/jenkins/.rvm/gemsets/default.gems evaluated to
empty gem list
jruby-1.7.13 - #generating default wrappers........
Using /home/jenkins/.rvm/gems/jruby-1.7.13
Successfully installed bundler-1.6.4
1 gem installed
Fetching gem metadata from https://rubygems.org/......
Fetching additional metadata from https://rubygems.org/..
Resolving dependencies...
Installing rake 0.9.2.2
Installing atoulme-Antwrap 0.7.4
Installing bouncy-castle-java 1.5.0147
Installing builder 3.2.2
Using bundler 1.6.4
Installing diff-lcs 1.2.4
Installing hoe 3.7.1
Installing jruby-openssl 0.8.10
Installing jruby-pageant 1.1.1
Installing json_pure 1.8.0
Installing minitar 0.5.4
Installing net-ssh 2.7.0
Installing net-sftp 2.1.2
Installing orderedhash 0.0.6
Installing rspec-core 2.14.5
Installing rspec-expectations 2.14.3
Installing rspec-mocks 2.14.3
Installing rspec 2.14.1
Installing rubyzip 0.9.9
Installing xml-simple 1.1.2
Installing buildr 1.4.19
Your bundle is complete!
Use `bundle show [gemname]` to see where a bundled gem is installed.
Post-install message from buildr:
To get started run buildr --help
(in <https://builds.apache.org/job/ODE-1.x/ws/,> hudson)
Buildr aborted!
RuntimeError : Unsatisfied dependency xmlbeans -> org.apache.xmlbeans:xmlbeans:jar:2.3.0
-> [">", #<Gem::Version "2.6.0">] not satisfied by 2.6.0
<https://builds.apache.org/job/ODE-1.x/ws/Rakefile>:35:in `(root)'
(See full trace by running task with --trace)
Build step 'Execute shell' marked build as failure
[locks-and-latches] Releasing all the locks
[locks-and-latches] All the locks released
Recording fingerprints
Archiving artifacts
Recording test results
TestNG Reports Processing: START
Looking for TestNG results report in workspace using pattern: **/reports/testng/testng-results.xml
Did not find any matching files.

Mime
View raw message