ode-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From gmlewis <...@git.apache.org>
Subject [GitHub] ode pull request: Upgrade Apache Commons Collections to v3.2.2
Date Thu, 10 Mar 2016 00:08:01 GMT
GitHub user gmlewis opened a pull request:

    https://github.com/apache/ode/pull/3

    Upgrade Apache Commons Collections to v3.2.2

    
    Version 3.2.1 has a CVSS 10.0 vulnerability. That is the worst kind of
    vulnerability that exists. By merely existing on the classpath, this
    library causes the Java serialization parser for the entire JVM process
    to go from being a state machine to a turing machine. A turing machine
    with an exec() function!
    
    https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2015-8103
    https://commons.apache.org/proper/commons-collections/security-reports.html
    http://foxglovesecurity.com/2015/11/06/what-do-weblogic-websphere-jboss-jenkins-opennms-and-your-application-have-in-common-this-vulnerability/

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/gmlewis/ode master

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/ode/pull/3.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #3
    
----
commit 6486f7f53e317dad071d3432b4c5b0d91383838a
Author: Glenn Lewis <gmlewis@google.com>
Date:   2016-03-10T00:07:56Z

    Upgrade Apache Commons Collections to v3.2.2

----


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message