ofbiz-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pierre Smits (Jira)" <j...@apache.org>
Subject [jira] [Commented] (OFBIZ-11401) getEntityRefData service has a weird issue
Date Sat, 23 May 2020 12:07:00 GMT

    [ https://issues.apache.org/jira/browse/OFBIZ-11401?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17114725#comment-17114725
] 

Pierre Smits commented on OFBIZ-11401:
--------------------------------------

Also a good argument to replace the error with a warning.

> getEntityRefData service has a weird issue
> ------------------------------------------
>
>                 Key: OFBIZ-11401
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-11401
>             Project: OFBiz
>          Issue Type: Bug
>          Components: framework/webtools
>    Affects Versions: Trunk
>            Reporter: Jacques Le Roux
>            Priority: Major
>
> It's reproductible on trunk demo though only visible in log, UI shows no issue
> Here is the log on trunk demo
> {noformat}
> 2020-02-21 21:11:56,445 |ajp-nio-8009-exec-2  |WebToolsServices              |E| null
> java.util.MissingResourceException: Can't find resource for bundle org.apache.ofbiz.base.util.UtilProperties$UtilResourceBundle,
key FieldDescription.WorkEffortType.createdTxStamp
> 	at java.util.ResourceBundle.getObject(ResourceBundle.java:450) ~[?:1.8.0_242]
> 	at java.util.ResourceBundle.getObject(ResourceBundle.java:444) ~[?:1.8.0_242]
> 	at java.util.ResourceBundle.getString(ResourceBundle.java:407) ~[?:1.8.0_242]
> 	at org.apache.ofbiz.webtools.WebToolsServices.getEntityRefData(WebToolsServices.java:685)
[main/:?]
> 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_242]
> 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_242]
> 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
~[?:1.8.0_242]
> 	at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_242]
> 	at org.apache.ofbiz.service.engine.StandardJavaEngine.serviceInvoker(StandardJavaEngine.java:100)
[main/:?]
> 	[...]
> 	at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
[tomcat-util-9.0.29.jar:9.0.29]
> 	at java.lang.Thread.run(Thread.java:748) [?:1.8.0_242]
> 2020-02-21 21:11:56,445 |ajp-nio-8009-exec-2  |WebToolsServices              |E| null
> java.util.MissingResourceException: Can't find resource for bundle org.apache.ofbiz.base.util.UtilProperties$UtilResourceBundle,
key FieldDescription.createdTxStamp
> 	at java.util.ResourceBundle.getObject(ResourceBundle.java:450) ~[?:1.8.0_242]
> 	at java.util.ResourceBundle.getObject(ResourceBundle.java:444) ~[?:1.8.0_242]
> 	at java.util.ResourceBundle.getString(ResourceBundle.java:407) ~[?:1.8.0_242]
> 	at org.apache.ofbiz.webtools.WebToolsServices.getEntityRefData(WebToolsServices.java:695)
[main/:?]
> 	[...]
> 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_242]
> 	at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
[tomcat-util-9.0.29.jar:9.0.29]
> 	at java.lang.Thread.run(Thread.java:748) [?:1.8.0_242]
> 2020-02-21 21:11:56,445 |ajp-nio-8009-exec-2  |ServiceDispatcher             |T| Sync
service [webtools/getEntityRefData] finished in [5760] milliseconds
> 	at org.apache.ofbiz.webtools.WebToolsServices.getEntityRefData(WebToolsServices.java:685)
[main/:?]
>     {noformat}
> So it repeats almost "ad ib" and eventually stops after 5+ seconds there.
> I guess R17 and R18 are also affected, R16 is OK.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message