openoffice-api mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fabrizio Marchesano <fmarches...@gmail.com>
Subject Re: OpenOffice plugin for NetBeans 7.2?
Date Fri, 25 Jan 2013 09:30:19 GMT
Hi,
just tested the 3.0.1 package with NetBeans 7.2.1 and AOO 3.5 developer
build on a Windows XP virtual machine: no problem at all so far in
importing projects, cleaning, building, modifying and deploying.
I could take on the Italian localization, but I, too, am uncertain if it
would be welcome or just unnecessary: as a developer, English is my only
language for software UI (so much that, paradoxically, at the beginning I
should brush up on common conventions used for it_IT software
localizations) and I think I'm not a black swan.
Any thoughts by other Italian developers?
Regards,

Fabrizio

On Tue, Jan 15, 2013 at 5:19 PM, Carl Marcum <carl@codebuilders.net> wrote:

> On 01/15/2013 10:45 AM, Jürgen Schmidt wrote:
>
>> On 1/15/13 4:36 PM, Carl Marcum wrote:
>>
>>> On 01/15/2013 09:57 AM, Jürgen Schmidt wrote:
>>>
>>>> On 1/15/13 3:47 PM, Carl Marcum wrote:
>>>>
>>>>> On 01/15/2013 09:06 AM, Jürgen Schmidt wrote:
>>>>>
>>>>>> On 1/15/13 2:44 PM, Carl Marcum wrote:
>>>>>>
>>>>>>> On 01/13/2013 02:58 PM, Alexandro Colorado wrote:
>>>>>>>
>>>>>>>> On Sun, Jan 13, 2013 at 12:14 PM, Carl Marcum <cmarcum@apache.org>
>>>>>>>> wrote:
>>>>>>>>
>>>>>>>>  Alexandro,
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> On 01/13/2013 03:02 AM, Alexandro Colorado wrote:
>>>>>>>>>
>>>>>>>>>  Anyone has experience NetBeans 7.2  and the OpenOffice
Extension
>>>>>>>>>> plugin?
>>>>>>>>>> http://wiki.openoffice.org/****wiki/OpenOffice_NetBeans_****
>>>>>>>>>> Integration<http://wiki.openoffice.org/**wiki/OpenOffice_NetBeans_**Integration>
>>>>>>>>>> <http://wiki.**openoffice.org/wiki/**OpenOffice_NetBeans_**
>>>>>>>>>> Integration<http://wiki.openoffice.org/wiki/OpenOffice_NetBeans_Integration>
>>>>>>>>>> >
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Is there any incompatibilities?
>>>>>>>>>>
>>>>>>>>>> Last I heard an update of the NetBeans plugin was
updated to AOO
>>>>>>>>>> 3.4
>>>>>>>>>> however, I am not sure about the version of NetBeans
will have any
>>>>>>>>>> impact
>>>>>>>>>> on the expected result. Last tested version said
5.6, although the
>>>>>>>>>> report
>>>>>>>>>> is a bit old.
>>>>>>>>>> http://wiki.openoffice.org/****wiki/OpenOffice_NetBeans_**<http://wiki.openoffice.org/**wiki/OpenOffice_NetBeans_**>
>>>>>>>>>> Integration_QA#Test_strategy<h**ttp://wiki.openoffice.org/**
>>>>>>>>>> wiki/OpenOffice_NetBeans_**Integration_QA#Test_strategy<http://wiki.openoffice.org/wiki/OpenOffice_NetBeans_Integration_QA#Test_strategy>
>>>>>>>>>> >
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Regards.
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>  You can also build the plugin in Netbeans also.
You can find the
>>>>>>>>> source
>>>>>>>>> here:
>>>>>>>>> http://svn.apache.org/repos/****asf/openoffice/devtools/**<http://svn.apache.org/repos/**asf/openoffice/devtools/**>
>>>>>>>>> netbeansintegration/trunk/<htt**p://svn.apache.org/repos/asf/**
>>>>>>>>> openoffice/devtools/**netbeansintegration/trunk/<http://svn.apache.org/repos/asf/openoffice/devtools/netbeansintegration/trunk/>
>>>>>>>>> >
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> Or the tagged 3.0.0.beta here:
>>>>>>>>> http://svn.apache.org/repos/****asf/openoffice/devtools/**<http://svn.apache.org/repos/**asf/openoffice/devtools/**>
>>>>>>>>> netbeansintegration/tags/3.0.****0.beta/<http://svn.apache.**
>>>>>>>>> org/repos/asf/openoffice/**devtools/netbeansintegration/**
>>>>>>>>> tags/3.0.0.beta/<http://svn.apache.org/repos/asf/openoffice/devtools/netbeansintegration/tags/3.0.0.beta/>
>>>>>>>>> >
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> Since the nbm file pulls in 3rd party jars, I'm not sure
we can
>>>>>>>>> provide a
>>>>>>>>> built version, but maybe we can get Netbeans to provide
the
>>>>>>>>> download.
>>>>>>>>>
>>>>>>>>> Most of the changes I've made so were to get it to run
on the
>>>>>>>>> Netbeans 7.x
>>>>>>>>> platform due to depreciated API's. and then Apache branding.
>>>>>>>>>
>>>>>>>>> Maybe if a few more people can confirm it works like
before we can
>>>>>>>>> take
>>>>>>>>> the beta off.
>>>>>>>>>
>>>>>>>>> Best regards,
>>>>>>>>> Carl
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>  Hi Carl, good that you respond, I have made some localization
to
>>>>>>>> some of
>>>>>>>> the files you have for spanish, but I am not sure how to
make the
>>>>>>>> commit,
>>>>>>>> so maybe i can private email the files.
>>>>>>>>
>>>>>>>> I have a friend that contributes to netbeans I might ask
him on
>>>>>>>> details to
>>>>>>>> have the extension register to their plugin platform.
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>> Alexandro,
>>>>>>>
>>>>>>> Thanks for the contribution!!
>>>>>>>
>>>>>>> I added a \ in the OpenIDE-Module-Long-**Description= section
after
>>>>>>> Calc
>>>>>>> Add-in
>>>>>>>
>>>>>>> A new nbm 3.0.1 file here:
>>>>>>> http://people.apache.org/~**cmarcum/devtools/<http://people.apache.org/~cmarcum/devtools/>
>>>>>>>
>>>>>>> Please review and I'll update the link on the the wiki page.
>>>>>>>
>>>>>>
>>>>>> how about changing the name to apache-openoffice-extensions-**
>>>>>> 3.0.2.nbm
>>>>>>
>>>>>> Juergen
>>>>>>
>>>>>>
>>>>>>
>>>>> Juergen,
>>>>>
>>>>> Do you mean the name of the nbm file only or the java package names
>>>>> also?
>>>>>
>>>>> Inside the jar package names follow the java naming based on domain
>>>>> org.openoffice.extensions...
>>>>>
>>>>> I don't think they have to be the same.
>>>>>
>>>>
>>>> changing the package is indeed too much overhead. Changing the name was
>>>> only a quick idea, not so important.
>>>>
>>>> Juergen
>>>>
>>>>
>>> I have updated all of the branding inside and it now displays "Apache
>>> OpenOffice API Plugin"
>>>
>>> Since Alexandro has updated Spanish, I think I'll see if I can find
>>> volunteers to update some other languages as well.
>>>
>>>
>> the question is how many developers don't use English as the preferred
>> language for development.
>>
>
> It's true that most developers are going to know English. There were
> already ja, pt_BR, and zn_CH that would be outdated since I updated text
> for the Apache move.
>
> Just a thought.
>
> Carl
>
>
>
>
>> Juergen
>>
>>  Best regards,
>>> Carl
>>>
>>>
>>>>> Thanks,
>>>>> Carl
>>>>>
>>>>>
>>>>>>> Details:
>>>>>>>
>>>>>>> Date: Tue Jan 15 01:44:20 2013
>>>>>>> New Revision: 1433255
>>>>>>>
>>>>>>> URL: http://svn.apache.org/viewvc?**rev=1433255&view=rev<http://svn.apache.org/viewvc?rev=1433255&view=rev>
>>>>>>> Log:
>>>>>>> Added ES localization bundle files.
>>>>>>> Patch by: Alexandro Colorado <jza@oooes.org>
>>>>>>>
>>>>>>> Added:
>>>>>>>
>>>>>>> openoffice/devtools/**netbeansintegration/trunk/src/**
>>>>>>> org/openoffice/extensions/**Bundle_es.properties
>>>>>>>
>>>>>>>
>>>>>>>      (with props)
>>>>>>>
>>>>>>> openoffice/devtools/**netbeansintegration/trunk/src/**
>>>>>>> org/openoffice/extensions/**config/Bundle_es.properties
>>>>>>>
>>>>>>>
>>>>>>>      (with props)
>>>>>>>
>>>>>>> Best regards,
>>>>>>> Carl
>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>
>>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message