openoffice-api mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Amenel VOGLOZIN <waav_zoungla-o...@yahoo.fr>
Subject Re: Extension
Date Wed, 01 Oct 2014 10:25:37 GMT
Hi Chris,

It would be better if you tried to make your query to the mailing list self-contained.

What is it that doesn't work? What's the behavior that you are expecting but don't see? Is
it that a text that contains "mistake" does not have that word underlined?

I guess you are using the NetBeans plugin? I personally prefer Eclipse so the only tasks I
use NB for are building the package, installing the extension in my "normal" OO installation
and most importantly, debugging the extension. Did you know that you could set breakpoints
and debug the extension in a running Open Office instance?

Try putting breakpoints in the overridden methods and check that the breakpoints are hit at
some point. That would be a good starting point. Also, I've found that logic flaws creep easily
into code and step by step debugging is sometimes the appropriate remedy. Anyway, make sure
your doProofreading is being called.

Good luck.



Le Mercredi 1 octobre 2014 8h37, Chris Banks <chris.daniel.banks@gmail.com> a écrit
:
 


Hi,
We're trying to create and extension for Open Office but are having a
little bit of trouble.
See this Stack Overflow question.
http://stackoverflow.com/questions/26122526/open-office-proofreading-extension-not-registering
Any help would be gratefully received.
Chris
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message