openoffice-api mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexandro Colorado <...@oooes.org>
Subject Re: Description.xml/Version propper user
Date Sat, 02 May 2015 07:55:45 GMT
On Saturday, May 02, 2015 08:47:49 AM Andrea Pescetti wrote:
> On 30/04/2015 Alexandro Colorado wrote:
> > According to description.xml
> > 
https://wiki.openoffice.org/wiki/Documentation/DevGuide/Extensions/Descri
p
> > tion_of_XML_Elements#Element_.2Fdescription.2Fversion The following 
is
> > described: Required. A textual representation of the extension 
version.
> > ... I want to confirm the policy and propper use of the metadata
> > according to the application.
> 
> I think it is simply a string, compared within OpenOffice using a string
> comparison (which is not optimal: if you have version "99.0" and version
> "100.0", version 100.0 comes before 99.0 since it starts with a "1").
> 
> I use "YYYY.MM.DD" like Marco, so "2015.05.02". It is fine to use "0.1",
> "0.2" and similar but "0.9" is not considered to come before "0.10" so
> keep that in mind. I believe more exotic numbering like "0.9-alpha2" is
> not accepted by the Extensions site, but is accepted by OpenOffice.

I see, thanks for clarifying this. My biggest concern is that the extension 
manager 'catch' the published updates correctly with the extension site.

> 
> It's been a few years since I last looked at this, but I don't think
> things have changed much. At the time, I settled for using "YYYY.MM.DD"
> and I've been consistently using that pattern.
> 
> Regards,
>    Andrea.
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: api-unsubscribe@openoffice.apache.org
> For additional commands, e-mail: api-help@openoffice.apache.org


Alexandro Colorado
Apache
*OpenOffice*^{TM} Contributor
882C 4389 3C27 E8DF 41B9 5C4C 1DB7 9D1C 7F4C 2614

Mime
View raw message