openoffice-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From msei...@apache.org
Subject svn commit: r1859670 - in /openoffice/branches/AOO42X: ./ main/configure.ac
Date Tue, 21 May 2019 17:55:53 GMT
Author: mseidel
Date: Tue May 21 17:55:53 2019
New Revision: 1859670

URL: http://svn.apache.org/viewvc?rev=1859670&view=rev
Log:
Merged r1859668 from trunk

General cleanup, updated URLs

Modified:
    openoffice/branches/AOO42X/   (props changed)
    openoffice/branches/AOO42X/main/configure.ac

Propchange: openoffice/branches/AOO42X/
------------------------------------------------------------------------------
--- svn:mergeinfo (original)
+++ svn:mergeinfo Tue May 21 17:55:53 2019
@@ -9,4 +9,4 @@
 /openoffice/branches/ia2:1417739-1541842
 /openoffice/branches/ooxml-osba:1546391,1546395,1546574,1546934,1547030,1547392,1551920,1551954,1551958,1552283
 /openoffice/branches/rejuvenate01:1480411,1534063,1534098,1536312,1549902,1560617
-/openoffice/trunk:1851110-1851111,1851115,1851118,1851121,1851206,1851214-1851215,1851443,1851449,1851464,1851575,1851634,1851637,1851639,1851715,1851753,1851813,1851987,1852008,1852010,1852029,1852046,1852174,1852187,1852190,1852197,1852430,1852438,1852623-1852624,1852841,1852965,1853175,1853245,1853252,1853285-1853286,1853299,1853319,1853327,1853443-1853444,1853456,1853466,1853504,1853558,1853643,1853668,1853670,1853726,1853742,1853972,1853976,1854051,1854065,1854176,1854196,1854324-1854325,1854473,1854519,1854740,1854788,1854852,1854933,1855053,1855140,1855181,1855246,1855509,1855523,1855617,1855647,1855649,1855778,1855813,1855926,1855947,1856034,1856079,1856113,1856224,1856555,1856677,1856833,1856899,1857186,1857302,1857311,1857450-1857451,1857877-1857878,1857899-1857900,1858000,1858167,1858209,1858284,1858381-1858382,1858505,1858511,1858682,1858700,1858940,1858942,1858949,1859148,1859223,1859362-1859363,1859486,1859491,1859582
+/openoffice/trunk:1851110-1851111,1851115,1851118,1851121,1851206,1851214-1851215,1851443,1851449,1851464,1851575,1851634,1851637,1851639,1851715,1851753,1851813,1851987,1852008,1852010,1852029,1852046,1852174,1852187,1852190,1852197,1852430,1852438,1852623-1852624,1852841,1852965,1853175,1853245,1853252,1853285-1853286,1853299,1853319,1853327,1853443-1853444,1853456,1853466,1853504,1853558,1853643,1853668,1853670,1853726,1853742,1853972,1853976,1854051,1854065,1854176,1854196,1854324-1854325,1854473,1854519,1854740,1854788,1854852,1854933,1855053,1855140,1855181,1855246,1855509,1855523,1855617,1855647,1855649,1855778,1855813,1855926,1855947,1856034,1856079,1856113,1856224,1856555,1856677,1856833,1856899,1857186,1857302,1857311,1857450-1857451,1857877-1857878,1857899-1857900,1858000,1858167,1858209,1858284,1858381-1858382,1858505,1858511,1858682,1858700,1858940,1858942,1858949,1859148,1859223,1859362-1859363,1859486,1859491,1859582,1859668

Modified: openoffice/branches/AOO42X/main/configure.ac
URL: http://svn.apache.org/viewvc/openoffice/branches/AOO42X/main/configure.ac?rev=1859670&r1=1859669&r2=1859670&view=diff
==============================================================================
--- openoffice/branches/AOO42X/main/configure.ac (original)
+++ openoffice/branches/AOO42X/main/configure.ac Tue May 21 17:55:53 2019
@@ -1,5 +1,5 @@
 dnl * *************************************************************
-dnl *  
+dnl *
 dnl *  Licensed to the Apache Software Foundation (ASF) under one
 dnl *  or more contributor license agreements.  See the NOTICE file
 dnl *  distributed with this work for additional information
@@ -7,16 +7,16 @@ dnl *  regarding copyright ownership.  T
 dnl *  to you under the Apache License, Version 2.0 (the
 dnl *  "License"); you may not use this file except in compliance
 dnl *  with the License.  You may obtain a copy of the License at
-dnl *  
+dnl *
 dnl *    http://www.apache.org/licenses/LICENSE-2.0
-dnl *  
+dnl *
 dnl *  Unless required by applicable law or agreed to in writing,
 dnl *  software distributed under the License is distributed on an
 dnl *  "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
 dnl *  KIND, either express or implied.  See the License for the
 dnl *  specific language governing permissions and limitations
 dnl *  under the License.
-dnl *  
+dnl *
 dnl * *************************************************************
 AC_REVISION( $Revision$ )
 AC_PREREQ(2.50)
@@ -59,7 +59,7 @@ AC_ARG_ENABLE(online-update,
 [  --disable-online-update Disables the Online Update feature.
 ],,enable_online_update=yes)
 AC_ARG_ENABLE(unit-tests,
-[  --disable-unit-tests		Disables default unit tests (eg. unit tests using Google test, ...).
+[  --disable-unit-tests    Disables default unit tests (eg. unit tests using Google test, ...).
 ],,enable_unit_tests=yes)
 AC_ARG_ENABLE(ldap,
 [  --disable-ldap          Disables the use of LDAP backend via OpenLDAP
@@ -131,8 +131,6 @@ AC_ARG_WITH(epm,
 AC_ARG_WITH(epm-url,
 [  --with-epm-url=<URL>    Specify the location of downloadable epm source code. For example:
                             https://sourceforge.net/projects/oooextras.mirror/files/epm-3.7.tar.gz
-                          or
-                            http://epm.sourcearchive.com/downloads/3.7-1/epm_3.7.orig.tar.gz
                           Version 3.7 or later is required. Note that epm is under GPL license.
 ],[  EPM_URL="$withval"
 ])
@@ -141,7 +139,7 @@ AC_ARG_WITH(package-format,
                           Default is "normal" one of the OS/Distribution.
 
                           Usage: --with-package-format="foo bar"
-],,)                   
+],,)
 AC_ARG_ENABLE(odk,
 [  --disable-odk           AOO includes an ODK, office development kit
                           which some packagers may want to build without
@@ -311,7 +309,7 @@ AC_ARG_ENABLE(opengl,
 ],,enable_opengl=no)
 AC_ARG_ENABLE(dbus,
 [  --enable-dbus           Determines whether to enable presentation mode
-                          screensaver control under GNOME via DBUS 
+                          screensaver control under GNOME via DBUS
 ],,enable_dbus=no)
 AC_ARG_ENABLE(gconf,
 [  --disable-gconf         Determines whether to use the GConf support
@@ -407,7 +405,7 @@ AC_ARG_WITH(external-thes-dir,
 
 AC_ARG_WITH(system-libs,
 [  --with-system-libs      Use libs already on system -- enables all
-                          --with-system-* flags except 
+                          --with-system-* flags except
                           odbc/sane/xrender-header(s)
 ],,)
 AC_ARG_WITH(system-headers,
@@ -419,7 +417,7 @@ AC_ARG_WITH(system-headers,
 AC_ARG_WITH(system-jars,
 [  --without-system-jars   When building with --with-system-libs, also the
                           needed jars are expected on the system. Use this to
-                          disable that. 
+                          disable that.
                           (except for the db case where --with-system-db
                           *has to* imply using the db.jar from there, too)
 ],,)
@@ -653,7 +651,7 @@ AC_ARG_WITH(java,
 [  --with-java             Build with[[out]] Java support. If you use
                           --without-java/--with-java=no then the build will have
                           no support for Java components, applets, accessibility
-                          or XML filters. 
+                          or XML filters.
 ], if test "$withval" = "yes"; then WITH_JAVA=java; else WITH_JAVA=$withval; fi, WITH_JAVA=java)
 AC_ARG_ENABLE(gcjaot,
 [  --enable-gcjaot         Build with[[out]] using Ahead of Time java compilation
@@ -694,7 +692,7 @@ AC_ARG_WITH(perl-home,
 ],,)
 AC_ARG_WITH(cl-home,
 [  --with-cl-home          For Windows NT users, please supply the path
-                          for the Microsoft C/C++ compiler. 
+                          for the Microsoft C/C++ compiler.
                           Note that this is not the location of the compiler
                           binary but the location of the entire distribution.
 
@@ -759,7 +757,7 @@ AC_ARG_WITH(mozilla-build,
                           Usage: --with-mozilla-build=<absolute path to mozilla build tools>
 
 						  At the moment of this writing, an installer for the mozilla build tools
-						  can be obtained from http://ftp.mozilla.org/pub/mozilla.org/mozilla/libraries/win32/.
+						  can be obtained from https://ftp.mozilla.org/pub/mozilla.org/mozilla/libraries/win32/.
 ],[MOZILLABUILD=$withval],)
 AC_ARG_WITH(local-solenv,
 [  --with-local-solenv     If you have solenv in a location other than ./solenv,
@@ -793,7 +791,7 @@ AC_ARG_ENABLE(coinmp,
 ],,)
 AC_ARG_ENABLE(check-only,
 [  --enable-check-only     Use this option option if you just want to check your
-                          environment.  This option stops the generation of an
+                          environment. This option stops the generation of an
                           ????env.set
 
                           Usage: --enable-check-only=yes
@@ -803,7 +801,7 @@ AC_ARG_ENABLE(ccache-skip,
                           escape compiler flags that would otherwise prevent
                           caching of the result (currently used on Mac only)
                           NOTE: requires patched version because of a bug in
-                          ccache (see issue 104567 for details and patch) 
+                          ccache (see issue 104567 for details and patch)
                           explicitly enable if your version of ccache does not
                           identify as version 2.4_OOo
 ]],,enable_ccache_skip=auto)
@@ -834,7 +832,7 @@ AC_ARG_WITH(dict,
 ],,)
 AC_ARG_WITH(intro-bitmaps,
 [  --with-intro-bitmaps    Prefer the specified intro bitmaps over the
-                          the default one.  Can be more than one (separated by
+                          the default one. Can be more than one (separated by
                           commas), the order means priority of fallback if the
                           first does not exist (in the installed tree).
 
@@ -917,7 +915,7 @@ AC_ARG_ENABLE(dependency-tracking,
 ],,)
 AC_ARG_ENABLE(category-b,
 [  --enable-category-b     Activate components under a category B license
-                          (see http://www.apache.org/legal/3party.html#category-b):
+                          (see https://www.apache.org/legal/3party.html#category-b):
                           MPL (hunspell, hyphen, nss, saxon, rhino),
                           CPL (silgraphite), CPL/EPL (CoinMP), OFL (fonts).
                           Flags for individual libraries override this one.
@@ -1126,7 +1124,7 @@ case "$build_os" in
         	test_randr=yes
 		test_freetype=yes
         	test_gstreamer=yes
-        	_os=Linux	
+        	_os=Linux
 		;;
 	gnu)
 		test_cups=no
@@ -1196,7 +1194,7 @@ case "$build_os" in
 		elif test "$OSVERSION" -lt "502102"; then
 			PTHREAD_CFLAGS="-D_THREAD_SAFE"
 			PTHREAD_LIBS="-lc_r"
-		else 
+		else
 			PTHREAD_CFLAGS=""
 			PTHREAD_LIBS="-pthread"
 		fi
@@ -1325,7 +1323,7 @@ if test -n "$enable_werror" && test "$en
    AC_MSG_RESULT([yes])
    AC_MSG_WARN([Turning warnings to errors has no effect in modules or])
    AC_MSG_WARN([on platforms where it has been disabled explicitely])
-   echo "Turning warnings to errors has no effect in modules or on platforms where it has been disabled explicitely" >> warn
+   echo "Turning warnings to errors has no effect in modules or on platforms where it has been disabled explicitly" >> warn
 else
    ENABLE_WERROR="FALSE"
    AC_MSG_RESULT([no])
@@ -1424,7 +1422,7 @@ dnl ====================================
 dnl Build options
 dnl ===================================================================
 
-# Disable or enable category-B librariets: nss, hunspell, hyphen, saxon,
+# Disable or enable category-B libraries: nss, hunspell, hyphen, saxon,
 # rhino, silgraphite.
 
 # Note that further below they may be enabled or disabled again by
@@ -1489,7 +1487,7 @@ dnl ====================================
 AC_MSG_CHECKING([whether to enable unit tests])
 if test "$enable_unit_tests" = "yes" -o "$enable_unit_tests" = "TRUE"; then
    ENABLE_UNIT_TESTS="YES"
-   BUILD_TYPE="$BUILD_TYPE GTEST" 
+   BUILD_TYPE="$BUILD_TYPE GTEST"
    AC_MSG_RESULT([yes])
 else
    ENABLE_UNIT_TESTS=""
@@ -1709,7 +1707,7 @@ dnl ====================================
 AC_MSG_CHECKING([gcc home])
 if test -z "$with_gcc_home"; then
 	GCC_HOME=`which gcc | $SED -e s,/bin/gcc,,`
-else	
+else
 	GCC_HOME="$with_gcc_home"
 fi
 AC_MSG_RESULT($GCC_HOME)
@@ -1769,7 +1767,7 @@ if test \( "$_os" != "WINNT" -o "$WITH_M
       fi
       AC_MSG_RESULT([ok (GNU ld)])
    fi
-fi 
+fi
 AC_SUBST(GCCVER)
 
 HAVE_LD_BSYMBOLIC_FUNCTIONS=
@@ -1818,8 +1816,8 @@ dnl Search all the common names for GNU
 dnl ===================================================================
 AC_MSG_CHECKING([for GNU make])
 for a in "$MAKE" "$GNUMAKE" make gmake gnumake; do
-      $a --version 2> /dev/null | $GREP GNU  2>&1 > /dev/null
-      if test $? -eq 0;  then
+      $a --version 2> /dev/null | $GREP GNU 2>&1 > /dev/null
+      if test $? -eq 0; then
            GNUMAKE=$a
            break
       fi
@@ -1885,7 +1883,7 @@ else
     # This test _should_ work because the one accepts -V (ours) and one
     # (the other) not...
     $DMAKE -V 2>/dev/null | $GREP -E 'dmake(.exe)? .* Version .*' >/dev/null
-    if test $? -eq 0; then 
+    if test $? -eq 0; then
        BUILD_DMAKE=NO
        AC_MSG_RESULT([yes])
        AC_MSG_CHECKING([the dmake version])
@@ -1917,8 +1915,8 @@ dnl Search all the common names for GNU
 dnl ===================================================================
 AC_MSG_CHECKING([for GNU or compatible BSD tar])
 for a in $GNUTAR gtar gnutar bsdtar tar; do
-      $a --version 2> /dev/null | $EGREP "GNU|libarchive"  2>&1 > /dev/null
-      if test $? -eq 0;  then
+      $a --version 2> /dev/null | $EGREP "GNU|libarchive" 2>&1 > /dev/null
+      if test $? -eq 0; then
            GNUTAR=$a
            break
       fi
@@ -1941,11 +1939,11 @@ if test "$_os" = "SunOS"; then
       dnl cc -V outputs to standard error!!!!
       _sunstudio_string=`$CC -V 2>&1 | $GREP '^cc' | sed -e 's/.* C //'`
       _sunstudio_version=`echo $_sunstudio_string | $AWK '{ print $1 }'`
-      _sunstudio_major=`echo $_sunstudio_version | $AWK -F. '{ print $1 }'` 
+      _sunstudio_major=`echo $_sunstudio_version | $AWK -F. '{ print $1 }'`
       if test "$_sunstudio_major" != "5"; then
          AC_MSG_ERROR([found version "$_sunstudio_version", use version 5.5, 5.7, 5.8 or 5.9 of the SunStudio C/C++ compiler])
       else
-         _sunstudio_minor=`echo $_sunstudio_version | $AWK -F. '{ if ($2 == 5) print "true"; else if ($2 == 7) print "true"; else if ($2 == 8) print "true"; else if ($2 == 9) print "true"; else print "false" }'` 
+         _sunstudio_minor=`echo $_sunstudio_version | $AWK -F. '{ if ($2 == 5) print "true"; else if ($2 == 7) print "true"; else if ($2 == 8) print "true"; else if ($2 == 9) print "true"; else print "false" }'`
          if test "$_sunstudio_minor" = "false"; then
             AC_MSG_ERROR([found version "$_sunstudio_version", use version 5.5, 5.7, 5.8 or 5.9 of the SunStudio C/C++ compiler])
          else
@@ -2022,7 +2020,7 @@ if test "$PERL"; then
    _perl_version=$?
    if test "$_perl_version" -lt 5; then
       AC_MSG_ERROR([found Perl version "$_perl_version", use version 5 of Perl])
-   fi 
+   fi
    AC_MSG_RESULT([checked (perl $_perl_version)])
 else
    AC_MSG_ERROR([Perl not found, install version 5 of Perl])
@@ -2032,7 +2030,7 @@ AC_SUBST(PERL)
 dnl ===================================================================
 dnl Testing for required Perl modules
 dnl The list of required Perl modules is documented here:
-dnl     http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO#General_Build_Requirements
+dnl     https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO#General_Build_Requirements
 dnl ===================================================================
 AC_MSG_CHECKING([for required Perl modules])
 if `$PERL -e 'use Archive::Zip;
@@ -2152,7 +2150,7 @@ if test "$_os" = "WINNT"; then
 			export INCLUDE=`cygpath -d "$COMPATH/Include"`
 			dnl  Check which Microsoft C/C++ compiler is found
 			AC_MSG_CHECKING([the Version of Microsoft C/C++ Compiler])
-dnl      The following find microsoft, matches nn.nn.nnnn then pulls numbers out.         
+dnl      The following find microsoft, matches nn.nn.nnnn then pulls numbers out.
 			CCTXTVER=`$CC 2>&1 | head -n1`
 			CCNUMVER=`echo $CCTXTVER | $AWK "/Microsoft/ && /..\\...\\...../ {
 							x = match( \\\$0, /..\\...\\...../ )
@@ -2218,7 +2216,7 @@ case "$build_os" in
 esac
 AC_SUBST(COM)
 
-dnl  Decode the compiler version.  Logic from main/solenv/inc/tg_compv.mk.
+dnl  Decode the compiler version. Logic from main/solenv/inc/tg_compv.mk.
 case $COM in
 	GCC)
 		CCVER=`${CC} -dumpfullversion -dumpversion 2>&1`;
@@ -2574,7 +2572,7 @@ main (void)
   test (E0);
   return 0;
 }
-],[AC_MSG_ERROR([your version of the GNU C++ compile has a bug which prevents Apache OpenOffice from being compiled correctly - please check http://gcc.gnu.org/ml/gcc-patches/2004-07/msg00968.html for details.])], [AC_MSG_RESULT([no])])
+],[AC_MSG_ERROR([your version of the GNU C++ compiler has a bug which prevents Apache OpenOffice from being compiled correctly - please check https://gcc.gnu.org/ml/gcc-patches/2004-07/msg00968.html for details.])], [AC_MSG_RESULT([no])])
    fi
 fi
 
@@ -2686,9 +2684,9 @@ if test "$_os" = "SunOS"; then
          AC_MSG_WARN([SunStudio C++ was not found])
          echo "SunStudio C++ was not found" >> warn
       else
-         AC_MSG_RESULT([checked]) 
+         AC_MSG_RESULT([checked])
       fi
-   fi 
+   fi
 fi
 dnl ===================================================================
 dnl Extra checking for the OSF compiler
@@ -2762,7 +2760,7 @@ fi
 # ===================================================================
 # use --ccache-skip?
 # ===================================================================
-dnl used to escape compiler options for ccache that otherwise prevent 
+dnl used to escape compiler options for ccache that otherwise prevent
 dnl caching of the results (like "-x objective-c++" for Mac)
 AC_MSG_CHECKING([whether we are allowed and able to use --ccache-skip])
 if test "$_os" != "Darwin" ; then
@@ -2779,7 +2777,7 @@ elif test "$enable_ccache_skip" = "auto"
    if test "$CCACHE" = "not_found" ; then
       AC_MSG_NOTICE([not enabling --ccache-skip (ccache not found)])
    else
-      # check ccache version 
+      # check ccache version
       AC_MSG_CHECKING([whether version of ccache is suitable])
       CCACHE_VERSION=`"$CCACHE" -V | "$AWK" '/^ccache version/{print $3}'`
       if test "$CCACHE_VERSION" = "2.4_OOo"; then
@@ -2789,7 +2787,7 @@ elif test "$enable_ccache_skip" = "auto"
          save_CXXFLAGS=$CXXFLAGS
          CXXFLAGS="$CXXFLAGS --ccache-skip -O2"
          dnl an empty program will do, we're checking the compiler flags
-         AC_COMPILE_IFELSE([AC_LANG_PROGRAM([],[])], 
+         AC_COMPILE_IFELSE([AC_LANG_PROGRAM([],[])],
             [use_ccache=yes], [use_ccache=no])
          if test $use_ccache = yes ; then
             AC_MSG_RESULT([yes, will enable --ccache-skip])
@@ -2836,7 +2834,7 @@ if test "$USE_SYSTEM_STL" = "YES"; then
 using namespace std;
 ],[istringstream strm( "test" ); return 0;],
       $EGREP -q  unresolvable conftest.err;
-      if test $? -eq 0; then gccvisok=no; else gccvisok=yes; fi, 
+      if test $? -eq 0; then gccvisok=no; else gccvisok=yes; fi,
       gccvisok=no)
       AC_MSG_RESULT([$gccvisok])
       if test "$gccvisok" = "no"; then
@@ -2866,7 +2864,7 @@ _ACEOF
             i?86|x86_64)
                if $EGREP -q '@PLT' visibility.s; then
                   gccvisbroken=no
-               else 
+               else
                   gccvisbroken=yes
                fi
                ;;
@@ -3023,16 +3021,16 @@ if test "$SOLAR_JAVA" != ""; then
 #           AC_MSG_ERROR([Kaffe is too old ($KAFFE_VER - $_kaffe_ver), you need at least 1.1.0])
 #        fi
 #        JDK=kaffe
-#        
+#
 #        dnl TODO: define some project exclusion variables
-#        
+#
 #        AC_MSG_RESULT([checked (Kaffe $KAFFE_VER)])
 #        AC_MSG_WARN([EXPERIMENTAL: Kaffe is not a full JDK replacement - some projects will fail to compile])
 #        echo "EXPERIMENTAL: Kaffe is not a full JDK replacement - some projects will fail to compile" >>warn
 #        JAVA_HOME=`echo $JAVAINTERPRETER | $SED -n "s,//*bin//*java,,p"`
       elif test `$JAVAINTERPRETER --version 2>&1 | $GREP -c "GNU libgcj"` -gt 0; then
         JDK=gcj
-        AC_MSG_RESULT([checked (gcj)]) 
+        AC_MSG_RESULT([checked (gcj)])
         _gij_version=`$JAVAINTERPRETER --version | $GREP GNU | $SED -e 's@^[[^0-9]]*@@' -e 's@ .*@@' -e 's@,.*@@'`;
         _gij_longver=`echo $_gij_version | $AWK -F. '{ print \$1*10000+\$2*100+\$3 }'`
 
@@ -3066,7 +3064,7 @@ if test "$SOLAR_JAVA" != ""; then
         dnl IBM JDK specific tests
         _jdk=`$JAVAINTERPRETER -version 2>&1 | $AWK -F'"' '{ print \$2 }' | $SED s/[[-A-Za-z]]*//`
         _jdk_ver=`echo "$_jdk" | $AWK -F. '{ print (($1 * 100) + $2) * 100 + $3;}'`
-   
+
         if test "$_jdk_ver" -lt 10500; then
              AC_MSG_ERROR([IBM JDK is too old, you need at least 1.5])
         fi
@@ -3079,8 +3077,8 @@ you must use the "--with-jdk-home" confi
         fi
 
         JAVA_HOME=$with_jdk_home
-	
-      else	
+
+      else
         JDK=sun
 
         dnl SUN JDK specific tests
@@ -3111,7 +3109,7 @@ dnl ====================================
 dnl Checks for javac
 dnl ===================================================================
 if test "$SOLAR_JAVA" != ""; then
-    if test "$JDK" = "gcj"; then 
+    if test "$JDK" = "gcj"; then
         javacompiler=`echo $WITH_JAVA | $SED -e "s/gij/gcj/g" | $SED -e "s/java/javac/g"`
     else
         javacompiler="javac"
@@ -3252,7 +3250,7 @@ _ACEOF
       if test "$JAVA_HOME" = "/usr" -a "x$with_jdk_home" = "x"; then
          javac_link_f=`readlink -f "$JAVACOMPILER" 2>/dev/null`
          if test $? == 0 && test "$JAVACOMPILER" != "$javac_link_f"; then
-          # try to recover first by looking whether we have a alternatives 
+          # try to recover first by looking whether we have a alternatives
           # system as in Debian or newer SuSEs where following /usr/bin/javac
           # over /etc/alternatives/javac leads to the right bindir where we
           # just need to strip a bit away to get a valid JAVA_HOME
@@ -3306,7 +3304,7 @@ fi
 AWTLIB=
 if test "$SOLAR_JAVA" != ""; then
    AC_MSG_CHECKING([for jawt lib name])
-   if test "$JDK" = "gcj"; then 
+   if test "$JDK" = "gcj"; then
       save_CFLAGS=$CFLAGS
       save_LDFLAGS=$LDFLAGS
       CFLAGS="$CFLAGS -I$JAVA_HOME/include"
@@ -3421,14 +3419,14 @@ if test "$enable_epm" = "yes"; then
          BUILD_TYPE="$BUILD_TYPE EPM"
       else
          if test "$EPM" = "no" ; then
-	    AC_MSG_ERROR([no. Install ESP Package Manager (http://www.msweet.org/projects.php?Z2) and/or specify the path to the right epm (--with-epm). Or specify an URL to an epm-3.7 source package (--with-epm-url); run configure with the --help option for a list of possible URLs.])
+	    AC_MSG_ERROR([no. Install ESP Package Manager (https://www.msweet.org/epm/) and/or specify the path to the right epm (--with-epm). Or specify an URL to an epm-3.7 source package (--with-epm-url); run configure with the --help option for a list of possible URLs.])
 	 else
 	    # Gentoo has some epm which is something different...
             AC_MSG_CHECKING([whether the found epm is the right epm])
             if $EPM | $GREP "ESP Package Manager" >/dev/null 2>/dev/null; then
                AC_MSG_RESULT([yes])
             else
-	       AC_MSG_ERROR([no. Install ESP Package Manager (http://www.msweet.org/projects.php?Z2) and/or specify the path to the right epm (--with-epm). Or specify an URL to an epm-3.7 source package (--with-epm-url); run configure with the --help option for a list of possible URLs.])
+	       AC_MSG_ERROR([no. Install ESP Package Manager (https://www.msweet.org/epm/) and/or specify the path to the right epm (--with-epm). Or specify an URL to an epm-3.7 source package (--with-epm-url); run configure with the --help option for a list of possible URLs.])
             fi
             AC_MSG_CHECKING([epm version])
             EPM_VERSION=`$EPM | $GREP 'ESP Package Manager' | cut -d' ' -f4 | $SED -e s/v//`
@@ -3502,7 +3500,7 @@ if test "$enable_epm" = "yes"; then
 		AC_MSG_ERROR([unknown system])
    esac
    if test -n "$with_package_format"; then
-	for i in $with_package_format; do 
+	for i in $with_package_format; do
 		case "$i" in
 			aix | bsd | deb | inst | tardist | osx | pkg | rpm | setld | native | portable | archive | dmg | installed | msi)
 			;;
@@ -3524,7 +3522,7 @@ archive - .tar.gz or .zip
 dmg - Mac OS X .dmg
 installed - installation tree
 msi - Windows .msi
-			]) 
+			])
 			;;
 		esac
 	done
@@ -3543,7 +3541,7 @@ msi - Windows .msi
             if test $? -eq 0; then
                RPM=$a
                break
-            fi 
+            fi
          fi
        done
        if test -z "$RPM" ; then
@@ -3595,7 +3593,7 @@ msi - Windows .msi
                       _pt="pkg"
                   fi
                   AC_MSG_WARN([the ${_pt}s will not be relocateable])
-                  echo "the ${_pt}s will not be relocateable" >> warn
+                  echo "the ${_pt}s will not be relocatable" >> warn
                   AC_MSG_WARN([if you want to make sure installation without --nodeps and
                   relocation will work, you need to patch your epm with the
                   patch in epm/epm-3.7.patch or build with
@@ -3690,9 +3688,9 @@ if test "z$enable_odk" = "z" -o "$enable
       if test -z "$WITH_MINGWIN" || test "$WITH_MINGWIN" = "0"; then
          AC_MSG_ERROR([for rebuilding unowinreg.dll you need the mingw32 C++ compiler.
          Specify mingw32 g++ executable name with --with-mingwin.
-         Or use prebuilt one from http://tools.openoffice.org/unowinreg_prebuild/680/ and
+         Or use prebuilt one from https://tools.openoffice.org/unowinreg_prebuild/680/ and
          put it into external/unowinreg using your browser or a command equivalent to:
-         wget -O external/unowinreg/unowinreg.dll http://www.openoffice.org/tools/unowinreg_prebuild/680/unowinreg.dll])
+         wget -O external/unowinreg/unowinreg.dll https://www.openoffice.org/tools/unowinreg_prebuild/680/unowinreg.dll])
       fi
       if echo "$WITH_MINGWIN" | $EGREP -q "/"; then
          if ! test -x "$WITH_MINGWIN"; then MINGWCXX=false; else MINGWCXX=`basename $WITH_MINGWIN`; fi
@@ -3977,21 +3975,21 @@ AC_MSG_CHECKING([which python to use])
 if test "$_os" = "Darwin" && test "$with_system_python" != "no"; then
    with_system_python=yes
 
-   _python="/Library/Frameworks/Python.framework/Versions/Current/bin/python" 
+   _python="/Library/Frameworks/Python.framework/Versions/Current/bin/python"
    if test ! -f $_python; then
    	  _python="/usr/bin/python"
    fi
    AC_MSG_RESULT([compiling against system python ($_python)])
 
    _python_hexversion=`$_python -c "import sys; print(sys.hexversion);"`
- 
+
    dnl hex version of Python 2.7.1 = 34013680
    if test $_python_hexversion -ge 34013680 ; then
    	  _python_version=`$_python -c "import sys; print sys.version;" | head -c 3`
       AC_MSG_RESULT([compiling against system python (version $_python_version)])
 
 	  _python_ver=`$_python -c "import distutils.sysconfig; print(distutils.sysconfig.get_config_var('VERSION'));"`
-	  
+
 	  if test -d "/Library/Frameworks/Python.framework/Versions/$_python_ver/include/python$_python_ver"; then
 	  	 PYTHON_CFLAGS="-I/Library/Frameworks/Python.framework/Versions/$_python_ver/include/python$_python_ver"
          elif test -d "$MACOSX_SDK_PATH/usr/include/python$_python_ver"; then
@@ -4054,12 +4052,12 @@ if test -n "$with_system_lucene" -o -n "
         AC_MSG_RESULT([external])
         SYSTEM_LUCENE=YES
         if test -z $LUCENE_CORE_JAR; then
-          AC_CHECK_FILE(/usr/share/java/lucene-core-2.9.4.jar, 
+          AC_CHECK_FILE(/usr/share/java/lucene-core-2.9.4.jar,
             [ LUCENE_CORE_JAR=/usr/share/java/lucene-core-2.9.4.jar ],
             [
-              AC_CHECK_FILE(/usr/share/java/lucene-core.jar, 
+              AC_CHECK_FILE(/usr/share/java/lucene-core.jar,
                 [ LUCENE_CORE_JAR=/usr/share/java/lucene-core.jar ],
-                [ AC_CHECK_FILE(/usr/share/java/lucene.jar, 
+                [ AC_CHECK_FILE(/usr/share/java/lucene.jar,
                    [ LUCENE_CORE_JAR=/usr/share/java/lucene.jar ],
                    [ AC_MSG_ERROR(lucene-core.jar replacement not found)]
                   )
@@ -4073,10 +4071,10 @@ if test -n "$with_system_lucene" -o -n "
         fi
 
         if test -z $LUCENE_ANALYZERS_JAR; then
-          AC_CHECK_FILE(/usr/share/java/lucene-analyzers-2.3.jar, 
+          AC_CHECK_FILE(/usr/share/java/lucene-analyzers-2.3.jar,
             [ LUCENE_ANALYZERS_JAR=/usr/share/java/lucene-analyzers-2.3.jar ],
             [
-              AC_CHECK_FILE(/usr/share/java/lucene-contrib/lucene-analyzers.jar, 
+              AC_CHECK_FILE(/usr/share/java/lucene-contrib/lucene-analyzers.jar,
                 [ LUCENE_ANALYZERS_JAR=/usr/share/java/lucene-contrib/lucene-analyzers.jar ],
                 [ AC_MSG_ERROR(lucene-analyzers.jar replacement not found.)]
               )
@@ -4157,7 +4155,7 @@ if test -n "$with_system_mysql" -o -n "$
 	if test -z "$MYSQLCONFIG" -o ! -x "$MYSQLCONFIG" ; then
 		AC_MSG_ERROR([can not find/execute mysql_config]);
 	fi
-	MYSQL_VERSION=`$MYSQLCONFIG --version` 
+	MYSQL_VERSION=`$MYSQLCONFIG --version`
 	MYSQL_MAJOR=`$MYSQLCONFIG --version | cut -d"." -f1`
 	if test "$MYSQL_MAJOR" -ge "5"; then
 		AC_MSG_RESULT([OK])
@@ -4165,7 +4163,7 @@ if test -n "$with_system_mysql" -o -n "$
 		AC_MSG_ERROR([too old, use 5.0.x or 5.1.x])
 	fi
 	AC_MSG_CHECKING([for MySQL Client library])
-	MYSQL_INC=`$MYSQLCONFIG --include` 
+	MYSQL_INC=`$MYSQLCONFIG --include`
 	MYSQL_LIB=`$MYSQLCONFIG --libs`
 	MYSQL_DEFINES=`$MYSQLCONFIG --cflags | sed -e s,$MYSQL_INC,,`
 	AC_MSG_RESULT([includes $MYSQL_INC, libraries $MYSQL_LIB])
@@ -4221,7 +4219,7 @@ int main(int argc, char **argv) {
 	driver = get_driver_instance();
 	if (driver->getMajorVersion() > 1 || \
 	   (driver->getMajorVersion() == 1 && driver->getMinorVersion() > 0) || \
-	   (driver->getMajorVersion() == 1 && driver->getMinorVersion() == 0 && driver->getPatchVersion() >= 6)) 
+	   (driver->getMajorVersion() == 1 && driver->getMinorVersion() == 0 && driver->getPatchVersion() >= 6))
         return 0;
       else
         return 1;
@@ -4314,11 +4312,11 @@ AC_SUBST(ENABLE_BEANSHELL)
 
 
 dnl ===================================================================
-dnl Check for saxon.  It can come from two different places:
-dnl - pre-installed on the system.  This is checked when the --with-system-saxon
+dnl Check for saxon. It can come from two different places:
+dnl - pre-installed on the system. This is checked when the --with-system-saxon
 dnl   option is given to configure.
 dnl   The exact place can be specified with the --with-saxon-jar=<path> option.
-dnl - From the saxon tar ball in ext_sources/.  This is used when --enable-saxon
+dnl - From the saxon tar ball in ext_sources/. This is used when --enable-saxon
 dnl   is given to configure but not any of --with-system-saxon or --with-saxon-jar.
 dnl ===================================================================
 DISABLE_SAXON=
@@ -4328,10 +4326,10 @@ if test -n "$with_system_saxon" -o -n "$
         AC_MSG_RESULT([external])
         SYSTEM_SAXON=YES
         if test -z $SAXON_JAR; then
-          AC_CHECK_FILE(/usr/share/java/saxon9.jar, 
+          AC_CHECK_FILE(/usr/share/java/saxon9.jar,
             [ SAXON_JAR=/usr/share/java/saxon9.jar ],
             [
-              AC_CHECK_FILE(/usr/share/java/saxon.jar, 
+              AC_CHECK_FILE(/usr/share/java/saxon.jar,
                 [ SAXON_JAR=/usr/share/java/saxon.jar ],
                 [ AC_CHECK_FILE(/usr/share/java/saxon9.jar,
                     [ SAXON_JAR=/usr/share/java/saxon9.jar ],
@@ -4566,7 +4564,7 @@ if test -n "$with_system_curl" -o -n "$w
    AC_MSG_CHECKING([whether curl is >= 7.13.1])
    if test "`$CURLCONFIG --version | $AWK -F' ' '{print $2}' | $AWK -F. '{ print $1 }'`" -gt "7" -a \
 	"`$CURLCONFIG --version | $AWK -F' ' '{print $2}' | $AWK -F. '{ print $2 }'`" -gt "13" -a \
-	"`$CURLCONFIG --version | $AWK -F' ' '{print $2}' | $AWK -F. '{ print $3 }'`" -gt "1"; then 
+	"`$CURLCONFIG --version | $AWK -F' ' '{print $2}' | $AWK -F. '{ print $3 }'`" -gt "1"; then
       AC_MSG_ERROR([no, you need at least curl 7.13,1])
    else
       AC_MSG_RESULT([yes])
@@ -4729,7 +4727,7 @@ Mozilla build tooling not found!
   It is required for NSS that is needed for AOO's security facilities.
   Either disable NSS using the option --disable-nss-module
   or use the --with-mozilla-build option after installing the tool obtained
-  from http://ftp.mozilla.org/pub/mozilla.org/mozilla/libraries/win32/])
+  from https://ftp.mozilla.org/pub/mozilla.org/mozilla/libraries/win32/])
       else
          if test \( "$WITH_MINGWIN" = "yes" \) ; then
             if test ! -d "$MOZILLABUILD" ; then
@@ -4945,7 +4943,7 @@ AC_SUBST(XLIB)
 AC_SUBST(XAU_LIBS)
 
 dnl ===================================================================
-dnl Check if fontconfig/fontconfig.h is available 
+dnl Check if fontconfig/fontconfig.h is available
 dnl ===================================================================
 if test "$ENABLE_FONTCONFIG" = "TRUE" ; then
     AC_CHECK_HEADER(fontconfig/fontconfig.h, [],
@@ -5437,7 +5435,7 @@ if test \( "$_os" = "WINNT" \) ; then
         fi
         if test -z "$with_atl_lib_dir"; then
             ATL_LIB=$COMPATH/atlmfc/lib
-	    ATL_LIB_X64=$COMPATH/atlmfc/lib/amd64
+        ATL_LIB_X64=$COMPATH/atlmfc/lib/amd64
         else
             ATL_LIB=`cygpath -u "$with_atl_lib_dir"`
             ATL_LIB_X64=$ATL_LIB/../amd64
@@ -5708,7 +5706,7 @@ else
 fi
 ASM_HOME="$with_asm_home"
 AC_SUBST(ASM_HOME)
- 
+
 dnl ***************************************
 dnl testing nasm.exe assembler path
 dnl ***************************************
@@ -5731,7 +5729,7 @@ else
 fi
 NASM_HOME="$with_nasm_home"
 AC_SUBST(NASM_HOME)
- 
+
 dnl ===================================================================
 dnl testing handle deprecated unzip switch
 dnl ===================================================================
@@ -5785,7 +5783,7 @@ if test "$_os" = "WINNT"; then
 Get it from the Microsoft site and put it into external/dbghelp.
 (Note: Microsoft seems to enjoy changing the exact location of this file. You
 may have to search Microsoft's website.) Last time it was seen at:
-<http://www.microsoft.com/downloads/release.asp?releaseid=30682>.])
+<https://www.microsoft.com/downloads/release.asp?releaseid=30682>.])
    fi
 fi
 
@@ -5800,16 +5798,16 @@ if test "$_os" = "WINNT"; then
       AC_MSG_RESULT([found and executable])
    else
       AC_MSG_ERROR([ vcredist_x86.exe is missing in external/vcredist/.
-Get it from the Microsoft site and put it into external/vcredist. You can try 
-to download it from http://www.microsoft.com/download/en/search.aspx?q=redistributable%20package.])
+Get it from the Microsoft site and put it into external/vcredist. You can try
+to download it from https://www.microsoft.com/download/en/search.aspx?q=redistributable%20package.])
    fi
    AC_MSG_CHECKING([for vcredist_x64.exe])
    if test -x ./external/vcredist/vcredist_x64.exe; then
       AC_MSG_RESULT([found and executable])
    else
       AC_MSG_ERROR([ vcredist_x64.exe is missing in external/vcredist/.
-Get it from the Microsoft site and put it into external/vcredist. You can try 
-to download it from http://www.microsoft.com/download/en/search.aspx?q=redistributable%20package.])
+Get it from the Microsoft site and put it into external/vcredist. You can try
+to download it from https://www.microsoft.com/download/en/search.aspx?q=redistributable%20package.])
    fi
    WITH_VC_REDIST=YES
    AC_SUBST(WITH_VC_REDIST)
@@ -5837,7 +5835,7 @@ if test "$_os" = "WINNT"; then
       AC_MSG_ERROR([gdiplus.dll is missing in external/gdiplus/.
 Get it from the Microsoft site and put it into external/gdiplus.
 You may have to search Microsoft's website. Last time it was seen at:
-<http://www.microsoft.com/downloads/details.aspx?familyid=6A63AB9C-DF12-4D41-933C-BE590FEAA05A&displaylang=en>.])
+<https://www.microsoft.com/downloads/details.aspx?familyid=6A63AB9C-DF12-4D41-933C-BE590FEAA05A&displaylang=en>.])
    fi
 fi
 
@@ -5853,7 +5851,7 @@ if test "$_os" = "WINNT"; then
 Get it from the Microsoft Visual C++ 2010 Redistributable Package (x86),
 from the Microsoft site and put it into external/msvcp100.
 You may have to search Microsoft's website. Last time it was seen at:
-<http://www.microsoft.com/en-us/download/search.aspx?q=Microsoft+Visual+C%2b%2b+2010+Redistributable>.])
+<https://www.microsoft.com/en-us/download/search.aspx?q=Microsoft+Visual+C%2b%2b+2010+Redistributable>.])
    fi
 fi
 
@@ -6035,7 +6033,7 @@ if test  "$test_cairo" = "yes"; then
            test "$with_system_cairo" != "no"; then
            AC_MSG_RESULT([external])
            SYSTEM_CAIRO=YES
-	   
+
            PKG_CHECK_MODULES( CAIRO, cairo >= 1.0.2 )
 	   if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$ENABLE_FONTCONFIG" != "TRUE" ; then
 	      AC_MSG_ERROR([Cairo library requires fontconfig.])
@@ -6060,7 +6058,7 @@ int main(int argc, char **argv) {
 	   if test "$build_cpu" != "x86_64"; then
 	      BUILD_PIXMAN=YES
 	   fi
-           AC_MSG_RESULT([internal])	   
+           AC_MSG_RESULT([internal])
         fi
     else
 	   AC_MSG_RESULT([no])
@@ -6131,7 +6129,7 @@ AC_SUBST(POPPLER_CFLAGS)
 AC_SUBST(POPPLER_LIBS)
 
 AC_MSG_CHECKING([whether to build the Wiki Publisher extension])
-if test -n "$enable_wiki_publisher" -a "$enable_wiki_publisher" != "no" && test  "$WITH_JAVA" != "no"; then
+if test -n "$enable_wiki_publisher" -a "$enable_wiki_publisher" != "no" && test "$WITH_JAVA" != "no"; then
   AC_MSG_RESULT([yes])
   AC_MSG_CHECKING([for swext module])
   if test -d ./swext; then
@@ -6186,10 +6184,10 @@ if test -n "$enable_report_builder" -a "
          [AC_MSG_ERROR(sac.jar not found.)], [])
 
   if test -z $LIBXML_JAR; then
-    AC_CHECK_FILE(/usr/share/java/libxml-1.0.0.jar, 
+    AC_CHECK_FILE(/usr/share/java/libxml-1.0.0.jar,
       [ LIBXML_JAR=/usr/share/java/libxml-1.0.0.jar ],
       [
-        AC_CHECK_FILE(/usr/share/java/libxml.jar, 
+        AC_CHECK_FILE(/usr/share/java/libxml.jar,
           [ LIBXML_JAR=/usr/share/java/libxml.jar ],
           [AC_MSG_ERROR(libxml.jar replacement not found.)]
         )
@@ -6201,10 +6199,10 @@ if test -n "$enable_report_builder" -a "
   fi
 
   if test -z $FLUTE_JAR; then
-    AC_CHECK_FILE(/usr/share/java/flute-1.3.0.jar, 
+    AC_CHECK_FILE(/usr/share/java/flute-1.3.0.jar,
       [ FLUTE_JAR=/usr/share/java/flute-1.3.0.jar ],
       [
-        AC_CHECK_FILE(/usr/share/java/flute.jar, 
+        AC_CHECK_FILE(/usr/share/java/flute.jar,
           [ FLUTE_JAR=/usr/share/java/flute.jar ],
           [ AC_MSG_ERROR(flute-1.3.0.jar replacement not found.)]
         )
@@ -6216,10 +6214,10 @@ if test -n "$enable_report_builder" -a "
   fi
 
   if test -z $JFREEREPORT_JAR; then
-    AC_CHECK_FILE(/usr/share/java/flow-engine-0.9.2.jar, 
+    AC_CHECK_FILE(/usr/share/java/flow-engine-0.9.2.jar,
       [ JFREEREPORT_JAR=/usr/share/java/flow-engine-0.9.2.jar ],
       [
-        AC_CHECK_FILE(/usr/share/java/flow-engine.jar, 
+        AC_CHECK_FILE(/usr/share/java/flow-engine.jar,
           [ JFREEREPORT_JAR=/usr/share/java/flow-engine.jar ],
           [AC_MSG_ERROR(jfreereport.jar replacement not found.)]
         )
@@ -6231,10 +6229,10 @@ if test -n "$enable_report_builder" -a "
   fi
 
   if test -z $LIBLAYOUT_JAR; then
-    AC_CHECK_FILE(/usr/share/java/liblayout-0.2.9.jar, 
+    AC_CHECK_FILE(/usr/share/java/liblayout-0.2.9.jar,
       [ LIBLAYOUT_JAR=/usr/share/java/liblayout-0.2.9.jar ],
       [
-        AC_CHECK_FILE(/usr/share/java/liblayout.jar, 
+        AC_CHECK_FILE(/usr/share/java/liblayout.jar,
           [ LIBLAYOUT_JAR=/usr/share/java/liblayout.jar ],
           [AC_MSG_ERROR(liblayout.jar replacement not found.)]
         )
@@ -6246,10 +6244,10 @@ if test -n "$enable_report_builder" -a "
   fi
 
   if test -z $LIBLOADER_JAR; then
-    AC_CHECK_FILE(/usr/share/java/libloader-1.0.0.jar, 
+    AC_CHECK_FILE(/usr/share/java/libloader-1.0.0.jar,
       [ LIBLOADER_JAR=/usr/share/java/libloader-1.0.0.jar ],
       [
-        AC_CHECK_FILE(/usr/share/java/libloader.jar, 
+        AC_CHECK_FILE(/usr/share/java/libloader.jar,
           [ LIBLOADER_JAR=/usr/share/java/libloader.jar ],
           [AC_MSG_ERROR(libloader.jar replacement not found.)]
         )
@@ -6261,10 +6259,10 @@ if test -n "$enable_report_builder" -a "
   fi
 
   if test -z $LIBFORMULA_JAR; then
-    AC_CHECK_FILE(/usr/share/java/libformula-0.2.0.jar, 
+    AC_CHECK_FILE(/usr/share/java/libformula-0.2.0.jar,
       [ LIBFORMULA_JAR=/usr/share/java/libformula-0.2.0.jar ],
       [
-        AC_CHECK_FILE(/usr/share/java/libformula.jar, 
+        AC_CHECK_FILE(/usr/share/java/libformula.jar,
           [ LIBFORMULA_JAR=/usr/share/java/libformula.jar ],
           [AC_MSG_ERROR(libformula.jar replacement not found.)]
         )
@@ -6276,10 +6274,10 @@ if test -n "$enable_report_builder" -a "
   fi
 
   if test -z $LIBREPOSITORY_JAR; then
-    AC_CHECK_FILE(/usr/share/java/librepository-1.0.0.jar, 
+    AC_CHECK_FILE(/usr/share/java/librepository-1.0.0.jar,
       [ LIBREPOSITORY_JAR=/usr/share/java/librepository-1.0.0.jar ],
       [
-        AC_CHECK_FILE(/usr/share/java/librepository.jar, 
+        AC_CHECK_FILE(/usr/share/java/librepository.jar,
           [ LIBREPOSITORY_JAR=/usr/share/java/librepository.jar ],
           [AC_MSG_ERROR(librepository.jar replacement not found.)]
         )
@@ -6291,10 +6289,10 @@ if test -n "$enable_report_builder" -a "
   fi
 
   if test -z $LIBFONTS_JAR; then
-    AC_CHECK_FILE(/usr/share/java/libfonts-1.0.0.jar, 
+    AC_CHECK_FILE(/usr/share/java/libfonts-1.0.0.jar,
       [ LIBFONTS_JAR=/usr/share/java/libfonts-1.0.0.jar ],
       [
-        AC_CHECK_FILE(/usr/share/java/libfonts.jar, 
+        AC_CHECK_FILE(/usr/share/java/libfonts.jar,
           [ LIBFONTS_JAR=/usr/share/java/libfonts.jar ],
           [AC_MSG_ERROR(libfonts.jar replacement not found.)]
         )
@@ -6306,10 +6304,10 @@ if test -n "$enable_report_builder" -a "
   fi
 
   if test -z $LIBSERIALIZER_JAR; then
-    AC_CHECK_FILE(/usr/share/java/libserializer-1.0.0.jar, 
+    AC_CHECK_FILE(/usr/share/java/libserializer-1.0.0.jar,
       [ LIBSERIALIZER_JAR=/usr/share/java/libserializer-1.0.0.jar ],
       [
-        AC_CHECK_FILE(/usr/share/java/libserializer.jar, 
+        AC_CHECK_FILE(/usr/share/java/libserializer.jar,
           [ LIBSERIALIZER_JAR=/usr/share/java/libserializer.jar ],
           [AC_MSG_ERROR(libserializer.jar replacement not found.)]
         )
@@ -6322,10 +6320,10 @@ if test -n "$enable_report_builder" -a "
 
 
   if test -z $LIBBASE_JAR; then
-    AC_CHECK_FILE(/usr/share/java/libbase-1.0.0.jar, 
+    AC_CHECK_FILE(/usr/share/java/libbase-1.0.0.jar,
       [ LIBBASE_JAR=/usr/share/java/libbase-1.0.0.jar ],
       [
-        AC_CHECK_FILE(/usr/share/java/libbase.jar, 
+        AC_CHECK_FILE(/usr/share/java/libbase.jar,
           [ LIBBASE_JAR=/usr/share/java/libbase.jar ],
           [AC_MSG_ERROR(libbase.jar replacement not found.)]
         )
@@ -6363,10 +6361,10 @@ if test "$with_system_apache_commons" =
   AC_MSG_RESULT([external])
 
   if test -z $COMMONS_LANG_JAR; then
-    AC_CHECK_FILE(/usr/share/java/commons-lang3-3.3.jar, 
+    AC_CHECK_FILE(/usr/share/java/commons-lang3-3.3.jar,
       [ COMMONS_LANG_JAR=/usr/share/java/commons-lang3-3.3.jar ],
       [
-        AC_CHECK_FILE(/usr/share/java/commons-lang.jar, 
+        AC_CHECK_FILE(/usr/share/java/commons-lang.jar,
           [ COMMONS_LANG_JAR=/usr/share/java/commons-lang.jar ],
           [AC_MSG_ERROR(commons-lang.jar replacement not found.)]
         )
@@ -6394,10 +6392,10 @@ if test "$with_system_apache_commons" =
 
   if test "$ENABLE_MEDIAWIKI" = "YES"; then
     if test -z $COMMONS_CODEC_JAR; then
-      AC_CHECK_FILE(/usr/share/java/commons-codec-1.9.jar, 
+      AC_CHECK_FILE(/usr/share/java/commons-codec-1.9.jar,
         [ COMMONS_CODEC_JAR=/usr/share/java/commons-codec-1.9.jar ],
         [
-          AC_CHECK_FILE(/usr/share/java/commons-codec.jar, 
+          AC_CHECK_FILE(/usr/share/java/commons-codec.jar,
             [ COMMONS_CODEC_JAR=/usr/share/java/commons-codec.jar ],
             [AC_MSG_ERROR(commons-codec.jar replacement not found.)]
           )
@@ -6409,10 +6407,10 @@ if test "$with_system_apache_commons" =
     fi
 
     if test -z $COMMONS_HTTPCLIENT_JAR; then
-      AC_CHECK_FILE(/usr/share/java/commons-httpclient-3.1.jar, 
+      AC_CHECK_FILE(/usr/share/java/commons-httpclient-3.1.jar,
         [ COMMONS_HTTPCLIENT_JAR=/usr/share/java/commons-httpclient-3.1.jar ],
         [
-          AC_CHECK_FILE(/usr/share/java/commons-httpclient.jar, 
+          AC_CHECK_FILE(/usr/share/java/commons-httpclient.jar,
             [ COMMONS_HTTPCLIENT_JAR=/usr/share/java/commons-httpclient.jar ],
             [AC_MSG_ERROR(commons-httpclient.jar replacement not found.)]
           )
@@ -6425,10 +6423,10 @@ if test "$with_system_apache_commons" =
   fi
   if test "$ENABLE_MEDIAWIKI" = "YES" -o "$ENABLE_REPORTBUILDER" = "YES"; then
     if test -z $COMMONS_LOGGING_JAR; then
-      AC_CHECK_FILE(/usr/share/java/commons-logging-1.1.3.jar, 
+      AC_CHECK_FILE(/usr/share/java/commons-logging-1.1.3.jar,
         [ COMMONS_LOGGING_JAR=/usr/share/java/commons-logging-1.1.3.jar ],
         [
-          AC_CHECK_FILE(/usr/share/java/commons-logging.jar, 
+          AC_CHECK_FILE(/usr/share/java/commons-logging.jar,
             [ COMMONS_LOGGING_JAR=/usr/share/java/commons-logging.jar ],
             [AC_MSG_ERROR(commons-logging.jar replacement not found.)]
           )
@@ -6507,7 +6505,7 @@ if test "$test_kde" = "yes" -a "$ENABLE_
     done
     AC_MSG_RESULT([$qt_incdir])
     if test "x$qt_incdir" = "xno" ; then
-        AC_MSG_ERROR([Qt headers not found.  Please specify the root of
+        AC_MSG_ERROR([Qt headers not found. Please specify the root of
 your Qt installation by exporting QTDIR before running "configure".])
     fi
 
@@ -6522,14 +6520,14 @@ your Qt installation by exporting QTDIR
     done
     AC_MSG_RESULT([$qt_libdir])
     if test "x$qt_libdir" = "xno" ; then
-        AC_MSG_ERROR([Qt libraries not found.  Please specify the root of
+        AC_MSG_ERROR([Qt libraries not found. Please specify the root of
 your Qt installation by exporting QTDIR before running "configure".])
     fi
 
     dnl Check for Meta Object Compiler
     AC_PATH_PROG( MOC, moc, no, [$QTDIR/bin:$PATH] )
     if test "$MOC" = "no" ; then
-        AC_MSG_ERROR([Qt Meta Object Compiler not found.  Please specify
+        AC_MSG_ERROR([Qt Meta Object Compiler not found. Please specify
 the root of your Qt installation by exporting QTDIR before running "configure".])
     fi
 
@@ -6544,7 +6542,7 @@ the root of your Qt installation by expo
     done
     AC_MSG_RESULT([$kde_incdir])
     if test "x$kde_incdir" = "xno" ; then
-        AC_MSG_ERROR([KDE headers not found.  Please specify the root of
+        AC_MSG_ERROR([KDE headers not found. Please specify the root of
 your KDE installation by exporting KDEDIR before running "configure".])
     fi
 
@@ -6559,7 +6557,7 @@ your KDE installation by exporting KDEDI
     done
     AC_MSG_RESULT([$kde_libdir])
     if test "x$kde_libdir" = "xno" ; then
-        AC_MSG_ERROR([KDE libraries not found.  Please specify the root of
+        AC_MSG_ERROR([KDE libraries not found. Please specify the root of
 your KDE installation by exporting KDEDIR before running "configure".])
     fi
 
@@ -6581,10 +6579,10 @@ MOC4="moc"
 if test "$test_kde4" = "yes" -a "$ENABLE_KDE4" = "TRUE" ; then
    qt_incdirs="$QT4INC $QT4DIR /usr/include/qt4 /usr/include $x_includes"
    qt_libdirs="$QT4LIB /usr/lib $x_libraries"
-   
+
    kde_incdirs="/usr/include /usr/include/kde4 $x_includes"
    kde_libdirs="/usr/lib /usr/lib/kde4 /usr/lib/kde4/devel $x_libraries"
-   
+
    if test "$build_cpu" = "x86_64" ; then
       qt_libdirs="$qt_libdirs /usr/lib64/qt4 /usr/lib64/qt /usr/lib64"
       kde_libdirs="$kde_libdirs /usr/lib64 /usr/lib64/kde4 /usr/lib64/kde4/devel"
@@ -6603,7 +6601,7 @@ if test "$test_kde4" = "yes" -a "$ENABLE
    qt_test_library="libQtCore.so"
    kde_test_include="ksharedptr.h"
    kde_test_library="libkdeui.so"
-   
+
    AC_MSG_CHECKING([for Qt4 headers])
    qt_header_dir="no"
    for inc_dir in $qt_incdirs ; do
@@ -6612,12 +6610,12 @@ if test "$test_kde4" = "yes" -a "$ENABLE
          break
       fi
    done
-   
+
    AC_MSG_RESULT([$qt_header_dir])
    if test "x$qt_header_dir" = "xno" ; then
-      AC_MSG_ERROR([Qt4 headers not found.  Please specify the root of your Qt4 installation by exporting QT4DIR before running "configure".])
+      AC_MSG_ERROR([Qt4 headers not found. Please specify the root of your Qt4 installation by exporting QT4DIR before running "configure".])
    fi
-   
+
    AC_MSG_CHECKING([for Qt4 libraries])
    qt_lib_dir="no"
    for lib_dir in $qt_libdirs ; do
@@ -6626,11 +6624,11 @@ if test "$test_kde4" = "yes" -a "$ENABLE
          break
       fi
    done
-   
+
    AC_MSG_RESULT([$qt_lib_dir])
-   
+
    if test "x$qt_lib_dir" = "xno" ; then
-      AC_MSG_ERROR([Qt4 libraries not found.  Please specify the root of your Qt4 installation by exporting QT4DIR before running "configure".])
+      AC_MSG_ERROR([Qt4 libraries not found. Please specify the root of your Qt4 installation by exporting QT4DIR before running "configure".])
    fi
 
    dnl Check for Meta Object Compiler
@@ -6639,7 +6637,7 @@ if test "$test_kde4" = "yes" -a "$ENABLE
    if test "$MOC4" = "no" ; then
       AC_PATH_PROG( MOC4, moc, no, [$PATH:$QT4DIR/bin] )
       if test "$MOC4" = "no" ; then
-         AC_MSG_ERROR([Qt Meta Object Compiler not found.  Please specify the root of your Qt installation by exporting QT4DIR before running "configure".])
+         AC_MSG_ERROR([Qt Meta Object Compiler not found. Please specify the root of your Qt installation by exporting QT4DIR before running "configure".])
       fi
    fi
 
@@ -6654,7 +6652,7 @@ if test "$test_kde4" = "yes" -a "$ENABLE
    done
    AC_MSG_RESULT([$kde_incdir])
    if test "x$kde_incdir" = "xno" ; then
-      AC_MSG_ERROR([KDE4 headers not found.  Please specify the root of your KDE4 installation by exporting KDE4DIR before running "configure".])
+      AC_MSG_ERROR([KDE4 headers not found. Please specify the root of your KDE4 installation by exporting KDE4DIR before running "configure".])
    fi
 
    dnl Check for KDE4 libraries
@@ -6666,10 +6664,10 @@ if test "$test_kde4" = "yes" -a "$ENABLE
          break
       fi
    done
-   
+
    AC_MSG_RESULT([$kde_libdir])
    if test "x$kde_libdir" = "xno" ; then
-      AC_MSG_ERROR([KDE4 libraries not found.  Please specify the root of your KDE4 installation by exporting KDE4DIR before running "configure".])
+      AC_MSG_ERROR([KDE4 libraries not found. Please specify the root of your KDE4 installation by exporting KDE4DIR before running "configure".])
    fi
 
    KDE4_CFLAGS="`pkg-config --cflags QtCore` `pkg-config --cflags QtGui` -I$kde_incdir -DQT_CLEAN_NAMESPACE -DQT_THREAD_SUPPORT"
@@ -6706,7 +6704,7 @@ else
 fi
 AC_SUBST(ENABLE_EVOAB2)
 AC_SUBST(GOBJECT_CFLAGS)
-AC_SUBST(GOBJECT_LIBS) 
+AC_SUBST(GOBJECT_LIBS)
 
 dnl ===================================================================
 dnl Test whether to include MathMLDTD
@@ -7046,7 +7044,7 @@ EOF
   fi
   AC_TRY_EVAL(ant_cmd)
   if test $? = 0 && test -f ./conftest.class ; then
-    AC_MSG_RESULT([Ant works]) 
+    AC_MSG_RESULT([Ant works])
     if test -z "$WITH_ANT_HOME"; then
         ANT_HOME=`$ANT -diagnostics | $EGREP "ant.home :" | $SED -e "s#ant.home : ##g"`
         if test -z "$ANT_HOME"; then
@@ -7075,10 +7073,10 @@ dnl Checking for ant.jar
 if test "$ANT_HOME" != "NO_ANT_HOME"; then
    AC_MSG_CHECKING([Ant lib directory])
    if test -f $ANT_HOME/lib/ant.jar; then
-	  ANT_LIB="$ANT_HOME/lib"
+    ANT_LIB="$ANT_HOME/lib"
    else
       if test -f $ANT_HOME/ant.jar; then
-	     ANT_LIB="$ANT_HOME"
+         ANT_LIB="$ANT_HOME"
       else
           if test -f /usr/share/java/ant.jar; then
               ANT_LIB=/usr/share/java
@@ -7094,7 +7092,7 @@ if test "$ANT_HOME" != "NO_ANT_HOME"; th
                    else
                        AC_MSG_ERROR([Ant libraries not found!])
                    fi
-                fi  
+                fi
              fi
           fi
       fi
@@ -7161,7 +7159,7 @@ EOF
   fi
   AC_TRY_EVAL(ant_cmd)
   if test $? = 0 && test -f ./conftest.class ; then
-    AC_MSG_RESULT([yes]) 
+    AC_MSG_RESULT([yes])
     rm -rf confdir
   else
     echo "configure: Ant test failed" >&5
@@ -7396,7 +7394,7 @@ AC_SUBST(OOO_VENDOR)
 
 UNIXWRAPPERNAME=
 AC_MSG_CHECKING([for UNIX wrapper name])
-if test -z "$with_unix_wrapper" -o "$with_unix_wrapper" = "no"  -o "$with_unix_wrapper" = "yes" ; then
+if test -z "$with_unix_wrapper" -o "$with_unix_wrapper" = "no" -o "$with_unix_wrapper" = "yes" ; then
    AC_MSG_RESULT([not set])
 else
    UNIXWRAPPERNAME="$with_unix_wrapper"
@@ -7409,7 +7407,7 @@ if test -n "$enable_static_gtk" && test
    ENABLE_STATIC_GTK="TRUE"
    AC_MSG_RESULT([yes])
 else
-   ENABLE_STATIC_GTK="FALSE"	
+   ENABLE_STATIC_GTK="FALSE"
    AC_MSG_RESULT([no])
 fi
 AC_SUBST(ENABLE_STATIC_GTK)
@@ -7419,7 +7417,7 @@ if test -n "$enable_layout" && test "$en
    ENABLE_LAYOUT="TRUE"
    AC_MSG_RESULT([yes])
 else
-   ENABLE_LAYOUT="FALSE"	
+   ENABLE_LAYOUT="FALSE"
    AC_MSG_RESULT([no])
 fi
 AC_SUBST(ENABLE_LAYOUT)
@@ -7483,7 +7481,7 @@ AC_SUBST(LOCAL_SOLVER)
 AC_SUBST(BUILD_TYPE)
 AC_SUBST(ADDITIONAL_REPOSITORIES)
 
-# make sure config.guess is +x; we execute config.guess, so it has to be so; 
+# make sure config.guess is +x; we execute config.guess, so it has to be so;
 chmod +x ./config.guess
 
 # Create files from their *.in templates.
@@ -7513,5 +7511,5 @@ else
       echo There were no warnings
    fi
    echo
-fi   
+fi
 



Mime
View raw message