openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jürgen Schmidt <>
Subject Re: [CODE]: spellchecker, hunspell, MacOS
Date Mon, 28 Nov 2011 14:36:39 GMT
On 11/25/11 6:19 PM, Ariel Constenla-Haile wrote:
> On Fri, Nov 25, 2011 at 05:32:39PM +0100, Jürgen Schmidt wrote:
>> On 11/25/11 3:54 PM, Ariel Constenla-Haile wrote:
>>> Hi Jürgen,
>>> On Fri, Nov 25, 2011 at 02:47:45PM +0100, Jürgen Schmidt wrote:
>>>> Hi,
>>>> do anybody know if Hunspell is also used and necessary on MacOS?
>>>> I noticed some build problems after the latest update and did a
>>>> build without --enable-hunspell. The build breaks in
>>>> lingucomponent/.../macspellimpl.cxx
>>> it was me who removed the dependency on hunspell there.
>>> By reading the sources (I don't have a MacOS, and never will) in
>>> trunk/main/lingucomponent/source/spellcheck/macosxspell/
>>> that code has no dependency at all in libhunspell.
>> no problem at all
>>> The dependency on hunspell was spread all over the components there,
>>> sure a bug of copy-and-pasting the makefiles.
>> probably yes
>>> So you should be able to build the MacOSXSpell component without
>>> hunspell enabled, and spell checking should work with only this
>>> component installed. Otherwise, its a bug (I tested the changes both on
>>> Linux and WinXP and the three components can be build and installed
>>> independently form each other; the same should work in MacOS).
>> that was my understanding as well
>>>> There was still a dependency to some types defined in Hunspell. I
>>>> tried to fix that and was able to build...
>>> that's quite strange. Do you have the logs?
>>> Was it a clean build?
>> yes, and it was simple compiler error, "dictentry" not defined ...
>> But the whole code looks strange, some places were changed where
>> this type was used before. I have changed the code and removed
>> unused stuff...
>>> The dependency on hunspell should now be only limited to
>>> trunk/main/lingucomponent/source/spellcheck/spell/ that is the only UNO
>>> component that interfaces with libhunspell.
>>> All the other code in lingusitic and lingucomponent should work out fo
>>> the box without hunspell.
>> after my small changes it built as expected
>>>> But it seems that spellchecking doesn't work,
>>> for spell checking to work you need the dictionaries (I have no idea
>>> what kind of dictionaries supports MacOS), but without dictionaries
>>> installed the UNO component are not even listed in Tools - Options
>>> - Linguistic - Writing Aids
>> i used an English version and at least the English dictionary is
>> installed. In other built office versions the spellchecker worked.
>>>> and also redlining doesn't work.
>>> AFAIK redlining does not depend on spell checking
>> but on dictionaries, i am no expert here and have to take a closer
>> look on it
>>>> Before i take a closer look in this problem i would
>>>> like to know if it should work without Hunspell in general.
>>> AFAIK it should, just look at the sources, macspellimp.hxx and
>>> macspellimp.cxx have no reference to hunpsell (the references I removed
>>> - look at the log - where there just because of a copy-and-paste error
>> >from the hunspell spell checker; the same is valid for the
>> yes i have seen it.
>> I assumed that somewhere is something triggered by Hunspell that now
>> doesn't work. I don't know yet. The only thing i see is that it
>> doesn't work. I will keep you informed.
> see if the attached patch solves your issue.
indeed you patch solves the problem and the spellchecker is now working 
on MacOS as well without --enable-hunspell.

I will integrate it with my changes in the code. But there is still some 
work for MacOS open to handle user dictionaries in a proper way or to 
clean the code finally. Postponed to later.


View raw message