openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joost Andrae <Joost.And...@gmx.de>
Subject Re: What does "supported" mean for us?
Date Wed, 02 Jan 2013 08:49:04 GMT
Hi,

> So is Vista supported?   It certainly isn't deprecated.  But neither
> is it getting the full QA treatment.  Similar questions for Linux
> releases.  We don't test every release of every distro.  We pick the
> major ones, such as the Ubuntu LTS releases.
>

on Vista I would be surprised if AOO won't run on it.
On Linux if AOO picks a defined version of a Linux distro as a 
'supported' one then this would be the wrong decision. 'Supporting' has 
to be seen in a more technical manner not from the 'commercial support' 
POV. In the past OOo was built by using a build infrastructure that 
allowed OOo to run the binary on most of the Linux distributions. There 
were just a few distros that failed because they were incompatible to 
everything else.

Platform compatibility depends on some prerequisites (just some examples):

glibc versions supported
system dependent system integration (eg. on KDE, Gnome, etc.)
drag&drop support
clipboard support
sane support on that platform
java dependencies on that platform (eg. Sun Java version, OpenSource 
derivates)

The more important question is: Is AOO a LSB compatible application ?



Kind regards, Joost


Mime
View raw message