openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Le Quan Ha" ...@canwrx.com>
Subject RE: Re: Setup OpenOffice as a Windows Server service
Date Mon, 22 Apr 2013 23:27:41 GMT
Dear Rob,

I already fixed it by running command line inside PhP and I do not need to call OpenOffice
as a Windows Server 2012 service any more.
I just call straightly php code each time

exec("\"C:\Program Files (x86)\OpenOffice.org 3\program\soffice.exe\" -headless -accept=\"socket,port=2002;urp;\"
-nofirststartwizard 2>&1");

Hence, I would like to close this,

Le Quan Ha

Canwrx Group Ltd
1407, 240-70 Shawville Blvd SE, Calgary, AB T2Y 2Z3 (Mailing address)
220-11625 Elbow Drive SW, Calgary, AB T2W 1G8 (Physical address)
PH: 403 508 2719
FX: 403 508 2698

This email and any files transmitted with it are confidential and intended solely for the
use of the individual or entity to whom they are addressed. If you have received this email
in error please notify the system manager. This message contains confidential information
and is intended only for the individual named. If you are not the named addressee you should
not disseminate, distribute or copy this e-mail.

-----Original Message-----
From: Le Quan Ha [mailto:ha@canwrx.com] 
Sent: Friday, April 19, 2013 1:00 AM
To: robweir@apache.org
Cc: dev@openoffice.apache.org
Subject: Re: Re: Setup OpenOffice as a Windows Server service

Dear Rob, 

> 1) Run OpenOffice 3.4.1 on your old Windows 2008 server, and see if that works.

I can't change the old server as it is running to serve customers 24h but I chose another
option as you suggested
> 2) Run OpenOffice 3.1 on your new Windows 2012 server. 
Result: there is no service started on my Windows 2012 server with OpenOffice 3.1, same error
as 3.4

I followed this guide to make the OO service: 
http://www.artofsolving.com/node/11 

except inside this guide, I did not see the file in step 7 share\registry\data\org\openoffice\Setup.xcu
to repair it.

May I ask you how to set the OpenOffice to run as service on Windows 2012 64-bit?

Thank you,
Ha.
Canwrx Group Ltd
#220, 11625 Elbow Dr. SW
Calgary, AB T2W 1G8
Employers PH: 403 508 2719
Workers PH: 403-514-6957
FX: 403 508 2698
Skype: canwrx


----- Original Message -----
From: Rob Weir [mailto:robweir@apache.org]
To: dev@openoffice.apache.org,ha@canwrx.com
Sent: Thu, 18 Apr 2013 19:14:48 -0400
Subject: Re: Setup OpenOffice as a Windows Server service

On Thu, Apr 18, 2013 at 4:42 PM, Le Quan Ha <ha@canwrx.com> wrote:

> Dear OpenOffice Development, ****
>
> ** **
>
> I would like to ask an OpenOffice question: previously we linked you 
> OpenOffice 3.1, 32-bit into our old Windows Server 2008 Standard and 
> setup OpenOffice 3.1 as a server service to read and parse .doc, .docx  
> document files  into our PhP software. Hence, whenever web users 
> upload their .doc, .docx files, we sent it to Windows Server 2008 
> service and return the content of the MS Word file, working very well 
> through  MS Word 97-2003 until Word 2010.****
>
> ** **
>
> PROBLEM: Now we discovered that you just develop a newer version 
> OpenOffice 3.4, 64-bit and we change to use a new Windows Server 2012
> 64-bit.****
>
> But may you check this for us: when I setup your newest version 64-bit 
> OpenOffice 3.4 as a Windows Server 2012 service called OO, this OO 
> service could not start with error: ****
>
> **
>

First, Apache OpenOffice 3.4.1 has 64-bit version for Linux only.  The Windows version is
available only in a 32-bit version.

Second, you are changing two variables at once:  the version of Windows and the version of
OpenOffice.  So it is hard to tell which is causing the problem.  If at all possible it would
be good to try one of two things:

1) Run OpenOffice 3.4.1 on your old Windows 2008 server, and see if that works.

or

2) Run OpenOffice 3.1 on your new Windows 2012 server.



> **
>
> “Windows could not start the OO service on Local Computer. Error 1053: 
> The service did not respond to the start or control request in a 
> timely
> fashion.”****
>
> **
>


Maybe the message is familiar to someone else in the community?   Let's
give it a few more hours.

Regards,

-Rob



> **
>
> What is changing in the settings of your newest version 64-bit 
> OpenOffice
> 3.4 and Windows Server 2012? Currently, I just set it as  before on 
> the old Windows Server 2008 ****
>
> Application:     “C:\Program Files (x86)\OpenOffice.org
> 3\program\soffice.exe”****
>
> AppParameters:    “-headless -accept=socket,port=2002;urp;”****
>
> ** **
>
> Urgently,****
>
> I would like to appreciate in advance,****
>
> Yours sincerely, ****
>
> *Le Quan Ha*
>
> *[image: Description: small_clear_logo]*
>
> *Canwrx Group Ltd*
>
> *1407, 240-70 Shawville Blvd SE, Calgary, AB T2Y 2Z3 (Mailing 
> address)*
>
> 220-11625 Elbow Drive SW, Calgary, AB T2W 1G8 (Physical address)****
>
> *PH: *403 508 2719****
>
> *FX: *403 508 2698**
>
> ** **
>
> This email and any files transmitted with it are confidential and 
> intended solely for the use of the individual or entity to whom they are addressed.
> If you have received this email in error please notify the system manager.
> This message contains confidential information and is intended only 
> for the individual named. If you are not the named addressee you 
> should not disseminate, distribute or copy this e-mail.****
>
> ** **
>




---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message