openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 張仁瀚 <yohey03...@gmail.com>
Subject Re: Use GDB but no debugging symbols found
Date Wed, 21 Aug 2013 18:22:19 GMT
Well,thank you for your help. I learned a lot but I got a new error that I
can't fix it. It looks like something happened to the module svgio.

Here is the log:

$ build debug=true --all
...
...
...
/home/yohey/AOO/aoo-trunk/main/svgio/source/svgreader/svgsvgnode.cxx:636:71:
error: taking address of temporary [-fpermissive]
/home/yohey/AOO/aoo-trunk/main/svgio/source/svgreader/svgsvgnode.cxx:679:75:
error: taking address of temporary [-fpermissive]
/home/yohey/AOO/aoo-trunk/main/svgio/source/svgreader/svgsvgnode.cxx:698:67:
error: taking address of temporary [-fpermissive]
make: *** [/home/yohey/AOO/aoo-trunk/main/solver/410/
unxlngx6.pro/workdir/CxxObject/svgio/source/svgreader/svgsvgnode.o] Error 1
dmake:  Error code 2, while making 'all'

1 module(s):
    svgio
need(s) to be rebuilt

Reason(s):

ERROR: error 65280 occurred while making
/home/yohey/AOO/aoo-trunk/main/svgio/prj

When you have fixed the errors in that module you can resume the build by
running:

    build --all:svgio


I have tried to find some useful information on wiki or other webs, but
failed...

Thanks for your patient and help.


    Yohey


2013/8/21 Herbert Duerr <hdu@apache.org>

> On 21.08.2013 11:07, 張仁瀚 wrote:
> > Thanks for your help.
> > But I can't build with debug=1, even I had do that with a new clean
> sources.
> > I can use "build killobj ; build debug=1" in the source which has been
> > built once previously. But it still didn't work and get a message "no
> > debugging symbols found" when I ran AOO with gdb just like the question
> in
> > my previous mail.
> >
> > Here is the build log with a new clean source:
> >
> >    $ build debug=true
> > build -- version: 275224
> >
> > =============
> > Building module instsetoo_native
> > =============
>
> The instructions I provided where for getting the debug symbols for
> individual modules. The instsetoo_native module is special because it is
> a meta-module only that has dependencies on the "real" modules. It
> doesn't have symbols itself. Also cleaning it up doesn't clean up the
> other modules so their object files will not be regenerated. When
> building in instsetoo_native one normally uses the "--all" option to
> make sure the modules it depends on are visited.
>
> For an introduction into the building process with many good pointers
> please see [1].
>
> [1] http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO
>
> Herbert
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> For additional commands, e-mail: dev-help@openoffice.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message