openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 張仁瀚 <yohey03...@gmail.com>
Subject Re: Use GDB but no debugging symbols found
Date Thu, 22 Aug 2013 16:16:25 GMT
Thanks a lot! It seems that I have fixed this error by replacing those
source code provided by your link [2]. It had continued building for a long
time but I bumped into another error...

**************************************************
ERROR: ERROR: unopkg sync --verbose -env:UNO_JAVA_JFW_ENV_JREHOME=true 2>&1
| failed!
in function: register_extensions
**************************************************

**************************************************
ERROR: Saved logfile: /home/yohey/AOO/aoo-trunk/main/instsetoo_native/
unxlngx6.pro/Apache_OpenOffice/archive/logging/en-US/log_AOO410_en-US.log
**************************************************
Wed Aug 21 19:52:44 2013 (01:58 min.)
dmake:  Error code 255, while making 'openoffice_en-US.archive'

1 module(s):
    instsetoo_native
need(s) to be rebuilt
Reason(s):

ERROR: error 65280 occurred while making
/home/yohey/AOO/aoo-trunk/main/instsetoo_native/util



Besides don't know how to fix this error, I have another question. Will
anyone who want to build AOO with "debug=true" all bump into these error I
have gotten or other errors I may encounter in the future? How they fix
them if they are new to AOO? Just by the way like I use or any other ways?

Thanks.

   Yohey.


2013/8/22 Herbert Duerr <hdu@apache.org>

> Hi Yohey,
>
> On 21.08.2013 20:22, 張仁瀚 wrote:
> > Well,thank you for your help. I learned a lot but I got a new error that
> I
> > can't fix it. It looks like something happened to the module svgio.
> >
> > Here is the log:
> >
> > $ build debug=true --all
> > ...
> > ...
> > ...
> >
> /home/yohey/AOO/aoo-trunk/main/svgio/source/svgreader/svgsvgnode.cxx:636:71:
> > error: taking address of temporary [-fpermissive]
>
> That is a known problem [1] that was fixed yesterday [2]. Please update
> your source to the latest trunk version and rerun the build again.
>
> [1] http://markmail.org/message/bertvcsy2djpvaot
> [2] http://svn.apache.org/viewvc?view=revision&revision=r1516122
>
> > I have tried to find some useful information on wiki or other webs, but
> > failed...
>
> You are doing great so far! :-)
>
> Herbert
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> For additional commands, e-mail: dev-help@openoffice.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message