openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From J├╝rgen Schmidt <jogischm...@gmail.com>
Subject Problem with building branch l10n40 on MacOS
Date Thu, 10 Oct 2013 11:56:31 GMT
Hi Jan,

as promised I tried to build the l10n40 branch on MacOS. I started with
my normal config settings and included some languages (keyid bg da de
en-US).

The first error I got was in l10ntools, makedepend was missing which is
built in soltools. This is strange because l10tools has a build
dependency on soltools. Anyway solving this manually I got the next
error in l10ntools.

The next problem was that lucene was not built and here the build
dependency is missing in l10ntools/prj/build.lst. Solving manually ...

Next problem is a missing hash_map header

In file included from
.../svn/l10n40/main/l10ntools/source/help/HelpLinker.cxx:24:
.../svn/l10n40/main/l10ntools/source/help/HelpCompiler.hxx:28:20: error:
hash_map: No such file or directory
.../l10n40/main/l10ntools/source/help/HelpCompiler.hxx:37:32: error:
boost/shared_ptr.hpp: No such file or directory


It seems that some build dependencies are missing ... I will continue
when I have time ...

Is the branch in sync with trunk or nearly up-to-date?

My recommendation is to build from scratch with a clean env to detect
missing dependencies.


Juergen

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message