openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jürgen Schmidt <jogischm...@gmail.com>
Subject Re: Error installing an extension
Date Mon, 21 Oct 2013 07:40:39 GMT
On 10/19/13 9:21 AM, Jörg Schmidt wrote:
> Hello,
> 
> I received a confirmation, because of my help on offer:
> http://wiki.openoffice.org/wiki/Extensions_Packager#BasicAddonBuilder_and_AOO_4.x
> 
> When installing an S-extension occurs an error message.
> Can someone only based on the following error message saying what the problem is?
> 
> The error-message is:
> 
> (com.sun.star.deployment.DeploymentException){{Message="An error occurred while enabling:
TestProgramMacro". Context = 
> (com.sun.star.unoXInterface) @bbe9010}, Cause = (any){(com.sun.star.lang.IllegalArgumentException)
{{Message = 
> "",Context=(com.sun.star.uno.XInterface) @0},ArgumentPosition=(short)0}}}
> 
> 

the error handling is far from good or optimal in this context. It's not
possible to identify the root cause for this highlevel exception.

But by the way I was able to install the extension version 0.5.1 from
the wiki page in AOO 4.0.1 on MacOS without problems.

Or do you mean that created extensions with the addon builder have this
problem?

Juergen

> 
> 
> Greetings,
> Jörg
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> For additional commands, e-mail: dev-help@openoffice.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message