openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andre Fischer <awf....@gmail.com>
Subject Re: Error installing an extension
Date Mon, 21 Oct 2013 07:44:34 GMT
On 19.10.2013 09:21, Jörg Schmidt wrote:
> Hello,
>
> I received a confirmation, because of my help on offer:
> http://wiki.openoffice.org/wiki/Extensions_Packager#BasicAddonBuilder_and_AOO_4.x
>
> When installing an S-extension occurs an error message.
> Can someone only based on the following error message saying what the problem is?
>
> The error-message is:
>
> (com.sun.star.deployment.DeploymentException){{Message="An error occurred while enabling:
TestProgramMacro". Context =
> (com.sun.star.unoXInterface) @bbe9010}, Cause = (any){(com.sun.star.lang.IllegalArgumentException)
{{Message =
> "",Context=(com.sun.star.uno.XInterface) @0},ArgumentPosition=(short)0}}}

Sadly, the error messages of the extension manager are very unhelpful.   
I can only see that some UNO call was made that did error checking and 
detected that one of its arguments was invalid but did not bother to 
provide additional information (Message = "", Context =...@0,  the 
ArgumentPosition may or may not have been set to 0).

The missing diagnostics in this area is often a real obstacle.  We 
should try to improve it.

-Andre

>
>
>
>
> Greetings,
> Jörg
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> For additional commands, e-mail: dev-help@openoffice.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message