openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jan i <j...@apache.org>
Subject Re: build breaker in solenv/bin/modules/install/logger.pm on ubuntu 12.04
Date Mon, 02 Dec 2013 16:08:34 GMT
On 2 December 2013 10:14, Andre Fischer <awf.aoo@gmail.com> wrote:

> On 02.12.2013 09:23, jan i wrote:
>
>> On 2 December 2013 09:14, Andre Fischer <awf.aoo@gmail.com> wrote:
>>
>>  On 01.12.2013 13:40, Efi wrote:
>>>
>>>  On 11/30/2013 04:54 PM, jan i wrote:
>>>>
>>>>  Hi.
>>>>>
>>>>>
>>>>> It seems the latest changes in logger.pm leads to a buildbreaker in
>>>>> instset_native.
>>>>>
>>>>> svn tell that this file was updated today, but I am not good at perl,
>>>>> at
>>>>> I
>>>>> cannot see what the problem is.
>>>>>
>>>>> Output from build --all:
>>>>>
>>>>> ... using package from pool
>>>>> ... creating epm list file epm_gid_Module_Root.lst ...
>>>>> ... checking pool package ...
>>>>> Stack Trace:
>>>>> /share/opensource/aoo/trunk/main/solenv/bin/modules/
>>>>> installer/logger.pm:206in
>>>>> function installer::logger::Die
>>>>> /share/opensource/aoo/trunk/main/solenv/bin/modules/
>>>>> installer/logger.pm:189in
>>>>> function installer::logger::print
>>>>> /share/opensource/aoo/trunk/main/solenv/bin/modules/installer/
>>>>> packagepool.pm:172 in function installer::logger::printf
>>>>> /share/opensource/aoo/trunk/main/solenv/bin/modules/installer/
>>>>> packagepool.pm:667 in function
>>>>> installer::packagepool::compare_package_content
>>>>> /share/opensource/aoo/trunk/main/solenv/bin/make_installer.pl:930 in
>>>>> function installer::packagepool::package_is_up_to_date
>>>>> /share/opensource/aoo/trunk/main/solenv/bin/make_installer.pl:2140 in
>>>>> function main::MakeNonWindowsBuild
>>>>> newline at start of line at
>>>>> /share/opensource/aoo/trunk/main/solenv/bin/modules/
>>>>> installer/logger.pmline
>>>>> 738.
>>>>> dmake:  Error code 255, while making 'openoffice_en-US.rpm'
>>>>>
>>>>> 1 module(s):
>>>>>           instsetoo_native
>>>>>
>>>>>
>>>>> any advice ?
>>>>>
>>>>>
>>>>>  Yes, can you try this patch?
>>> https://issues.apache.org/ooo/attachment.cgi?id=82021&action=diff
>>>
>>> I will commit this patch later this day unless I hear that it does not
>>> work (no, this not meant as a thread :-)
>>>
>>>  I will try the patch a bit later today.
>>
>>  Alternatively, or additionally, can you tell me how you build?  The
>>> offending code is not triggered by our build bot builds nor by my local
>>> builds.  It is good that you found this, I would like to be able to
>>> reproduce it.
>>>
>>>  Environment: Ubuntu 12.04 (server) standard installation
>> ./configure --with-jdk-home=/usr/lib/jvm/java-6-openjdk \
>>              --with-dmake-url=
>> http://dmake.apache-extras.org.codespot.com/files/dmake-4.12.tar.bz2 \
>>              --with-epm-url=
>> http://www.msweet.org/files/project2/epm-3.7-source.tar.gz \
>>              --enable-verbose \
>>              --enable-category-b \
>>              --enable-opengl \
>>              --enable-dbus \
>>              --enable-gstreamer \
>>              --enable-bundled-dictionaries \
>>              --with-lang="da en-US es" \
>>              --with-package-format="rpm deb" \
>>              --with-vendor="jani local build"
>>
>>
>> I hope that helps. As you know I build very often, and this problem came
>> with the latest "svn up" on trunk.
>>
>
> Interesting.  I would have thought the relevant changes were active for a
> while now.
> Anyway, do you use the  --with-packager-list= option when you call
> configure?
> I expect that to trigger the build breaker.
>

Not so interesting, your comment made me go back through the log files. The
configure above is my standard configure, but I have been using
--with-packager-list the last period to test a couple of things.


>
>
>
>> thanks in advance for your patch.
>>
>
> I break it, I fix it.
>

thx.
rgds
jan I.

>
>
> Regards,
> Andre
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> For additional commands, e-mail: dev-help@openoffice.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message