openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Herbert Duerr <...@apache.org>
Subject Re: Using system boost 1.54 (was Re: EXTERNAL: Re: Building comphelper)
Date Thu, 02 Jan 2014 14:32:40 GMT
Happy new year!

A small update on the problem Kay mentioned:

On 23.12.2013 08:51, Herbert Duerr wrote:
> Kay Schenk wrote:
>> On Fri, Dec 13, 2013 at 6:04 AM, Herbert Duerr <hdu@apache.org> wrote:
>>> [...]
>>> In your installation the hash template is apparently already mapped to the
>>> std namespace, so us trying to map it there again causes trouble. To verify
>>> this idea you could comment out the
>>>          using STLP4_EMUBASE_NS::hash;
>>> lines in booth main/stlport/systemstl/hash_* files.
>>>
>>
>> a short update on my progress...
>>
>> The suggestion above worked for that problem...
>
> Wonderful! This means some parts (or all?) of boost's tr1 headers are
> already directly into the std namespace. And they are of course also
> available in the std::tr1 namespace where they come from. Please have a
> look at the preprocessor output. To see what the compiler sees to achive
> this.

If you compiled in C++11 mode then the C++11 templates for TR1 libraries 
are already required to be in the std namespace. When I tried it out 
myself I saw similar problems to the ones you saw. I fixed them in issue 
123947 / revision 1554812 on trunk. You might want to try it out.

Kay, did you explicitly enable C++11 mode for your Linux build? AFAIK 
C++11 mode is not enabled by default on any Linux distribution, or has a 
distro already switched this default? I'm sure this would break a lot of 
third-party codes...

Herbert

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message