openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jürgen Schmidt <jogischm...@gmail.com>
Subject Re: Build error on Mac OS X 10.7 with AOO main in testtools
Date Mon, 03 Mar 2014 12:00:41 GMT
On 3/3/14 12:56 PM, Raphael Bircher wrote:
> Hi Jürgen, *
> 
> Am 03.03.2014 um 12:20 schrieb Jürgen Schmidt:
> 
>> On 3/3/14 12:06 PM, Raphael Bircher wrote:
>>> Hi Andre
>>>
>>> Am 03.03.2014 um 10:17 schrieb Andre Fischer:
>>>
>>>> On 03.03.2014 10:03, Raphael Bircher wrote:
>>>>> Hi at all.
>>>>>
>>>>> I have a build error on my Mac OS X 10.7 in testtools
>>>>>
>>>>>        /Users/nacnaub/Documents/AOO_main/main/solenv/bin/createcomponent.xslt
constructors.component
>>>>> : &&     DYLD_LIBRARY_PATH=/Users/nacnaub/Documents/AOO_main/main/solver/410/unxmaccx.pro/lib${DYLD_LIBRARY_PATH:+:${DYLD_LIBRARY_PATH}}
xsltproc --nonet --stringparam uri './cppobj.uno.dylib' -o ../../unxmaccx.pro/misc/cppobj.component
\
>>>>>        /Users/nacnaub/Documents/AOO_main/main/solenv/bin/createcomponent.xslt
cppobj.component
>>>>> : &&     DYLD_LIBRARY_PATH=/Users/nacnaub/Documents/AOO_main/main/solver/410/unxmaccx.pro/lib${DYLD_LIBRARY_PATH:+:${DYLD_LIBRARY_PATH}}
xsltproc --nonet --stringparam uri \
>>>>>        'vnd.sun.star.expand:${MY_CLASSDIR_URL}testComponent.jar' -o ../../unxmaccx.pro/misc/testComponent.component
\
>>>>>        /Users/nacnaub/Documents/AOO_main/main/solenv/bin/createcomponent.xslt
testComponent.component
>>>>> : &&     DYLD_LIBRARY_PATH=/Users/nacnaub/Documents/AOO_main/main/solver/410/unxmaccx.pro/lib${DYLD_LIBRARY_PATH:+:${DYLD_LIBRARY_PATH}}
xsltproc --nonet --stringparam prefix /Users/nacnaub/Documents/AOO_main/main/testtools/source/bridgetest/../../unxmaccx.pro/misc/
-o ../../unxmaccx.pro/lib/uno_services.rdb \
>>>>>        /Users/nacnaub/Documents/AOO_main/main/solenv/bin/packcomponents.xslt
../../unxmaccx.pro/misc/uno_services.input
>>>>> cd ../../unxmaccx.pro/lib && : &&     DYLD_LIBRARY_PATH=/Users/nacnaub/Documents/AOO_main/main/solver/410/unxmaccx.pro/lib${DYLD_LIBRARY_PATH:+:${DYLD_LIBRARY_PATH}}
/Users/nacnaub/Documents/AOO_main/main/solver/410/unxmaccx.pro/bin/uno \
>>>>> 		-ro uno_services.rdb -ro uno_types.rdb \
>>>>> 		-s com.sun.star.test.bridge.BridgeTest -- \
>>>>> 		com.sun.star.test.bridge.CppTestObject
>>>>> /bin/bash: line 1: 51041 Segmentation fault: 11  DYLD_LIBRARY_PATH=/Users/nacnaub/Documents/AOO_main/main/solver/410/unxmaccx.pro/lib${DYLD_LIBRARY_PATH:+:${DYLD_LIBRARY_PATH}}
/Users/nacnaub/Documents/AOO_main/main/solver/410/unxmaccx.pro/bin/uno -ro uno_services.rdb
-ro uno_types.rdb -s com.sun.star.test.bridge.BridgeTest -- com.sun.star.test.bridge.CppTestObject
>>>>> dmake:  Error code 139, while making 'runtest'
>>>>
>>>> Is this a reproducable problem?  It it is then rebuild cpputools (this is
where the 'uno' executable is built), deliver and try again to build testtools.
>>>
>>> cpputools was already build. but if I deleted it and rebuild it, I have had outputs
like this:
>>>
>>> clang: error: no input files
>>> clang: error: no input files
>>> Making:    all_regsingleton.dpobj
>>> : &&     DYLD_LIBRARY_PATH=/Users/nacnaub/Documents/AOO_main/main/solver/410/unxmaccx.pro/lib${DYLD_LIBRARY_PATH:+:${DYLD_LIBRARY_PATH}}
/Users/nacnaub/Documents/AOO_main/main/solver/410/unxmaccx.pro/bin/cppumaker @/var/folders/hs/4f4b588j4gsg1pl0b65n795m0000gn/T//mkfbracU
&& touch ../../unxmaccx.pro/inc/regsingleton_headergen.done
>>>
>>
>> whatever you did, you did something wrong. On my 10.7.5 system testools
>> built quite well and the brigde test succeeded.
>>
>> I suggest that you clean up your env and rebuild completely form scratch.
> 
> The build is from the scratch. If there is something wrong with Java or Python, it would
allready break in the configure step, right

configure should complain about it, yes but this error has nothing to do
with it. The uno binary failed with a segmentation fault and there seems
to be a general problem with your build and/or env.

Juergen


> 
> Raphael
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> For additional commands, e-mail: dev-help@openoffice.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message